отмена
Отображаются результаты для 
Вместо этого искать 
Вы имели в виду: 
cancel
Объявления
Community Live

675
Просмотры
5
Полезный материал
3
Ответы
djspy
Beginner

IOS to ASA site ti site vpn

С главного!

Тоннель инициируется только со стороны ASA но трафик идёт только в сторону 1921 и обратно не возвращается, счётчик пакетов растёт только на отправку

Со стороны 1921 тоннель не поднимается с ошибками

Sep 23 16:20:13.607: ISAKMP (1002): received packet from **.30.209.144 dport 500 sport 500 Global (R) QM_IDLE      
Sep 23 16:20:13.607: ISAKMP: set new node 190935522 to QM_IDLE      
Sep 23 16:20:13.607: ISAKMP:(1002): processing HASH payload. message ID = 190935522
Sep 23 16:20:13.607: ISAKMP:(1002): processing NOTIFY DPD/R_U_THERE protocol 1
        spi 0, message ID = 190935522, sa = 0x316D1F14
Sep 23 16:20:13.607: ISAKMP:(1002):deleting node 190935522 error FALSE reason "Informational (in) state 1"
Sep 23 16:20:13.607: ISAKMP:(1002):Input = IKE_MESG_FROM_PEER, IKE_INFO_NOTIFY
Sep 23 16:20:13.607: ISAKMP:(1002):Old State = IKE_P1_COMPLETE  New State = IKE_P1_COMPLETE 

Sep 23 16:20:13.607: ISAKMP:(1002):DPD/R_U_THERE received from peer **.30.209.144, sequence 0x1D9DFE04
Sep 23 16:20:13.607: ISAKMP: set new node 978487150 to QM_IDLE      
Sep 23 16:20:13.607: ISAKMP:(1002):Sending NOTIFY DPD/R_U_THERE_ACK protocol 1
        spi 677897984, message ID = 978487150
Sep 23 16:20:13.607: ISAKMP:(1002): seq. no 0x1D9DFE04
Sep 23 16:20:13.607: ISAKMP:(1002): sending packet to **.30.209.144 my_port 500 peer_port 500 (R) QM_IDLE      
Sep 23 16:20:13.607: ISAKMP:(1002):Sending an IKE IPv4 Packet.
Sep 23 16:20:13.607: ISAKMP:(1002):purging node 978487150
Sep 23 16:20:13.607: ISAKMP:(1002):Input = IKE_MESG_FROM_PEER, IKE_MESG_KEEP_ALIVE
Sep 23 16:20:13.607: ISAKMP:(1002):Old State = IKE_P1_COMPLETE  New State = IKE_P1_COMPLETE 

 ASA конфиг

ASA Version 9.1(7)16
!
hostname ASA
domain-name ap.ru
enable password Ckpec0ZP1rz47u0D encrypted
xlate per-session deny tcp any4 any4
xlate per-session deny tcp any4 any6
xlate per-session deny tcp any6 any4
xlate per-session deny tcp any6 any6
xlate per-session deny udp any4 any4 eq domain
xlate per-session deny udp any4 any6 eq domain
xlate per-session deny udp any6 any4 eq domain
xlate per-session deny udp any6 any6 eq domain
passwd 2KFQnbNIdI.2KYOU encrypted
names
ip local pool vpn-pool 192.168.10.201-192.168.10.210 mask 255.255.255.0
!
interface GigabitEthernet0/0
nameif outside
security-level 0
ip address ***.30.209.144 255.255.255.***
!
interface GigabitEthernet0/1
nameif inside
security-level 100
ip address 192.168.10.254 255.255.255.0
!
interface GigabitEthernet0/2
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
shutdown
nameif mgmt
security-level 0
no ip address
!
boot system disk0:/asa917-16-k8.bin
ftp mode passive
dns server-group DefaultDNS
domain-name vidap.ru
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object network inside-subnet
subnet 192.168.10.0 255.255.255.0
object network WIFI-subnet
subnet 192.168.11.0 255.255.255.0
object network Guest-subnet
subnet 192.168.12.0 255.255.255.0
object network wifi
object network NETWORK_OBJ_192.168.10.192_27
subnet 192.168.10.192 255.255.255.224
object network NETWORK_OBJ_192.168.10.0_24
subnet 192.168.10.0 255.255.255.0
object network NETWORK_OBJ_192.168.0.0_24
subnet 192.168.0.0 255.255.255.0
object network NETWORK_OBJ_192.168.9.0_24
subnet 192.168.9.0 255.255.255.0
object-group network DM_INLINE_NETWORK_1
network-object 192.168.11.0 255.255.255.0
network-object object WIFI-subnet
object-group network DM_INLINE_NETWORK_3
network-object object Guest-subnet
network-object object inside-subnet
object-group network DM_INLINE_NETWORK_2
network-object object NETWORK_OBJ_192.168.0.0_24
network-object object NETWORK_OBJ_192.168.9.0_24
access-list vpn-acl standard permit 192.168.10.0 255.255.255.0
access-list outside_cryptomap extended permit ip 192.168.10.0 255.255.255.0 object-group DM_INLINE_NETWORK_2
access-list global_access extended permit icmp any any
access-list global_access extended permit ip 192.168.10.0 255.255.255.0 any
pager lines 24
logging enable
logging trap debugging
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu mgmt 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-791.bin
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
nat (inside,outside) source static NETWORK_OBJ_192.168.10.0_24 NETWORK_OBJ_192.168.10.0_24 destination static NETWORK_OBJ_192.168.10.192_27 NETWORK_OBJ_192.168.10.192_27 no-proxy-arp route-lookup
nat (inside,outside) source static NETWORK_OBJ_192.168.10.0_24 NETWORK_OBJ_192.168.10.0_24 destination static NETWORK_OBJ_192.168.0.0_24 NETWORK_OBJ_192.168.0.0_24 no-proxy-arp route-lookup
nat (inside,outside) source static NETWORK_OBJ_192.168.10.0_24 NETWORK_OBJ_192.168.10.0_24 destination static NETWORK_OBJ_192.168.9.0_24 NETWORK_OBJ_192.168.9.0_24 no-proxy-arp route-lookup
nat (inside,outside) source static NETWORK_OBJ_192.168.10.0_24 NETWORK_OBJ_192.168.10.0_24 destination static DM_INLINE_NETWORK_2 DM_INLINE_NETWORK_2 no-proxy-arp route-lookup
!
object network inside-subnet
nat (inside,outside) dynamic interface
access-group global_access global
route outside 0.0.0.0 0.0.0.0 **.30.209.129 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
aaa authentication ssh console LOCAL
http server enable
http 192.168.0.0 255.255.255.255 mgmt
http 192.168.10.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANS esp-aes esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-128-MD5-TRANS esp-aes esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-192-SHA-TRANS esp-aes-192 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-192-MD5-TRANS esp-aes-192 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-256-SHA-TRANS esp-aes-256 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-256-MD5-TRANS esp-aes-256 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANS esp-3des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-3DES-MD5-TRANS esp-3des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-3DES-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-DES-SHA-TRANS esp-des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-DES-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-DES-MD5-TRANS esp-des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-DES-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-SHA esp-aes esp-sha-hmac
crypto ipsec security-association pmtu-aging infinite
crypto map outside_map2 1 match address outside_cryptomap
crypto map outside_map2 1 set peer 95.31.3.255
crypto map outside_map2 1 set ikev1 transform-set ESP-AES-SHA
crypto map outside_map2 1 set reverse-route
crypto map outside_map2 interface outside
crypto ca trustpoint ASDM_TrustPoint0
enrollment self
subject-name CN=ASA
proxy-ldc-issuer
crl configure
crypto ca trustpool policy
crypto ca certificate chain ASDM_TrustPoint0

quit
crypto ikev1 enable outside
crypto ikev1 policy 10
authentication pre-share
encryption aes-256
hash sha
group 2
lifetime 86400
crypto ikev1 policy 20
authentication rsa-sig
encryption aes-256
hash sha
group 2
lifetime 86400
crypto ikev1 policy 30
authentication pre-share
encryption aes
hash sha
group 2
lifetime 86400
crypto ikev1 policy 40
authentication pre-share
encryption aes-192
hash sha
group 2
lifetime 86400
crypto ikev1 policy 50
authentication rsa-sig
encryption aes-192
hash sha
group 2
lifetime 86400
crypto ikev1 policy 80
authentication rsa-sig
encryption aes
hash sha
group 2
lifetime 86400
crypto ikev1 policy 100
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto ikev1 policy 110
authentication rsa-sig
encryption 3des
hash sha
group 2
lifetime 86400
crypto ikev1 policy 130
authentication pre-share
encryption des
hash sha
group 2
lifetime 86400
crypto ikev1 policy 140
authentication rsa-sig
encryption des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh stricthostkeycheck
ssh 192.168.10.0 255.255.255.0 inside
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0
vpn-sessiondb max-anyconnect-premium-or-essentials-limit 250
threat-detection basic-threat
threat-detection statistics port
threat-detection statistics protocol
threat-detection statistics access-list
threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
ssl trust-point ASDM_TrustPoint0 mgmt
ssl trust-point ASDM_TrustPoint0 outside
ssl trust-point ASDM_TrustPoint0 inside
webvpn
enable outside
anyconnect-essentials
anyconnect image disk0:/anyconnect-macos-4.8.03052-webdeploy-k9.pkg 1
anyconnect image disk0:/anyconnect-win-4.8.01090-webdeploy-k9.pkg 2
anyconnect enable
tunnel-group-list enable
internal-password enable
cache
disable
group-policy DfltGrpPolicy attributes
vpn-tunnel-protocol ikev1 l2tp-ipsec ssl-clientless
group-policy GroupPolicy_SSL-VPN internal
group-policy GroupPolicy_SSL-VPN attributes
wins-server none
dns-server value 192.168.10.11
vpn-tunnel-protocol ssl-client
split-tunnel-policy tunnelspecified
split-tunnel-network-list value vpn-acl
default-domain value ap.ru
webvpn
anyconnect mtu 1406
tunnel-group DefaultL2LGroup ipsec-attributes
ikev1 pre-shared-key *****
tunnel-group SSL-VPN type remote-access
tunnel-group SSL-VPN general-attributes
address-pool vpn-pool
default-group-policy GroupPolicy_SSL-VPN
tunnel-group SSL-VPN webvpn-attributes
group-alias SSL-VPN enable
tunnel-group ***.31.3.255 type ipsec-l2l
tunnel-group ***.31.3.255 ipsec-attributes
ikev1 pre-shared-key *****
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect ip-options
inspect netbios
inspect rsh
inspect rtsp
inspect skinny
inspect esmtp
inspect sqlnet
inspect sunrpc
inspect tftp
inspect sip
inspect xdmcp
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
call-home
profile CiscoTAC-1
no active
destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
destination address email callhome@cisco.com
destination transport-method http
subscribe-to-alert-group diagnostic
subscribe-to-alert-group environment
subscribe-to-alert-group inventory periodic monthly
subscribe-to-alert-group configuration periodic monthly
subscribe-to-alert-group telemetry periodic daily
hpm topN enable

 

 

1921 конфиг

version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
no aaa new-model
no ipv6 cef
ip source-route
ip cef
ip dhcp excluded-address 192.168.0.1 192.168.0.100
!
ip dhcp pool OFFICE
 network 192.168.0.0 255.255.255.0
 default-router 192.168.0.254 
 dns-server 192.168.0.254 
!
ip domain name ap.ru
ip name-server 8.8.8.8
ip name-server 8.8.4.4
!
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
crypto isakmp policy 10
 encr aes 256
 authentication pre-share
 group 2
crypto isakmp key ******* address ***.30.209.144
!
!
crypto ipsec transform-set ESP-AES-SHA esp-aes esp-sha-hmac 
!
crypto map outside_map 10 ipsec-isakmp 
 set peer ***.30.209.144
 set transform-set ESP-AES-SHA 
 match address 110
!
!
!
!         
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 description Outside
 mac-address c46e.1f38.fd68
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
 crypto map outside_map
!
interface GigabitEthernet0/1
 description Inside
 ip address 192.168.0.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip dns server
ip dns primary ap.ru soa dc01.ap.ru hostmaster.ap.ru 21600 900 7776000 86400
ip nat inside source list 20 interface GigabitEthernet0/0 overload
ip nat inside source route-map nonat interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 95.31.0.1
!
access-list 20 permit any
access-list 110 remark VPN to kashirka traffic access-list
access-list 110 permit ip 192.168.0.0 0.0.0.255 192.168.10.0 0.0.0.255
access-list 110 permit ip 192.168.9.0 0.0.0.255 192.168.10.0 0.0.0.255
access-list 111 remark nat exeption access-list
access-list 111 deny   ip 192.168.0.0 0.0.0.255 192.168.10.0 0.0.0.255
access-list 111 deny   ip 192.168.9.0 0.0.0.255 192.168.10.0 0.0.0.255
access-list 111 permit ip 192.168.0.0 0.0.0.255 any
!
route-map nonat permit 10
 match ip address 111

 

Не могу найти в чём тут ошибка, прошу помощи сообщества!

1 УТВЕРЖДЕННОЕ РЕШЕНИЕ

Утвержденные решения

Нет, сделать вот так:

ip nat inside source route-map nonat interface GigabitEthernet0/0 overload
ip nat inside source list 20 interface GigabitEthernet0/0 overload

Вместо

ip nat inside source list 20 interface GigabitEthernet0/0 overload
ip nat inside source route-map nonat interface GigabitEthernet0/0 overload 

 

Просмотреть решение в исходном сообщении

3 ОТВЕТ 3
Sergey Lisitsin
Collaborator

Добрый день,

 

Возможно проблема в этом:

ip nat inside source list 20 interface GigabitEthernet0/0 overload
access-list 20 permit any

 Попробуйте поманять порядок Ваших NAT строк на 1921.

 

djspy
Beginner

access-list 20 permit any

Поставить его ниже типа

access-list 150 permit any

 

ip nat inside source list 150 interface GigabitEthernet0/0 overload

Нет, сделать вот так:

ip nat inside source route-map nonat interface GigabitEthernet0/0 overload
ip nat inside source list 20 interface GigabitEthernet0/0 overload

Вместо

ip nat inside source list 20 interface GigabitEthernet0/0 overload
ip nat inside source route-map nonat interface GigabitEthernet0/0 overload 

 

Просмотреть решение в исходном сообщении

Создать
Выразить признание своим коллегам
Опросы
Какой контент Вы хотели бы чаще видеть в Сообществе?
Content for Community-Ad

Сообщество Cisco

Помощь по сообществу