отмена
Отображаются результаты для 
Вместо этого искать 
Вы имели в виду: 
cancel

начальный настройки cisco router для подключение интернет

869
Просмотры
0
Полезный материал
0
Комментарии

Доброе утро коллеги,

Лабораторную я делаю на eve-ng, если кому-нибудь интересно, то сайт https://www.eve-ng.net/

В данной статье я опишу, как настроить интернет на маршрутизаторе cisco в небольшом или среднем офисе на 20-40 пользователей. 

Нам потребуется 1 маршрутизатор (cisco 1841 или 2800) и 1 коммутатор 2960 на 24 портов или 48 портов. Для теста берем 2 компьютера с разными виланами. Первый VLAN будет использоваться обычными пользователями, второй VLAN будет использоваться для бухгалтерии.

Данная схема точно работает, так как я устанавливал данные настройки и адреса, которыми я пользуюсь в данной лаборатории, вы можете использовать свои адреса. Кабель от ISP подключен к коммутатору, а через него на роуте.

Для безопасности нашей сети, мы отключаем все неиспользуемые порты на коммутаторе. В итоге мы настраиваем 3 VLAN-а:

1. вилан 101 это ISP

2. вилан 10 это staff

3. вилан 20 это Accou

Для внутренней сети я использую следующие адреса:

192.168.1.0/24 сеть для пользователей

192.168.2.0/24 сеть для бухгалтерии

топология выглядит такоетопология выглядит такое

Начинаем настройку нашего оборудования.
настройки R1:
int et0/0 - в этой интерфейсе нечего не делаем
no ip address
no ip redirect
no ip proxy-arp
no shut
!
int et0/0.101 - здесь у нас саб интерфейс для провайдера
description ISP
no ip redirect
no ip proxy-arp
encupsulation dot1Q 101
ip address 10.1.1.2 255.255.255.252
ip nat outside
no shut
int et0/1 - в этом интерфейсе нечего не делаем
no ip address
no ip redirect
no ip proxy-arp
!
no shu
int et0/1.10 - у нас саб интерфейс для внутренней сети
description staff
encupsulation dot1Q 10
ip address 192.168.1.1 255.255.255.0 - Внутренняя сеть
ip nat inside
!
int et0/1.20 - саб интерфейс для внутренней сети
description Accou
encupsulation dot1Q 20
ip address 192.168.2.1 255.255.255.0 - внутренняя сеть
ip nat inside
!
ip access-list extended FOR-NAT - делаем расширенный ACL лист
permit ip 192.168.1.0 0.0.0.255 any - разрешаем внутреннюю сеть
permit ip 192.168.2.0 0.0.0.255 any - разрешаем внутреннюю сеть
!
Добавляем nat
(FOR-NAT это имя ACL)
ip nat inside source list FOR-NAT interface0/0.101 overload
!
Затеп прописываем в сторону провайдера маршрут по умолчанию
ip route 0.0.0.0 0.0.0.0 10.1.1.1 name ISP
!
настройки коммутатора:
conf ter
hostname S1 - любой имя на ваше усмотрение
vlan 101
name ISP
vlan 10
name staf
vlan 20
name accou
int range et0/0-3 , et1/0-3
shutdown - отключаем все наши порты сначала, а затем снова включаем 
int et0/0 - порт в сторону R1 
description TO->R1
switchport trunk allowed vlan 101 - добавляем trunk для интернета
switchport trunk encupsulation dot1Q
switchport mode trunk
no shut
!
int et0/1 - порт в сторону R1 
description TO->R1
switchport trunk allowed vlan 10,20 - добавляем trunk для внутренней сети
switchport trunk encupsulation dot1Q
switchport mode trunk
no shut
!
int et0/2
switchport mode access
switchport access vlan 10
no shut
!
int et0/3
switchport mode access
switchport access vlan 20
no shut
!
int et1/3 - в данный порт у нас подключен кабель от ISP
switchport mode access
switchport access vlan 101
no shut
!
последний шаг - настройка ip адреса компьютера.

Проверяем проходят ли пакеты с помощью команды ping
пингую из компьютера 5 вилан 10
Видим, что все работает.

ведем что пинг на оба стороны работаетведем что пинг на оба стороны работает

Не удалось отобразить этот виджет.