отмена
Отображаются результаты для 
Вместо этого искать 
Вы имели в виду: 
cancel
Объявления
542
Просмотры
0
Полезный материал
3
Ответы
k.shcherbatykh
Beginner

Написание своей policy для DCNM

Коллеги, подскажите, где можно найти информацию по проблеме.

 

Дано: VXLAN фабрика на Nexus 9K, под управлением DCNM.

Внутри фабрики активно применяется route-leaking между разными L3VNI.
Сейчас, при размещении L3VNI на leaf коммутаторе, необходимые строки конфигурации добавляются через "Free form config".
Все работает.
Пример конфигурации:

 

vrf context bl-110-vrf
vni 50110
rd auto
address-family ipv4 unicast
route-target both auto
route-target both auto evpn
route-target import 10:1
route-target import 10:1 evpn
route-target export 20:1
route-target export 20:1 evpn



Проблема в том, что настройки route-target export/import должны быть одинаковыми на всех экземплярах VRF на разных коммутаторах.

Хочется добавить свою policy к DCNM, которая будет раздавать единые настройки в рамках одного VRF.

 

Как написать генерацию строк настроек в policy понятно. Язык cli template описан достаточно подробно.

 

Вопрос в том, как оформить policy таким образом, чтобы DCNM сам привязывал экземпляр policy к VRF.
Желаемое поведение должно быть похоже на поведение стандартной policy "Default_VRF_Universal".

 

Возможно ли такое сделать в рамках DCNM?
Есть ли где-то примеры написания своих policy для DCNM?

 

 

3 ОТВЕТ 3
Leonid Voronkin
VIP Collaborator

Не оно?

https://www.cisco.com/c/en/us/td/docs/switches/datacenter/sw/11_4_1/config_guide/lanfabric/b_dcnm_fabric_lan/control.html#task_h5s_jps_shb

 

________________________________________________________
Если ответ понравился, ставь звёздочку. Если ответ помог решить твою проблему, утверди его в качестве решения

Это читал, не оно. В документе описано как руками можно присоединить  policy к коммутатору, причем policy из набора, поставляемого с DCNM.

 

Хочется привязывать свою policy не к коммутатору, а к VRF, при размещении VFR на leaf коммутаторе.

 

k.shcherbatykh
Beginner

Виден свет в конце туннеля.

Задача такова:

DCNM генерирует для каждого VRF примерно следующую конфигурацию:

interface Vlan3122
  vrf member vxtest2l3
vrf context vxtest2l3
  vni 50122
  rd auto
  address-family ipv4 unicast
    route-target both auto
    route-target both auto evpn
  address-family ipv6 unicast
    route-target both auto
    route-target both auto evpn
router bgp 65100
  vrf vxtest2l3
    address-family ipv4 unicast
      advertise l2vpn evpn
      redistribute direct route-map fabric-rmap-redist-subnet
      maximum-paths ibgp 2
    address-family ipv6 unicast
      advertise l2vpn evpn
      redistribute direct route-map fabric-rmap-redist-subnet
      maximum-paths ibgp 2

Хочется для каждого VRF добавить фрагмент конфигурации для route leak и заставить DCNM добавлять эту конфигурацию на все экземпляры VRF на фабрике. В результате должно получиться примерно так:

vrf context vxtest2l3
  vni 50122
  rd auto
  address-family ipv4 unicast
    route-target both auto
    route-target both auto evpn
    route-target import 1:2
    route-target import 1:2 evpn
    route-target export 1:1
    route-target export 1:1 evpn
  address-family ipv6 unicast
    route-target both auto
    route-target both auto evpn
router bgp 65100
  vrf vxtest2l3
    address-family ipv4 unicast
      advertise l2vpn evpn
      redistribute direct route-map fabric-rmap-redist-subnet
      maximum-paths ibgp 2
    address-family ipv6 unicast
      advertise l2vpn evpn
      redistribute direct route-map fabric-rmap-redist-subnet
      maximum-paths ibgp 2

Изначально искались способы подключить свой фрагмент кода к уже существующим template через параметры template (зависимости, tag, и.т.д.). Такого способа не нашлось. Cisco указывает на единственный способ это сделать - копировать существующий template (для этого в DCNM есть специальная кнопка) и  модифицировать его под свои нужды.

 

В результате план решения таков:

Клонировать  template "Default_VRF_Universal"

Добавить в клон генерацию кода

Применить новый template к VRF

Результат предварительного макетирования

2021-03-26 11.42.49 dcnm-srv-1 0d250edf890e.jpg

Осталось аккуратно  дописать генерацию конфигурации и протестировать схему перехода для уже настроенных VRF.

Regards

 

 

 

 

Создать
Выразить признание своим коллегам
Content for Community-Ad

Помощь по сообществу