キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 
cancel
告知

CSC-campaign-v2.JPG

 

IOS-XR: SR-TE tunnel 経由での通信を行うための設定について

481
閲覧回数
0
いいね!
0
コメント

 

概要

Segment Routing 環境で SR-TE Tunnel を設定する場合、local label の割り当てのために、
以下のコンフィグをグローバルで有効にする必要があります。


(config)#segment-routing

以下では、上記コンフィグの設定有無による動作の違いを確認します。

  

ネットワーク構成

                                     MPLS(Segment Routing)/ ISIS
                                      +------- tunnel-te1 ------->
    Lo0: 1.1.1.1                                                                            Lo0: 2.2.2.2
     +---------+                                                                          +---------+
     |                 | Gi0/0/0/0                                           Gi0/0/0/0 |                 |
     |   iosxr-1   +-----------------------------------------+   iosxr-2   |
     |                 | .1                       192.168.0.0/24                    .2 |                 |
     +---------+                                                                          +---------+
Lo1: 100.100.100.100                                                           Lo1: 200.200.200.200
        (vrf TEST)                                                                               (vrf TEST)

  

segment-routing をグローバルで有効にしない場合

RP/0/0/CPU0:iosxr-1#show running-config segment-routing
Fri Nov  3 00:05:59.666 UTC
% No such configuration item(s)

RP/0/0/CPU0:iosxr-1#
RP/0/0/CPU0:iosxr-1#
RP/0/0/CPU0:iosxr-1#
RP/0/0/CPU0:iosxr-1#show mpls forwarding
Fri Nov  3 00:06:47.748 UTC
Local  Outgoing    Prefix             Outgoing     Next Hop        Bytes
Label  Label       or ID              Interface                    Switched
------ ----------- ------------------ ------------ --------------- ------------
19001  Pop         SR Pfx (idx 1)     Gi0/0/0/0    192.168.0.2     191
24000  Pop         SR Adj (idx 0)     Gi0/0/0/0    192.168.0.2     0
24001  Pop         SR Adj (idx 2)     Gi0/0/0/0    192.168.0.2     0
24002  Pop         No ID              tt1          point2point     0
24005  Aggregate   TEST: Per-VRF Aggr[V]   \
                                      TEST                         50440
RP/0/0/CPU0:iosxr-1#
RP/0/0/CPU0:iosxr-1#
RP/0/0/CPU0:iosxr-1#
RP/0/0/CPU0:iosxr-1#show cef ipv4 2.2.2.2/32
Fri Nov  3 00:07:13.506 UTC
2.2.2.2/32, version 10, labeled SR, internal 0x1000001 0x81 (ptr 0xa12edcac) [1], 0x0 (0xa12d34d0), 0xa20 (0xa1553230)
 Updated Nov  3 00:06:37.908
 Prefix Len 32, traffic index 0, precedence n/a, priority 1
 Extensions: context-label:19001
   via 2.2.2.2/32, tunnel-te1, 5 dependencies, weight 0, class 0 [flags 0x0]
    path-idx 0 NHID 0x0 [0xa162344c 0x0]
    next hop 2.2.2.2/32
    local adjacency
     labels imposed {None}                                <<<<< 対向 PE 向けのラベル付与が行えていない
RP/0/0/CPU0:iosxr-1#
RP/0/0/CPU0:iosxr-1#
RP/0/0/CPU0:iosxr-1#
RP/0/0/CPU0:iosxr-1#ping 200.200.200.200 vrf TEST
Fri Nov  3 00:07:35.335 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.200.200.200, timeout is 2 seconds:
UUUUU
Success rate is 0 percent (0/5)
RP/0/0/CPU0:iosxr-1#

 

segment-routing をグローバルで有効にした場合

RP/0/0/CPU0:iosxr-1#show running-config segment-routing
Fri Nov  3 00:35:04.472 UTC
segment-routing
!

RP/0/0/CPU0:iosxr-1#
RP/0/0/CPU0:iosxr-1#
RP/0/0/CPU0:iosxr-1#
RP/0/0/CPU0:iosxr-1#show mpls forwarding
Fri Nov  3 00:08:45.080 UTC
Local  Outgoing    Prefix             Outgoing     Next Hop        Bytes
Label  Label       or ID              Interface                    Switched
------ ----------- ------------------ ------------ --------------- ------------
19001  Pop         SR Pfx (idx 1)     Gi0/0/0/0    192.168.0.2     389
24000  Pop         SR Adj (idx 0)     Gi0/0/0/0    192.168.0.2     0
24001  Pop         SR Adj (idx 2)     Gi0/0/0/0    192.168.0.2     0
24002  Pop         No ID              tt1          point2point     0
24004  Pop         2.2.2.2/32         tt1          2.2.2.2         0
24005  Aggregate   TEST: Per-VRF Aggr[V]   \
                                      TEST                         24960
RP/0/0/CPU0:iosxr-1#
RP/0/0/CPU0:iosxr-1#
RP/0/0/CPU0:iosxr-1#
RP/0/0/CPU0:iosxr-1#show cef ipv4 2.2.2.2/32
Fri Nov  3 00:09:22.838 UTC
2.2.2.2/32, version 14, labeled SR, internal 0x1000001 0x81 (ptr 0xa12edcac) [1], 0x0 (0xa12d34d0), 0xa20 (0xa1553208)
 Updated Nov  3 00:08:10.423
 Prefix Len 32, traffic index 0, precedence n/a, priority 3
 Extensions: context-label:19001
   via 2.2.2.2/32, tunnel-te1, 5 dependencies, weight 0, class 0 [flags 0x0]
    path-idx 0 NHID 0x0 [0xa162344c 0xa1623394]
    next hop 2.2.2.2/32
    local adjacency
     local label 24004      labels imposed {ImplNull}    <<<<< 対向 PE 向けのラベルが付与された
RP/0/0/CPU0:iosxr-1#
RP/0/0/CPU0:iosxr-1#
RP/0/0/CPU0:iosxr-1#
RP/0/0/CPU0:iosxr-1#ping 200.200.200.200 vrf TEST
Fri Nov  3 00:08:51.890 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.200.200.200, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
RP/0/0/CPU0:iosxr-1#

 

補足事項

segment-routing をグローバルで有効にしなくとも、以下のコマンドでも

同様に local label の割り当てが可能です。このとき、mpls ldp 配下において

interface の指定は不要です。

(config)#mpls ldp

それぞれ設計要件等に応じて適切な方法を使用してください。

 

参考:設定例

iosxr-1

RP/0/0/CPU0:iosxr-1#show running-config
Fri Nov  3 00:50:16.579 UTC
Building configuration...
!! IOS XR Configuration 6.3.1
!! Last configuration change at Fri Nov  3 00:34:57 2017 by cisco
!
!  IOS-XR Config generated on 2017-11-02 07:39
! by autonetkit_0.23.5
hostname iosxr-1
service timestamps log datetime msec
service timestamps debug datetime msec
telnet vrf default ipv4 server max-servers 10
telnet vrf Mgmt-intf ipv4 server max-servers 10
domain name virl.info
domain lookup disable
explicit-path name to_iosxr-2
 index 1 next-address strict ipv4 unicast 2.2.2.2
!
vrf test
 address-family ipv4 unicast
  import route-target
   1:1
  !
  export route-target
   1:1
  !
 !
!
vrf Mgmt-intf
 address-family ipv4 unicast
 !
 address-family ipv6 unicast
 !
!
line template vty
 timestamp
 exec-timeout 720 0
!
line console
 exec-timeout 0 0
!
line default
 exec-timeout 720 0
!
vty-pool default 0 50
control-plane
 management-plane
  inband
   interface all
    allow all
   !
  !
 !
!
interface Loopback0
 description Loopback
 ipv4 address 1.1.1.1 255.255.255.255
!
interface Loopback1
 vrf test
 ipv4 address 100.100.100.100 255.255.255.255
!
interface tunnel-te1
 ipv4 unnumbered Loopback0
 autoroute announce
 !
 destination 2.2.2.2
 path-option 1 explicit name to_iosxr-2 segment-routing
!
interface MgmtEth0/0/CPU0/0
 description OOB Management
 ! Configured on launch
 vrf Mgmt-intf
 ipv4 address 10.255.0.74 255.255.0.0
!
interface GigabitEthernet0/0/0/0
 description to iosxrv-2
 ipv4 address 192.168.0.1 255.255.255.252
!
interface GigabitEthernet0/0/0/1
 description GigabitEthernet0/0/0/1
!
interface GigabitEthernet0/0/0/2
 description GigabitEthernet0/0/0/2
!
route-policy bgp_in
  pass
end-policy
!
route-policy bgp_out
  pass
end-policy
!
router isis 1
 net 10.1010.1111.2222.3332.00
 segment-routing global-block 19000 23999
 address-family ipv4 unicast
  metric-style wide
  mpls traffic-eng level-1
  mpls traffic-eng router-id Loopback0
  segment-routing mpls
 !
 interface Loopback0
  address-family ipv4 unicast
   prefix-sid index 2
  !
 !
 interface GigabitEthernet0/0/0/0
  point-to-point
  address-family ipv4 unicast
   fast-reroute per-prefix
   fast-reroute per-prefix ti-lfa
   metric 10
  !
 !
!
router bgp 65000
 bgp router-id 1.1.1.1
 address-family vpnv4 unicast
 !
 neighbor 2.2.2.2
  remote-as 65000
  update-source Loopback0
  address-family vpnv4 unicast
  !
 !
 vrf test
  rd 1:1
  address-family ipv4 unicast
   redistribute connected
  !
 !
!
mpls traffic-eng
 interface GigabitEthernet0/0/0/0
 !
!
segment-routing
!
end

 

iosxr-2

RP/0/0/CPU0:iosxr-2#show running-config
Fri Nov  3 00:50:50.698 UTC
Building configuration...
!! IOS XR Configuration 6.3.1
!! Last configuration change at Fri Nov  3 00:04:04 2017 by CVAC
!
!  IOS-XR Config generated on 2017-11-02 07:39
! by autonetkit_0.23.5
hostname iosxr-2
service timestamps log datetime msec
service timestamps debug datetime msec
telnet vrf default ipv4 server max-servers 10
telnet vrf Mgmt-intf ipv4 server max-servers 10
vrf test
 address-family ipv4 unicast
  import route-target
   1:1
  !
  export route-target
   1:1
  !
 !
!
vrf Mgmt-intf
 address-family ipv4 unicast
 !
 address-family ipv6 unicast
 !
!
vty-pool default 0 50
control-plane
 management-plane
  inband
   interface all
    allow all
   !
  !
 !
!
interface Loopback0
 description Loopback
 ipv4 address 2.2.2.2 255.255.255.255
!
interface Loopback1
 vrf test
 ipv4 address 200.200.200.200 255.255.255.255
!
interface MgmtEth0/0/CPU0/0
 description OOB Management
 ! Configured on launch
 vrf Mgmt-intf
 ipv4 address 10.255.0.75 255.255.0.0
!
interface GigabitEthernet0/0/0/0
 description to iosxrv-1
 ipv4 address 192.168.0.2 255.255.255.252
!
interface GigabitEthernet0/0/0/1
 description GigabitEthernet0/0/0/1
!
interface GigabitEthernet0/0/0/2
 description GigabitEthernet0/0/0/2
!
interface GigabitEthernet0/0/0/3
 description GigabitEthernet0/0/0/3
!
router isis 1
 is-type level-1
 net 10.1010.1111.2222.3331.00
 segment-routing global-block 19000 23999
 address-family ipv4 unicast
  metric-style wide
  mpls traffic-eng level-1
  mpls traffic-eng router-id Loopback0
  segment-routing mpls
 !
 interface Loopback0
  address-family ipv4 unicast
   prefix-sid index 1
  !
 !
 interface GigabitEthernet0/0/0/0
  point-to-point
  address-family ipv4 unicast
   fast-reroute per-prefix
   fast-reroute per-prefix ti-lfa
   metric 10
  !
 !
!
router bgp 65000
 bgp router-id 2.2.2.2
 address-family vpnv4 unicast
 !
 neighbor 1.1.1.1
  remote-as 65000
  update-source Loopback0
  address-family vpnv4 unicast
  !
 !
 vrf test
  rd 1:1
  address-family ipv4 unicast
   redistribute connected
  !
 !
!
mpls traffic-eng
 interface GigabitEthernet0/0/0/0
 !
!
end