キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 
cancel
1566
閲覧回数
0
いいね!
0
コメント
takasano
Cisco Employee
Cisco Employee

はじめに

このドキュメントではCisco Nexus VXLAN EVPN での vPC を用いた Multi-homing の簡単な解説や基本的な設定方法、注意点を紹介します。
本稿は「Cisco Nexus シリーズ : VXLAN EVPN Multi-homing (vPC) Part.1/2」の続きとなっています。
Part.1 をご覧になっていない方は先にそちらをご覧ください。

 

使用するトポロジー

topology.png

このトポロジーでは L3SW01 と L3SW02 は VXLAN を介して VLAN 100 のセグメント上にいます。
また、Leaf01~03 はそれぞれが同一の IP アドレス (192.168.100.254) をもつ Interface VLAN 100 もち、VLAN 100 のデフォルトゲートウェイとして機能させることもできますが、本稿では別のネットワークへの通信は行いません。
Leaf01 と Leaf02 は vPC を用いて配下の L3SW01 とのリンクを冗長化しています。


設定方法

Step3, VXLAN EVPN の設定

ここでは VXLAN でL2延伸を行い、Overlay Network の構築を行います。
VLAN と NVE 関連付け、VXLAN のパケットをカプセル化した際の送受信に用いる Source Interface として Loopback 1 を作成します。
Loopback 1 では vPC を用いた2台のVTEPを論理的に1台の VTEPとして他の VTEP に認識させるため、secondary  IP アドレスを指定します。
また、"fabric forwarding anycast-gateway-mac" コマンドと VLAN Interface 配下で "fabric forwarding mode anycast-gateway" コマンドを用いることで同一セグメント上にいるが、異なるVTEPにいる場合でもVLAN Interfaceの持つ MAC アドレスが同一になるようにします。
これにより、 vMotion などで仮想マシンが VXLAN を跨いで移動する際に新しいロケーションでデフォルトゲートウェイに ARP 要求を再度する必要が無くなります。
コンバージェンス時や障害発生時等のLeaf間での通信の迂回が必要な場合にも通信を継続するために VLAN 777 を作成し、OSPF Area 0 に参加させます。
これはNVE Infra-vlan として機能し、Leaf と Spine 間のリンクが切れると VXLAN のデータは vPC peer-link 上の VLAN 777 を通り、対になっているスイッチを経由して目的の VTEP まで転送されるようになります。
NVE Infra-vlan の詳細については「Cisco Nexus シリーズ : VXLAN EVPN "system nve infra-vlans" コマンド」をご覧ください。

Leaf01:

feature interface-vlan
feature vn-segment-vlan-based
feature nv overlay

fabric forwarding anycast-gateway-mac 2020.0000.00aa
vlan 1,100,777
vlan 100
  vn-segment 10100

interface Vlan100
  no shutdown
  ip address 192.168.100.254/24
  fabric forwarding mode anycast-gateway

interface Vlan777
  no shutdown
  ip address 192.168.12.1/24
  ip ospf network point-to-point
  ip router ospf 100 area 0.0.0.0

interface nve1
  no shutdown
  host-reachability protocol bgp
  source-interface loopback1
  member vni 10100
    ingress-replication protocol bgp

interface loopback1
  ip address 11.11.11.11/32
  ip address 11.22.11.22/32 secondary
  ip router ospf 100 area 0.0.0.0

evpn
  vni 10100 l2
    rd auto
    route-target import auto
    route-target export auto

 

Leaf02:

feature interface-vlan
feature vn-segment-vlan-based
feature nv overlay

fabric forwarding anycast-gateway-mac 2020.0000.00aa
vlan 1,100,777
vlan 100
  vn-segment 10100

interface Vlan100
  no shutdown
  ip address 192.168.100.254/24
  fabric forwarding mode anycast-gateway

interface Vlan777
  no shutdown
  ip address 192.168.12.2/24
  ip ospf network point-to-point
  ip router ospf 100 area 0.0.0.0

interface nve1
  no shutdown
  host-reachability protocol bgp
  source-interface loopback1
  member vni 10100
    ingress-replication protocol bgp

interface loopback1
  ip address 22.22.22.22/32
  ip address 11.22.11.22/32 secondary
  ip router ospf 100 area 0.0.0.0

evpn
  vni 10100 l2
    rd auto
    route-target import auto
    route-target export auto

 

Leaf03:

feature interface-vlan
feature vn-segment-vlan-based
feature nv overlay

fabric forwarding anycast-gateway-mac 2020.0000.00aa vlan 1,100 vlan 100 vn-segment 10100 interface Vlan100 no shutdown ip address 192.168.100.254/24 fabric forwarding mode anycast-gateway interface nve1 no shutdown host-reachability protocol bgp source-interface loopback1 member vni 10100 ingress-replication protocol bgp interface loopback1 ip address 33.33.33.33/32 ip router ospf 100 area 0.0.0.0 evpn vni 10100 l2 rd auto route-target import auto route-target export auto

 

Step4, ホスト向け Interface の設定

各スイッチに接続されるホスト向けの Interface を設定するために vPC 等の設定を行います。
このため、下記 Config を各スイッチに投入しました。

Leaf01:

feature lacp
feature vpc

vpc domain 1
  peer-keepalive destination 10.0.0.2 source 10.0.0.1

interface port-channel1
  switchport
  switchport access vlan 100
  vpc 1

interface port-channel10
  switchport
  switchport mode trunk
  spanning-tree port type network
  vpc peer-link

interface Ethernet1/1
  switchport
  switchport mode trunk
  channel-group 10 mode active
  no shutdown

interface Ethernet1/2
  switchport
  switchport mode trunk
  channel-group 10 mode active

interface Ethernet1/7
  switchport
  switchport access vlan 100
  channel-group 1 mode active
  no shutdown

interface mgmt0
  vrf member management
  ip address 10.0.0.1/24

 

Leaf02:

feature lacp
feature vpc

vpc domain 1
  peer-keepalive destination 10.0.0.1 source 10.0.0.2

interface port-channel1
  switchport
  switchport access vlan 100
  vpc 1

interface port-channel10
  switchport
  switchport mode trunk
  spanning-tree port type network
  vpc peer-link

interface Ethernet1/1
  switchport
  switchport mode trunk
  channel-group 10 mode active
  no shutdown

interface Ethernet1/2
  switchport
  switchport mode trunk
  channel-group 10 mode active
  no shutdown

interface Ethernet1/9
  switchport
  switchport access vlan 100
  channel-group 1 mode active
  no shutdown

interface mgmt0
  vrf member management
  ip address 10.0.0.2/24

 

Leaf03:

interface Ethernet1/7
  switchport
  switchport access vlan 100
  no shutdown

 

Step5, "system nve infra-vlans" コマンド

Nexus 9300 シリーズの型番が EX、FX、及び FX2 で終わるものについては NVE Infra-vlan を有効化するために "system nve infra-vlans" コマンドの投入が必要になります。
本コマンドの詳細は「Configure System nve infra-vlans in VXLAN BGP EVPN on Cisco Nexus 9000 Switches」をご覧ください。
ここで Leaf に用いている製品では投入が必要です。
そのため、下記 Config を投入しました。

Leaf01, Leaf02:

system nve infra-vlans 777

以上で設定は終了です。

結果確認

ここではLeafが経路の学習状況やそれぞれの Mac Address table、Routing Tableの状況を確認します。
下記結果から確かに対向の VTEP や VXLAN を越えた先にあるホストを学習していることが分かります。

Leaf01(config)# sh bgp l2evpvpn evpn
BGP routing table information for VRF default, address family L2VPN EVPN
BGP table version is 69, Local Router ID is 1.1.1.1
Status: s-suppressed, x-deleted, S-stale, d-dampened, h-history, *-valid, >-best
Path type: i-internal, e-external, c-confed, l-local, a-aggregate, r-redist, I-injected
Origin codes: i - IGP, e - EGP, ? - incomplete, | - multipath, & - backup, 2 - best2

   Network            Next Hop            Metric     LocPrf     Weight Path
Route Distinguisher: 1.1.1.1:32867    (L2VNI 10100)
*>i[2]:[0]:[0]:[48]:[ac7a.5645.2187]:[0]:[0.0.0.0]/216
                      33.33.33.33                       100          0 i
*>l[2]:[0]:[0]:[48]:[ac7a.568f.3c77]:[0]:[0.0.0.0]/216
                      11.22.11.22                       100      32768 i
*>i[2]:[0]:[0]:[48]:[ac7a.5645.2187]:[32]:[192.168.100.2]/248
                      33.33.33.33                       100          0 i
*>l[2]:[0]:[0]:[48]:[ac7a.568f.3c77]:[32]:[192.168.100.1]/248
                      11.22.11.22                       100      32768 i
*>l[3]:[0]:[32]:[11.22.11.22]/88
                      11.22.11.22                       100      32768 i
*>i[3]:[0]:[32]:[33.33.33.33]/88
                      33.33.33.33                       100          0 i

Route Distinguisher: 3.3.3.3:32867
*>i[2]:[0]:[0]:[48]:[ac7a.5645.2187]:[0]:[0.0.0.0]/216
                      33.33.33.33                       100          0 i
*>i[2]:[0]:[0]:[48]:[ac7a.5645.2187]:[32]:[192.168.100.2]/248
                      33.33.33.33                       100          0 i
*>i[3]:[0]:[32]:[33.33.33.33]/88
                      33.33.33.33                       100          0 i

Leaf01(config)# show mac address-table
Legend: 
        * - primary entry, G - Gateway MAC, (R) - Routed MAC, O - Overlay MAC
        age - seconds since last seen,+ - primary entry using vPC Peer-Link,
        (T) - True, (F) - False, C - ControlPlane MAC, ~ - vsan
   VLAN     MAC Address      Type      age     Secure NTFY Ports
---------+-----------------+--------+---------+------+----+------------------
C  100     ac7a.5645.2187   dynamic  0         F      F    nve1(33.33.33.33)
*  100     ac7a.568f.3c77   dynamic  0         F      F    Po1
G    -     2020.0000.00aa   static   -         F      F    sup-eth1(R)
*  777     ac7a.565a.f527   static   -         F      F    vPC Peer-Link(R)
*  100     ac7a.565a.f527   static   -         F      F    vPC Peer-Link(R)
G    -     ac7a.565a.f587   static   -         F      F    sup-eth1(R)
G  777     ac7a.565a.f587   static   -         F      F    sup-eth1(R)
G  100     ac7a.565a.f587   static   -         F      F    sup-eth1(R)
Leaf01(config)# sh ip route
IP Route Table for VRF "default"
'*' denotes best ucast next-hop
'**' denotes best mcast next-hop
'[x/y]' denotes [preference/metric]
'%<string>' in via output denotes VRF <string>

1.1.1.1/32, ubest/mbest: 2/0, attached
    *via 1.1.1.1, Lo0, [0/0], 01:14:19, local
    *via 1.1.1.1, Lo0, [0/0], 01:14:19, direct
2.2.2.2/32, ubest/mbest: 1/0
    *via 192.168.10.1, Eth1/49, [110/3], 00:04:12, ospf-100, intra
3.3.3.3/32, ubest/mbest: 1/0
    *via 192.168.10.1, Eth1/49, [110/3], 00:04:12, ospf-100, intra
10.10.10.10/32, ubest/mbest: 1/0
    *via 192.168.10.1, Eth1/49, [110/2], 00:04:12, ospf-100, intra
11.11.11.11/32, ubest/mbest: 2/0, attached
    *via 11.11.11.11, Lo1, [0/0], 01:07:28, local
    *via 11.11.11.11, Lo1, [0/0], 01:07:28, direct
11.22.11.22/32, ubest/mbest: 2/0, attached
    *via 11.22.11.22, Lo1, [0/0], 01:07:28, local
    *via 11.22.11.22, Lo1, [0/0], 01:07:28, direct
22.22.22.22/32, ubest/mbest: 1/0
    *via 192.168.10.1, Eth1/49, [110/3], 00:04:12, ospf-100, intra
33.33.33.33/32, ubest/mbest: 1/0
    *via 192.168.10.1, Eth1/49, [110/3], 00:04:12, ospf-100, intra
192.168.10.0/24, ubest/mbest: 1/0, attached
    *via 192.168.10.2, Eth1/49, [0/0], 00:04:18, direct
192.168.10.2/32, ubest/mbest: 1/0, attached
    *via 192.168.10.2, Eth1/49, [0/0], 00:04:18, local
192.168.12.0/24, ubest/mbest: 1/0, attached
    *via 192.168.12.1, Vlan777, [0/0], 01:10:27, direct
192.168.12.1/32, ubest/mbest: 1/0, attached
    *via 192.168.12.1, Vlan777, [0/0], 01:10:27, local
192.168.20.0/24, ubest/mbest: 1/0
    *via 192.168.10.1, Eth1/49, [110/2], 00:04:12, ospf-100, intra
192.168.30.0/24, ubest/mbest: 1/0
    *via 192.168.10.1, Eth1/49, [110/2], 00:04:12, ospf-100, intra
192.168.100.0/24, ubest/mbest: 1/0, attached
    *via 192.168.100.254, Vlan100, [0/0], 01:15:29, direct
192.168.100.1/32, ubest/mbest: 1/0, attached
    *via 192.168.100.1, Vlan100, [190/0], 01:09:41, hmm
192.168.100.254/32, ubest/mbest: 1/0, attached
    *via 192.168.100.254, Vlan100, [0/0], 01:15:29, local

Leaf02(config)# sh bgp l2evpvpn evpn
BGP routing table information for VRF default, address family L2VPN EVPN
BGP table version is 34, Local Router ID is 2.2.2.2
Status: s-suppressed, x-deleted, S-stale, d-dampened, h-history, *-valid, >-best
Path type: i-internal, e-external, c-confed, l-local, a-aggregate, r-redist, I-injected
Origin codes: i - IGP, e - EGP, ? - incomplete, | - multipath, & - backup, 2 - best2

   Network            Next Hop            Metric     LocPrf     Weight Path
Route Distinguisher: 2.2.2.2:32867    (L2VNI 10100)
*>i[2]:[0]:[0]:[48]:[ac7a.5645.2187]:[0]:[0.0.0.0]/216
                      33.33.33.33                       100          0 i
*>l[2]:[0]:[0]:[48]:[ac7a.568f.3c77]:[0]:[0.0.0.0]/216
                      11.22.11.22                       100      32768 i
*>i[2]:[0]:[0]:[48]:[ac7a.5645.2187]:[32]:[192.168.100.2]/248
                      33.33.33.33                       100          0 i
*>l[2]:[0]:[0]:[48]:[ac7a.568f.3c77]:[32]:[192.168.100.1]/248
                      11.22.11.22                       100      32768 i
*>l[3]:[0]:[32]:[11.22.11.22]/88
                      11.22.11.22                       100      32768 i
*>i[3]:[0]:[32]:[33.33.33.33]/88
                      33.33.33.33                       100          0 i

Route Distinguisher: 3.3.3.3:32867
*>i[2]:[0]:[0]:[48]:[ac7a.5645.2187]:[0]:[0.0.0.0]/216
                      33.33.33.33                       100          0 i
*>i[2]:[0]:[0]:[48]:[ac7a.5645.2187]:[32]:[192.168.100.2]/248
                      33.33.33.33                       100          0 i
*>i[3]:[0]:[32]:[33.33.33.33]/88
                      33.33.33.33                       100          0 i

Leaf02(config)# show mac address-table
Legend: 
        * - primary entry, G - Gateway MAC, (R) - Routed MAC, O - Overlay MAC
        age - seconds since last seen,+ - primary entry using vPC Peer-Link,
        (T) - True, (F) - False, C - ControlPlane MAC, ~ - vsan
   VLAN     MAC Address      Type      age     Secure NTFY Ports
---------+-----------------+--------+---------+------+----+------------------
C  100     ac7a.5645.2187   dynamic  0         F      F    nve1(33.33.33.33)
+  100     ac7a.568f.3c77   dynamic  0         F      F    Po1
G    -     2020.0000.00aa   static   -         F      F    sup-eth1(R)
G    -     ac7a.565a.f527   static   -         F      F    sup-eth1(R)
G  777     ac7a.565a.f527   static   -         F      F    sup-eth1(R)
G  100     ac7a.565a.f527   static   -         F      F    sup-eth1(R)
*  777     ac7a.565a.f587   static   -         F      F    vPC Peer-Link(R)
*  100     ac7a.565a.f587   static   -         F      F    vPC Peer-Link(R)
Leaf02(config)# sh ipr route
IP Route Table for VRF "default"
'*' denotes best ucast next-hop
'**' denotes best mcast next-hop
'[x/y]' denotes [preference/metric]
'%<string>' in via output denotes VRF <string>

1.1.1.1/32, ubest/mbest: 1/0
    *via 192.168.20.1, Eth1/51, [110/3], 00:04:13, ospf-100, intra
2.2.2.2/32, ubest/mbest: 2/0, attached
    *via 2.2.2.2, Lo0, [0/0], 01:10:13, local
    *via 2.2.2.2, Lo0, [0/0], 01:10:13, direct
3.3.3.3/32, ubest/mbest: 1/0
    *via 192.168.20.1, Eth1/51, [110/3], 00:12:27, ospf-100, intra
10.10.10.10/32, ubest/mbest: 1/0
    *via 192.168.20.1, Eth1/51, [110/2], 00:12:27, ospf-100, intra
11.11.11.11/32, ubest/mbest: 1/0
    *via 192.168.20.1, Eth1/51, [110/3], 00:04:13, ospf-100, intra
11.22.11.22/32, ubest/mbest: 2/0, attached
    *via 11.22.11.22, Lo1, [0/0], 01:07:13, local
    *via 11.22.11.22, Lo1, [0/0], 01:07:13, direct
22.22.22.22/32, ubest/mbest: 2/0, attached
    *via 22.22.22.22, Lo1, [0/0], 01:07:13, local
    *via 22.22.22.22, Lo1, [0/0], 01:07:13, direct
33.33.33.33/32, ubest/mbest: 1/0
    *via 192.168.20.1, Eth1/51, [110/3], 00:12:27, ospf-100, intra
192.168.10.0/24, ubest/mbest: 1/0
    *via 192.168.20.1, Eth1/51, [110/2], 00:04:18, ospf-100, intra
192.168.12.0/24, ubest/mbest: 1/0, attached
    *via 192.168.12.2, Vlan777, [0/0], 01:10:27, direct
192.168.12.2/32, ubest/mbest: 1/0, attached
    *via 192.168.12.2, Vlan777, [0/0], 01:10:27, local
192.168.20.0/24, ubest/mbest: 1/0, attached
    *via 192.168.20.2, Eth1/51, [0/0], 00:12:43, direct
192.168.20.2/32, ubest/mbest: 1/0, attached
    *via 192.168.20.2, Eth1/51, [0/0], 00:12:43, local
192.168.30.0/24, ubest/mbest: 1/0
    *via 192.168.20.1, Eth1/51, [110/2], 00:12:27, ospf-100, intra
192.168.100.0/24, ubest/mbest: 1/0, attached
    *via 192.168.100.254, Vlan100, [0/0], 01:11:40, direct
192.168.100.1/32, ubest/mbest: 1/0, attached
    *via 192.168.100.1, Vlan100, [190/0], 01:09:41, hmm
192.168.100.254/32, ubest/mbest: 1/0, attached
    *via 192.168.100.254, Vlan100, [0/0], 01:11:40, local

Leaf03(config)# sh bgp l2vpn evpn
BGP routing table information for VRF default, address family L2VPN EVPN
BGP table version is 93, Local Router ID is 3.3.3.3
Status: s-suppressed, x-deleted, S-stale, d-dampened, h-history, *-valid, >-best
Path type: i-internal, e-external, c-confed, l-local, a-aggregate, r-redist, I-injected
Origin codes: i - IGP, e - EGP, ? - incomplete, | - multipath, & - backup, 2 - best2

   Network            Next Hop            Metric     LocPrf     Weight Path
Route Distinguisher: 1.1.1.1:32867
*>i[2]:[0]:[0]:[48]:[ac7a.568f.3c77]:[0]:[0.0.0.0]/216
                      11.22.11.22                       100          0 i
*>i[2]:[0]:[0]:[48]:[ac7a.568f.3c77]:[32]:[192.168.100.1]/248
                      11.22.11.22                       100          0 i
*>i[3]:[0]:[32]:[11.22.11.22]/88
                      11.22.11.22                       100          0 i

Route Distinguisher: 2.2.2.2:32867
*>i[2]:[0]:[0]:[48]:[ac7a.568f.3c77]:[0]:[0.0.0.0]/216
                      11.22.11.22                       100          0 i
*>i[2]:[0]:[0]:[48]:[ac7a.568f.3c77]:[32]:[192.168.100.1]/248
                      11.22.11.22                       100          0 i
*>i[3]:[0]:[32]:[11.22.11.22]/88
                      11.22.11.22                       100          0 i

Route Distinguisher: 3.3.3.3:32867    (L2VNI 10100)
*>l[2]:[0]:[0]:[48]:[ac7a.5645.2187]:[0]:[0.0.0.0]/216
                      33.33.33.33                       100      32768 i
* i[2]:[0]:[0]:[48]:[ac7a.568f.3c77]:[0]:[0.0.0.0]/216
                      11.22.11.22                       100          0 i
*>i                   11.22.11.22                       100          0 i
*>l[2]:[0]:[0]:[48]:[ac7a.5645.2187]:[32]:[192.168.100.2]/248
                      33.33.33.33                       100      32768 i
*>i[2]:[0]:[0]:[48]:[ac7a.568f.3c77]:[32]:[192.168.100.1]/248
                      11.22.11.22                       100          0 i
* i                   11.22.11.22                       100          0 i
*>i[3]:[0]:[32]:[11.22.11.22]/88
                      11.22.11.22                       100          0 i
* i                   11.22.11.22                       100          0 i
*>l[3]:[0]:[32]:[33.33.33.33]/88
                      33.33.33.33                       100      32768 i

Leaf03(config)# Leaf03(config)# sh mac address-table
Legend: 
        * - primary entry, G - Gateway MAC, (R) - Routed MAC, O - Overlay MAC
        age - seconds since last seen,+ - primary entry using vPC Peer-Link,
        (T) - True, (F) - False, C - ControlPlane MAC, ~ - vsan
   VLAN     MAC Address      Type      age     Secure NTFY Ports
---------+-----------------+--------+---------+------+----+------------------
*  100     ac7a.5645.2187   dynamic  0         F      F    Eth1/7
C  100     ac7a.568f.3c77   dynamic  0         F      F    nve1(11.22.11.22)
G    -     2020.0000.00aa   static   -         F      F    sup-eth1(R)
G    -     ac7a.565a.9ee7   static   -         F      F    sup-eth1(R)
G  100     ac7a.565a.9ee7   static   -         F      F    sup-eth1(R)
Leaf03(config)# sh ip route
IP Route Table for VRF "default"
'*' denotes best ucast next-hop
'**' denotes best mcast next-hop
'[x/y]' denotes [preference/metric]
'%<string>' in via output denotes VRF <string>

1.1.1.1/32, ubest/mbest: 1/0
    *via 192.168.30.1, Eth1/49, [110/3], 02:43:30, ospf-100, intra
2.2.2.2/32, ubest/mbest: 1/0
    *via 192.168.30.1, Eth1/49, [110/3], 02:59:15, ospf-100, intra
3.3.3.3/32, ubest/mbest: 2/0, attached
    *via 3.3.3.3, Lo0, [0/0], 05:07:28, local
    *via 3.3.3.3, Lo0, [0/0], 05:07:28, direct
10.10.10.10/32, ubest/mbest: 1/0
    *via 192.168.30.1, Eth1/49, [110/2], 05:04:45, ospf-100, intra
11.11.11.11/32, ubest/mbest: 1/0
    *via 192.168.30.1, Eth1/49, [110/3], 02:43:30, ospf-100, intra
11.22.11.22/32, ubest/mbest: 1/0
    *via 192.168.30.1, Eth1/49, [110/3], 03:54:15, ospf-100, intra
22.22.22.22/32, ubest/mbest: 1/0
    *via 192.168.30.1, Eth1/49, [110/3], 02:59:15, ospf-100, intra
33.33.33.33/32, ubest/mbest: 2/0, attached
    *via 33.33.33.33, Lo1, [0/0], 05:07:29, local
    *via 33.33.33.33, Lo1, [0/0], 05:07:29, direct
192.168.10.0/24, ubest/mbest: 1/0
    *via 192.168.30.1, Eth1/49, [110/2], 02:43:45, ospf-100, intra
192.168.12.0/24, ubest/mbest: 1/0
    *via 192.168.30.1, Eth1/49, [110/42], 03:57:14, ospf-100, intra
192.168.20.0/24, ubest/mbest: 1/0
    *via 192.168.30.1, Eth1/49, [110/2], 02:59:30, ospf-100, intra
192.168.30.0/24, ubest/mbest: 1/0, attached
    *via 192.168.30.2, Eth1/49, [0/0], 05:05:02, direct
192.168.30.2/32, ubest/mbest: 1/0, attached
    *via 192.168.30.2, Eth1/49, [0/0], 05:05:02, local
192.168.100.0/24, ubest/mbest: 1/0, attached
    *via 192.168.100.254, Vlan100, [0/0], 05:07:29, direct
192.168.100.2/32, ubest/mbest: 1/0, attached
    *via 192.168.100.2, Vlan100, [190/0], 05:06:08, hmm
192.168.100.254/32, ubest/mbest: 1/0, attached
    *via 192.168.100.254, Vlan100, [0/0], 05:07:29, local

 

本構成の冗長性

ここでは連続して ping を L3SW01 から L3SW02 に送りながら、一斉に下図のようにリンクを Down させます。

failure.png

すると、次のような結果となり、失敗した ping はありません。

L3SW01(config)# ping 192.168.100.2 count 500
PING 192.168.100.2 (192.168.100.2): 56 data bytes
64 bytes from 192.168.100.2: icmp_seq=0 ttl=254 time=1.11 ms
64 bytes from 192.168.100.2: icmp_seq=1 ttl=254 time=0.678 ms
64 bytes from 192.168.100.2: icmp_seq=2 ttl=254 time=0.62 ms
...
64 bytes from 192.168.100.2: icmp_seq=497 ttl=254 time=0.631 ms
64 bytes from 192.168.100.2: icmp_seq=498 ttl=254 time=0.628 ms
64 bytes from 192.168.100.2: icmp_seq=499 ttl=254 time=0.63 ms

--- 192.168.100.2 ping statistics ---
500 packets transmitted, 500 packets received, 0.00% packet loss
round-trip min/avg/max = 0.558/0.651/1.224 ms

このように本構成は障害に対する冗長性をもっています。

First Hop Gateway (FHG) の冗長化について

本稿で触れたvPCによる VXLAN Multi-homingは FHG の冗長化に有効です。
これまでのネットワークではゲートウェイの冗長化のために通常、HSRP や VRRP、GLBP 等の First Hop Redundancy Protocol (FHRP) を利用してきました。
しかし、「VXLAN EVPN Multi-Site Design and Deployment White Paper」の Legacy site integration の節には " The co-existence of these different first-hop gateway approaches is not supported today" 及び "the BGW is allowed to operate in a vPC domain and to offer the first-hop gateway functions (in this case, DAG)." とあり、VXLAN と FHRP の共存はサポートされておらず、代わりにこの用途では Anycast gateway と vPC を使うことを紹介しています。
そのため、FHG の冗長化を行う際には FHRP使わず、本稿のようにvPC にてリンクを構成し  VLAN Interface を FHG として利用することを検討してください。
"fabric forwarding anycast-gateway-mac" 及び  "fabric forwarding mode anycast-gateway" を使うことで各 FHG が同一の MAC アドレスを持つことも可能で、仮想マシンを異なる VTEP にある同一のセグメント間に移動させた際の ARP 要求を再度行うことも必要としません。

関連コンテンツ

Nexus スイッチ (NX-OS) : 設定例
Cisco Nexus シリーズ : VXLAN EVPN 基本設定
Cisco Nexus シリーズ : VXLAN EVPN L3VNI 基本設定
Cisco Nexus vPCとは
Cisco Nexus シリーズ : VXLAN EVPN Multi-homing (vPC) Part.1/2
Cisco Nexus シリーズ : VXLAN EVPN "system nve infra-vlans" コマンド

参考情報

Configuration Guide : Configuring VXLAN BGP EVPN

Getting Started

検索バーにキーワード、フレーズ、または質問を入力し、お探しのものを見つけましょう

シスコ コミュニティをいち早く使いこなしていただけるよう役立つリンクをまとめました。みなさんのジャーニーがより良いものとなるようお手伝いします