キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 
cancel
16432
閲覧回数
53
いいね!
5
コメント
Hiroto Kowata
Cisco Employee
Cisco Employee

以下の構成を想定したPPPoEクライアントの設定例になります。サーバの設定はISPでよく見られるものです。

[Client]Fa0/0-------------------Fa0/0[Server]

設定の趣旨は以下のようにまとめられます。

  1. 認証はCHAP/PAPを使用(username:cisco, password:sisco)
  2. サーバがクライアントを認証
  3. クライアントのIPアドレスはIPCPでネゴシエート

クライアントの設定は以下の通りです。

interface FastEthernet0/0

no ip address

ip tcp adjust-mss 1452

duplex auto

speed auto

pppoe enable

pppoe-client dial-pool-number 1

!

interface Dialer1

ip address negotiated

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication pap chap callin

ppp pap sent-username cisco password sisco

ppp chap hostname cisco

ppp chap password sisco

!

ip route 0.0.0.0 0.0.0.0 Dialer1

サーバの設定例は以下の通りです。

username cisco password sisco

!

bba-group pppoe global

virtual-template 1

!

interface FastEthernet0/0

ip address 10.252.102.49 255.255.255.240

duplex auto

speed auto

pppoe enable group global

!

interface Virtual-Template1

mtu 1492

ip unnumbered FastEthernet0/0

peer default ip address pool pppoepool

ppp authentication pap chap

!

ip local pool pppoepool 10.10.10.1 10.10.10.200

この設定でのフローは以下のようにまとめることが出来ます。

  1. PADo, PADi, PADrを使用してサーバ、クライアントは共にLCPフェーズに移行する
  2. 認証、その他のパラメータのネゴシエーションを行う
  3. サーバはユーザ名、パスワードをクライアントに問い合わせる(PAPが最初に使われる)
  4. クライアントはDialerインターフェイスに設定されているユーザ名、パスワードをサーバに送る
  5. サーバは自身に設定されたリストを参照し認証を行う
  6. クライアント、サーバ共にIPCPフェーズへ移行する
  7. クライアントは0.0.0.0を送りサーバに対してIPアドレスを要求する
  8. サーバはIPプールからクライアントにIPアドレスを割り当てる
  9. クライアント、サーバはネゴシエーションを完了しIP通信が出来るようになる
コメント
watanabe.m
Beginner
Beginner

PPPoE Client側の設定にて、Interface Dialerに"dialer-group 1"の設定は不要ではないでしょうか。

PPPoE Client側でDial on Demand PPPoEとする場合に必要となるパラメータであると考えております。

Hiroto Kowata
Cisco Employee
Cisco Employee

コメントありがとうございます。ご指摘の通りですね。

ちなみにDial on Demand PPPoEとする場合はdialer-group 1を削除せずにdialer-list 1 protocol ip permitなどを追加する必要があります。

tashiina
Cisco Employee
Cisco Employee

interface Dialer1 にも mtu 1492 があったほうがいいです。デフォルトだとLCPのネゴシエーションでMRU 1500で行こうとしてしまいますから。下のURLの設定例ではip mtuになってますが、ip mtuだとMRUがデフォルトのままになるので、mtuコマンドのほうがいいですね。

http://www.cisco.com/JP/support/partner/loc/tac/107/1074940/router_crb.shtml

mhiyoshi
Participant
Participant

PPPoEでdialer-watchとの連携は可能でしょうか?

例えば、上記PPPoEクライアントの設定に以下のコンフィグを変更・追加を行って

通常はIPの通信ができる状態にしてOSPFの経路のdialer watchを行い経路が

消失した際にPPPoEのセッションを確立させる動作を実現できないかと考えております。

interface FastEthernet0/0
ip address 任意のアドレス
 *対向とIP通信可能にしてOSPFで"2.2.2.2"の経路を配信
pppoe-client dial-pool-number 1 dial-on-demand
!
dialer watch-list 1 ip 2.2.2.2 255.255.255.255
dialer watch-list 1 delay connect 10
!
interface Dialer1
dialer watch-group 1

!
router ospf 1

network *対向とネイバーを確立させるアドレス

watanabe.m
Beginner
Beginner

かなり遅レスですが、dialer watchを使わなくともfloating staticで良いのではないかと思います。

私がうまく要件を理解できていないだけかもしれません。。。

Getting Started

検索バーにキーワード、フレーズ、または質問を入力し、お探しのものを見つけましょう

シスコ コミュニティをいち早く使いこなしていただけるよう役立つリンクをまとめました。みなさんのジャーニーがより良いものとなるようお手伝いします:



推薦したいメンバーがいます