取消
显示结果 
搜索替代 
您的意思是: 
cancel
4374
查看次数
0
有帮助
12
回复

关于思科2960交换机DHCP无法显示IP地址及mac地址

xixideng61446
Beginner
Beginner
2960交换机远程就是dhcp中无法显示IP 地址及mac,全局配置也做了ip dhcp snooping,端口聚合也配了 ip dhcp snooping trust,端口是状态是正常的,端口接的电脑也正常获取IP地址,配置如下,请各位大佬帮帮我。
#sho run
Building configuration...
Current configuration : 12640 bytes
!
! Last configuration change at 11:53:11 GMT Thu Nov 26 2020 by sheng1_deng
! NVRAM config last updated at 15:02:30 GMT Wed Nov 25 2020 by sheng1_deng
!
version 15.0
no service pad
service timestamps debug datetime localtime
service timestamps log datetime localtime show-timezone
service password-encryption
!
hostname
!
boot-start-marker
boot-end-marker
!
logging buffered 40960
enable secret 5 $1$kKL0$pv31fuOPoflWFIy2KUmqv.
!
username admin password 7 0718204A4B1B48574446
aaa new-model
!
!
aaa group server tacacs+ MAINTEK_LOGIN_ACS
server 10.162.244.211
server 10.162.244.212
!
aaa authentication fail-message ^C
******** Authentication failed ********
If you have connected to this system by mistake, disconnect NOW.
Warning: All of the activities will be monitored and logged.
^C
aaa authentication login default group MAINTEK_LOGIN_ACS local
aaa authentication login LOGIN_CONSOLE_FREE none
aaa authorization config-commands
aaa authorization exec default group MAINTEK_LOGIN_ACS none
aaa authorization exec EXEC_CONSOLE_FREE none
aaa authorization commands 3 default group MAINTEK_LOGIN_ACS none
aaa authorization commands 3 COMMAND_CONSOLE_FREE none
aaa authorization commands 15 default group MAINTEK_LOGIN_ACS none
aaa authorization commands 15 COMMAND_CONSOLE_FREE none
aaa accounting commands 1 default start-stop group MAINTEK_LOGIN_ACS
aaa accounting commands 15 default start-stop group MAINTEK_LOGIN_ACS
!
!
!
!
!
!
aaa session-id common
clock timezone GMT 8 0
system mtu routing 1500
vtp mode transparent
!
!
ip dhcp snooping
no ip domain-lookup
!
!
crypto pki trustpoint TP-self-signed-2881924608
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2881924608
revocation-check none
rsakeypair TP-self-signed-2881924608
!
!
crypto pki certificate chain TP-self-signed-2881924608
certificate self-signed 01
3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 32383831 39323436 3038301E 170D3933 30333031 30303030
35395A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 38383139
32343630 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100C07D 692C80B2 FB0B1549 B2D17CDA 7482AFF5 957E211D 61D83D28 7A1EBF3D
988D59BF 9A12E0C9 069CE79F FC4ECF71 D1F545A0 C8928022 9279B671 6A50D30C
BCF1295E 3E6CBA14 2D70222C 99393F42 7B1963DC 4545477C 5D49CD69 0BCB2784
2F050054 4948F253 4BACEB11 B12BBB68 01890A6F C3F3019A D807F860 B3232D2E
BD350203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
551D2304 18301680 141A54F7 222187F3 8C4014F9 E7D54CAA DA478394 73301D06
03551D0E 04160414 1A54F722 2187F38C 4014F9E7 D54CAADA 47839473 300D0609
2A864886 F70D0101 05050003 81810002 B39D560E 70623E63 3E97D7DD A30A85B4
6EBD9CCB 1537042D 95C9905E 90A28B3E DB4E84B6 D55E3AAA 057B510A C7BFD3C4
08D302AF F2AAFCBB EF2BEBB6 E1F71546 A0539F41 0DE7A466 CE46F386 A6F67F39
521535AA 86C3EAA3 BE8FD41F 057D481F 592C2D85 4EA51C8B 24DBF06C 523298E4
E897683D 7FD16633 D10EFD5F 115448
quit
!
!
!
!
!
no errdisable detect cause link-flap
errdisable recovery cause udld
errdisable recovery cause bpduguard
errdisable recovery cause security-violation
errdisable recovery cause channel-misconfig (STP)
errdisable recovery cause pagp-flap
errdisable recovery cause dtp-flap
errdisable recovery cause link-flap
errdisable recovery cause sfp-config-mismatch
errdisable recovery cause gbic-invalid
errdisable recovery cause psecure-violation
errdisable recovery cause port-mode-failure
errdisable recovery cause dhcp-rate-limit
errdisable recovery cause pppoe-ia-rate-limit
errdisable recovery cause mac-limit
errdisable recovery cause vmps
errdisable recovery cause storm-control
errdisable recovery cause inline-power
errdisable recovery cause arp-inspection
errdisable recovery cause loopback
errdisable recovery cause small-frame
errdisable recovery cause psp
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 100-131,201
!
!
!
interface Port-channel1
switchport mode trunk
ip dhcp snooping trust
!
interface FastEthernet0/1
switchport access vlan 201
switchport mode access
switchport port-security maximum 2
switchport port-security
storm-control broadcast level 2.00
storm-control multicast level 2.00
storm-control action shutdown
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/2
switchport access vlan 201
switchport mode access
switchport port-security maximum 2
switchport port-security
storm-control broadcast level 2.00
storm-control multicast level 2.00
storm-control action shutdown
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/3
switchport access vlan 201
switchport mode access
switchport port-security maximum 2
switchport port-security
storm-control broadcast level 2.00
storm-control multicast level 2.00
storm-control action shutdown
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/4
switchport access vlan 201
switchport mode access
switchport port-security maximum 2
switchport port-security
storm-control broadcast level 2.00
storm-control multicast level 2.00
storm-control action shutdown
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/5
switchport access vlan 201
switchport mode access
switchport port-security maximum 2
switchport port-security
storm-control broadcast level 2.00
storm-control multicast level 2.00
storm-control action shutdown
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/6
switchport access vlan 201
switchport mode access
switchport port-security maximum 2
switchport port-security
storm-control broadcast level 2.00
storm-control multicast level 2.00
storm-control action shutdown
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/7
switchport access vlan 201
switchport mode access
switchport port-security maximum 2
switchport port-security
storm-control broadcast level 2.00
storm-control multicast level 2.00
storm-control action shutdown
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/8
switchport access vlan 201
switchport mode access
switchport port-security maximum 2
switchport port-security
storm-control broadcast level 2.00
storm-control multicast level 2.00
storm-control action shutdown
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/9
switchport access vlan 201
switchport mode access
switchport port-security maximum 2
switchport port-security
storm-control broadcast level 2.00
storm-control multicast level 2.00
storm-control action shutdown
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/10
switchport access vlan 201
switchport mode access
switchport port-security maximum 2
switchport port-security
storm-control broadcast level 2.00
storm-control multicast level 2.00
storm-control action shutdown
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/11
switchport access vlan 201
switchport mode access
switchport port-security maximum 2
switchport port-security
storm-control broadcast level 2.00
storm-control multicast level 2.00
storm-control action shutdown
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/12
switchport access vlan 201
switchport mode access
switchport port-security maximum 2
switchport port-security
storm-control broadcast level 2.00
storm-control multicast level 2.00
storm-control action shutdown
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/13
switchport access vlan 201
switchport mode access
switchport port-security maximum 2
switchport port-security
storm-control broadcast level 2.00
storm-control multicast level 2.00
storm-control action shutdown
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/14
switchport access vlan 201
switchport mode access
switchport port-security maximum 2
switchport port-security
storm-control broadcast level 2.00
storm-control multicast level 2.00
storm-control action shutdown
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/15
switchport access vlan 201
switchport mode access
switchport port-security maximum 2
switchport port-security
storm-control broadcast level 2.00
storm-control multicast level 2.00
storm-control action shutdown
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/16
switchport access vlan 201
switchport mode access
switchport port-security maximum 2
switchport port-security
storm-control broadcast level 2.00
storm-control multicast level 2.00
storm-control action shutdown
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/17
switchport access vlan 201
switchport mode access
switchport port-security maximum 2
switchport port-security
storm-control broadcast level 2.00
storm-control multicast level 2.00
storm-control action shutdown
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/18
switchport access vlan 201
switchport mode access
switchport port-security maximum 2
switchport port-security
storm-control broadcast level 2.00
storm-control multicast level 2.00
storm-control action shutdown
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/19
switchport access vlan 201
switchport mode access
switchport port-security maximum 2
switchport port-security
storm-control broadcast level 2.00
storm-control multicast level 2.00
storm-control action shutdown
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/20
switchport access vlan 201
switchport mode access
switchport port-security maximum 2
switchport port-security
storm-control broadcast level 2.00
storm-control multicast level 2.00
storm-control action shutdown
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/21
switchport access vlan 201
switchport mode access
switchport port-security maximum 2
switchport port-security
storm-control broadcast level 2.00
storm-control multicast level 2.00
storm-control action shutdown
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/22
switchport access vlan 201
switchport mode access
switchport port-security maximum 2
switchport port-security
storm-control broadcast level 2.00
storm-control multicast level 2.00
storm-control action shutdown
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/23
switchport access vlan 201
switchport mode access
switchport port-security maximum 2
switchport port-security
storm-control broadcast level 2.00
storm-control multicast level 2.00
storm-control action shutdown
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/24
switchport access vlan 201
switchport mode access
switchport port-security maximum 2
switchport port-security
storm-control broadcast level 2.00
storm-control multicast level 2.00
storm-control action shutdown
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet0/1
switchport mode trunk
channel-group 1 mode on
ip dhcp snooping trust
!
interface GigabitEthernet0/2
switchport mode trunk
channel-group 1 mode on
ip dhcp snooping trust
!
interface Vlan1
no ip address
!
interface Vlan100
XXXXXXXX255.255.255.255.0
!
ip default-gateway X XXXXXXXX
no ip http server
ip http secure-server
logging trap debugging
logging host 10.162.244.245
snmp-server community pronms!ro RO
snmp-server community pronms#rw RW
tacacs-server host 10.162.244.211 key 7 0014180C08540C0F01204F5D
tacacs-server host 10.162.244.212 key 7 13151C180703032325252B20
!
!
!
privilege interface level 3 shutdown
privilege configure level 3 interface
privilege exec level 15 connect
privilege exec level 15 telnet
privilege exec level 2 ping
privilege exec level 3 configure terminal
privilege exec level 3 configure
!
line con 0
authorization commands 3 COMMAND_CONSOLE_FREE
authorization commands 15 COMMAND_CONSOLE_FREE
authorization exec EXEC_CONSOLE_FREE
login authentication LOGIN_CONSOLE_FREE
line vty 0 4
password 7 08364D480C0B5445415F
line vty 5 15
!
ntp server 10.162.244.244
end
12 条回复12

bo chen
Beginner
Beginner
sh ip dhcp snooping binding要在做dhcp服务器的交换机或路由器上敲。一般看ip对应mac,我都用sh ip dhcp binding。希望我的回答可以帮到你{:2_27:}

xixideng61446
Beginner
Beginner
CSCO12178277 发表于 2020-11-26 15:21
sh ip dhcp snooping binding要在做dhcp服务器的交换机或路由器上敲。一般看ip对应mac,我都用sh ip dhcp bi ...

我在2960敲了sho ip dhcp snooping bing 就是显示不出来 上面图片有,谢谢大佬回答

xixideng61446
Beginner
Beginner
CSCO12178277 发表于 2020-11-26 15:21
sh ip dhcp snooping binding要在做dhcp服务器的交换机或路由器上敲。一般看ip对应mac,我都用sh ip dhcp bi ...

路由器上是做了Server的

cruiseluo
Beginner
Beginner
感觉2960交换机作为一个二层设备应该不会显示"show ip dhcp snooping binding",虽然它有这个命令

xixideng61446
Beginner
Beginner
cruiseluo 发表于 2020-11-27 09:55
感觉2960交换机作为一个二层设备应该不会显示"show ip dhcp snooping binding",虽然它有这个命令

但是有些可以啊

xixideng61446
Beginner
Beginner
有没有大大知道啊:(:(

xixideng61446
Beginner
Beginner
有没有大大知道 啊,谢谢了:(:(

xixideng61446
Beginner
Beginner
大佬们 :(:(:(:(

xixideng61446
Beginner
Beginner
各位大大 。解救下啊啊:(:(

xixideng61446
Beginner
Beginner
各位大大 。解救下啊啊:(:(

xixideng61446
Beginner
Beginner
问题找到了只要打一条IP DHCP VLAN xx就行了:'(:'(:'(:'(

xixideng61446
Beginner
Beginner
问题找到了只要打一条IP DHCP SNOONPing VLAN xx就行了:'(:'(:'(:'(
入门指南

使用上面的搜索栏输入关键字、短语或问题,搜索问题的答案。

我们希望您在这里的旅程尽可能顺利,因此这里有一些链接可以帮助您快速熟悉思科社区:





认可您的同行
快捷链接