取消
显示结果 
搜索替代 
您的意思是: 
cancel
公告

December 2020

8164
查看次数
6
有帮助
6
回复
Highlighted
Beginner

部分vlan无法通过dhcp获取地址

本帖最后由 id404 于 2016-3-30 17:52 编辑
统一回复:之前又出现另一个问题,就是两台电脑直接连到同一vlan互ping不丢包,一旦划入不同vlan就会丢包,电脑都是直接连网络连到交换机上,中间没经过任何设备。最后更新系统IOS解决。
221030fzqhaqa1pnid60hy.png
网络拓扑如上图
核心交换机3850作为vtp server 、dhcp server 并划分多个vlan ,每个vlan 配置相应的ip地址
接入层交换机2960为vtp client,按不同接口划入不同vlan
3850和2960之间的接口都为trunk
客户端通过dhcp自动获取ip
现在的问题是只有vlan402接口的电脑能自动获取到ip地址,其它vlan 无法通过dhcp获取到ip
请问具体是哪里配置问题或者可以通过什么方法排查问题?
3850配置如下:
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname c3850
!
boot-start-marker
boot-end-marker
!
!
vrf definition Mgmt-vrf
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
!
no aaa new-model
switch 1 provision ws-c3850-48t
ip routing
!
ip dhcp excluded-address 10.104.15.1 10.104.15.9
ip dhcp excluded-address 10.104.15.240 10.104.15.254
ip dhcp excluded-address 10.103.20.1 10.104.20.9
ip dhcp excluded-address 10.104.20.240 10.104.20.254
ip dhcp excluded-address 10.104.32.1 10.104.32.9
ip dhcp excluded-address 10.104.32.240 10.104.32.254
ip dhcp excluded-address 10.104.35.1 10.104.35.9
ip dhcp excluded-address 10.104.35.240 10.104.35.254
!
ip dhcp pool WIRELESS-GUEST
network 10.104.15.0 255.255.255.0
default-router 10.104.15.1
dns-server 192.168.133.5 192.168.133.6
lease 0 3
!
ip dhcp pool WIRESS-USER
network 10.104.20.0 255.255.255.0
default-router 10.104.20.1
dns-server 192.168.133.5 192.168.133.6
lease 0 3
!
ip dhcp pool VOICE-USER
network 10.104.35.0 255.255.255.0
default-router 10.104.35.1
dns-server 202.96.128.143 114.114.114.114
!
ip dhcp pool WIRELESS-MGMT
network 192.168.31.0 255.255.255.0
default-router 192.168.31.1
dns-server 202.96.128.143 114.114.114.114
!
ip dhcp pool WIRE-USER
network 10.104.32.0 255.255.255.0
default-router 10.104.32.1
dns-server 192.168.133.5 192.168.133.6
!
!
qos wireless-default-untrust
!
!
!
!
!
diagnostic bootup level minimal
identity policy webauth-global-inactive
inactivity-timer 3600
spanning-tree mode pvst
spanning-tree extend system-id
!
redundancy
mode sso
!
!
!
class-map match-any non-client-nrt-class
match non-client-nrt
!
!
!
!
!
interface GigabitEthernet0/0
vrf forwarding Mgmt-vrf
no ip address
negotiation auto
!
interface GigabitEthernet1/0/1
switchport mode trunk
!
interface GigabitEthernet1/0/2
switchport mode trunk
!
interface GigabitEthernet1/0/3
switchport mode trunk
!
interface GigabitEthernet1/0/4
switchport mode trunk
!
interface GigabitEthernet1/0/5
switchport access vlan 108
switchport mode access
!
interface GigabitEthernet1/0/6
!
interface Vlan1
no ip address
!
interface Vlan102
ip address 10.104.2.2 255.255.255.0
!
interface Vlan103
ip address 10.104.3.2 255.255.255.0
!
interface Vlan104
ip address 10.104.4.1 255.255.255.0
!
interface Vlan105
ip address 10.104.5.1 255.255.255.0
!
interface Vlan106
ip address 10.104.6.1 255.255.255.0
!
interface Vlan107
ip address 10.104.7.1 255.255.255.0
!
interface Vlan108
ip address 10.104.8.1 255.255.255.0
!
interface Vlan115
ip address 10.104.15.1 255.255.255.0
!
interface Vlan120
ip address 10.104.20.1 255.255.255.0
!
interface Vlan400
ip address 10.104.30.1 255.255.255.0
!
interface Vlan401
ip address 10.104.31.1 255.255.255.0
!
interface Vlan402
ip address 10.104.32.1 255.255.255.0
!
interface Vlan405
ip address 10.104.35.1 255.255.255.0
!
interface Vlan408
ip address 10.104.38.1 255.255.255.0
!
no ip http server
ip http authentication local
ip http secure-server
ip route 0.0.0.0 0.0.0.0 10.104.2.1
!
ip access-list extended NAT
permit ip 0.0.0.0 255.255.248.0 any
!
!
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login local
line vty 5 15
login local
!
wsma agent exec
profile httplistener
profile httpslistener
wsma agent config
profile httplistener
profile httpslistener
wsma agent filesys
profile httplistener
profile httpslistener
wsma agent notify
profile httplistener
profile httpslistener
!
wsma profile listener httplistener
transport http
!
wsma profile listener httpslistener
transport https
ap dot11 24ghz rrm channel dca 1
ap dot11 24ghz rrm channel dca 6
ap dot11 24ghz rrm channel dca 11
ap dot11 5ghz rrm channel dca 36
ap dot11 5ghz rrm channel dca 40
ap dot11 5ghz rrm channel dca 44
ap dot11 5ghz rrm channel dca 48
ap dot11 5ghz rrm channel dca 52
ap dot11 5ghz rrm channel dca 56
ap dot11 5ghz rrm channel dca 60
ap dot11 5ghz rrm channel dca 64
ap dot11 5ghz rrm channel dca 149
ap dot11 5ghz rrm channel dca 153
ap dot11 5ghz rrm channel dca 157
ap dot11 5ghz rrm channel dca 161
ap group default-group
end
2960配置如下:Building configuration...
Current configuration : 7797 bytes
!
! Last configuration change at 03:58:03 UTC Wed Nov 11 2015 by admin
! NVRAM config last updated at 03:59:12 UTC Wed Nov 11 2015 by admin
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname c2960D
!
boot-start-marker
boot-end-marker
!
no aaa new-model
switch 1 provision ws-c2960x-48fpd-l
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
interface FastEthernet0
no ip address
!
interface GigabitEthernet1/0/1
switchport mode trunk
!
interface GigabitEthernet1/0/2
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/3
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/4
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/5
switchport access vlan 405
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/6
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/7
switchport access vlan 115
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/8
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/9
switchport access vlan 120
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/10
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/11
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/12
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/13
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/14
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/15
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/16
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/17
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/18
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/19
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/20
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/21
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/22
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/23
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/24
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/25
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/26
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/27
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/28
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/29
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/30
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/31
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/32
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/33
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/34
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/35
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/36
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/37
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/38
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/39
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/40
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/41
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/42
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/43
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/44
switchport access vlan 408
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/45
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/46
switchport access vlan 402
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/47
switchport access vlan 408
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/48
switchport access vlan 408
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/49
!
interface GigabitEthernet1/0/50
!
interface TenGigabitEthernet1/0/1
!
interface TenGigabitEthernet1/0/2
!
interface Vlan1
no ip address
!
interface Vlan400
ip address 10.104.30.2 255.255.255.0
!
ip http server
ip http secure-server
!
!
!
!
line con 0
login local
line vty 0 4
login local
line vty 5 14
login local
line vty 15
login
!
end
6 条回复6
Highlighted
Cisco Employee

可以使用以下命令troubleshooting:
Show tech-support
Show ip dhcp banding
Show ip dhcp conflict
Show ip dhcp database
Show ip dhcp pool
http://www.cisco.com/c/en/us/support/docs/ip/dynamic-address-allocation-resolution/27470-100.html
相关参考文档,也可以复现故障,开case给Cisco TAC.
Highlighted

我一直在留意这个问题,配置上没看出什么问题,不知道楼主解决了没有,分享一下经验。谢谢
Highlighted
Cisco Employee

您需要判断一下3850是否收到了DHCP请求报文,以及是否回复了DHCP报文。建议在3850上执行debug ip dhcp server packet看一下3850是否收到了DHCP报文。
Highlighted
Cisco Employee

其他VLAN 的PC,手写一个对应的IP,看是否能正常用,ping GW
Highlighted
Beginner

统一回复:之前又出现另一个问题,就是两台电脑直接连到同一vlan互ping不丢包,一旦划入不同vlan就会丢包,电脑都是直接连网络连到交换机上,中间没经过任何设备。最后更新系统IOS解决。
Highlighted
Community Manager

id404 发表于 2016-3-30 17:51 back.gif
统一回复:之前又出现另一个问题,就是两台电脑直接连到同一vlan互ping不丢包,一旦划入不同vlan就会丢包, ...

感谢分享最终的解决方法 :handshake
不能显示该小部件。