取消
显示结果 
搜索替代 
您的意思是: 
cancel
417
查看次数
0
有帮助
7
回复

三层交换机与两路由做内网出口,做热备份的路由配置问题

Machanic
Beginner
Beginner

在这个图中,主要核心是三层交换机,学者我主要是较复杂的内网和外网中不能使用默认路由,需要配置动态路由,并且在配置路由表中,遇到路由器与三层交换机,哪种情况需要用二层接口,哪些情况要升为三层接口,存在疑惑,希望有大神就从图中画红线的地方指点指点我,(三层交换机接两路由目的是为了做热备份),望大家不吝赐教。谢谢!

7 条回复7

Machanic
Beginner
Beginner
 

不知道怎么发图片,貌似只能发附件是吗?

如下是你所提及的拓扑图:

Snipaste_2023-11-18_19-53-16.png

如你的描述来说,想知道SW和RT连接的情况,什么时候可以使用L2接口,什么时候转换为L3接口对吗?如果是这样的话,我根据我的理解陈述一下:

  • SW的L2接口可以连接RT,如果需要SW和RT互联接口通信,则需要给连接RT的SW接口所在VLAN配置一个SVI地址,用以和RT接口通信(如SW的F0/6配置为Access VLAN 10,而下侧的CISCO2811的F0/0配置IP为192.168.7.1/30;那么SW3560上可以配置一个SVI接口,及inter vlan 10, ip add 192.168.7.2/30)
  • SW连接RT的时候,也可以将连接RT的接口修改为L3接口,即在接口下通过no switchport命令关闭switch port功能,这个时候,就不需要再SW上再配置SVI,因为该接口已经是L3接口,可以直接在该L3接口上配置IP地址(如下侧的CISCO2811的接口配置不变,而SW3560的配置为inter f0/6,no switchport, ip add 192.168.7.2/30)

这种情况都可以实现互联的通信,有些时候取决于网络的规划和设备特性。如上的这两种情况,我认为都可以实现互联需求。当你的SW的接口无法分配为L3接口时,那么第一种方式通常是适用的;当你的SW可以配置为L3接口时,则可以选择任意一种方式,只要在你的场景下能够完成相关需求即可。不知我是否理解到你所需的内容,希望可以帮到你。

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Rps-Cheers | If it solves your problem, please mark as answer. Thanks !

Machanic
Beginner
Beginner

大神。您好,你的分析我已经充分理解了,非常感谢,我的理解是3层交换机的普通接口默认是二层接口,可以升为三层,我尝试对连接三层机的路由配置动态路由表,实验证明,不能单独network 192.168.8.0,或192.168.0.0,只能依次把192.168.1.0 2.0 3.0 4.0 5.0 单独NETWORK,才能实现内网互通,不知到怎么解释?还有就是我才进入这个论坛,大神可以告诉我怎么直接上传图片,显示图片,而不是文件呢?

你好,

1.关于通告的路由的问题。

如果你使用的RIP的话,只能network主类。以如下示例说明:

 

R1(config)#router rip
R1(config-router)#no au
R1(config-router)#no auto-summary
R1(config-router)#net 10.1.1.0
R1(config-router)#net 172.16.1.0
R1(config-router)#net 192.168.1.0
R1#sho run | s router rip
router rip
 network 10.0.0.0
 network 172.16.0.0
 network 192.168.1.0
 no auto-summary

 

所以network的192.168.8.0或192.168.0.0都只能代表对应主类网段,即192.168.0.0/24,高级一些的路由协议,如OSPF可以支持精确通告。

2.关于传图片

在编辑文本的上面有一个类似“照相机”的图标,点击之后可以上传图片,完成就可以在编辑的文本中插入图片了。

1.png2.png

 

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Rps-Cheers | If it solves your problem, please mark as answer. Thanks !

Machanic
Beginner
Beginner

如果本图中F0/6 0/7升为三层接口,那么做热备份还需要做虚拟网关吗?谢谢

你好,

没有看到你提到的F0/7接口在哪里,如果F0/6和F0/7是网关设备面对下行的网络接口,不管他是L2还是L3接口,做网关冗余都是一个推荐的做法(毕竟网关冗余增加了网络的可靠性),不同的是,对于L2接口,是在SVI下配置虚拟网关协议,对于L3接口,可以直接在L3接口上配置冗余网关协议。

如下是任意的两个示例,一个是配置在SVI接口下的,一个是在物理接口下配置的。

Switch# configure terminal
Switch(config)# interface gigabitethernet0/1
Switch(config-if)# no switchport
Switch(config-if)# standby ip 172.20.128.3
Switch(config-if)# standby priority 120 preempt delay 300
Switch(config-if)# end

Switch(config)#interface vlan 10
Switch(config-if)#standby version 2
Switch(config-if)#standby 10 ip 10.10.0.254 
Switch(config-if)#standby 10 priority 150       
Switch(config-if)#standby 10 preempt 

 

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Rps-Cheers | If it solves your problem, please mark as answer. Thanks !
入门指南

使用上面的搜索栏输入关键字、短语或问题,搜索问题的答案。

我们希望您在这里的旅程尽可能顺利,因此这里有一些链接可以帮助您快速熟悉思科社区:









快捷链接