custom.ribbon_feed
取消
显示结果 
搜索替代 
您的意思是: 
cancel
6188
查看次数
0
有帮助
10
回复

两台C9300做了堆叠之后如何做出双机热备的效果

mikeright24293
Level 1
Level 1
现采购了两台C9300,插上堆叠线之后,系统就自动堆叠了。那么,如何在此基础上做出双机热备的效果,即两台交换机同时运行,如果有一台交换机突发故障,另一台交换机能继续使用,转发数据。
1 个已接受解答

已接受的解答

ilay
VIP
VIP
mikeright24293 发表于 2020-11-16 08:53
如果和堆叠交换机相邻的设备无法配置portchannel,那是否意味着只能放弃堆叠,做vrrp或hsrp?

不是的
首先portchannel是用来实现链路冗余的; VRRP/HSRP是首跳冗余协议,换句话说是网关冗余的协议。
堆叠的好处就是 可以将两条或者两台以上的交换机逻辑的当做一台设备来使用。可以实现跨物理交换机的链路捆绑,在这种情况下没有必要使用vrrp/hsrp。此时如果对端设备不支持portchannel,完全可以任意单独接一条线,或者从两台交换机上各接一条,通过spanning-tree来保证链路无环
如果放弃堆叠,要实现网关的冗余则必然需要使用vrrp、hsrp; 对应的,如果设备不支持port-channel,那也是任意单接一边,同样无法避免单点故障的问题。如果对端设备支持两两条链路连接,也会在生成树的工作下只能使用其中一条。
093332y19niha3jlz3p9vd.png
拿个实际例子说明,上图sw1sw2堆叠成一台逻辑设备,此时与其相连的access sw和pc可以直接通过建立portchannel,保证链路冗余性,如果设备不支持portchannel 如PC2,可以任意在sw1、sw2上取一个接口连接即可(无论上图还是下图,PC2都无法避免单节点引发的故障)
下面的图是两条设备各自运行,通过vrrp或者hsrp实现网关冗余,但是相应的access-sw PC1,只能实现一条链路使用,当sw1故障的时候,另一条链路才会使用。相当于空闲着一条链路。PC2,无论接SW1还是SW2都能正常工作,但是单节点故障时会受到影响。
093358vnlc4htrrr3fhmnp.png
总的来说 堆叠还是有好处的,现在大多数交换机基本上都支持port-channel,服务器也可以做team网卡捆绑,即便是按照你说的不支持portchannel的设备,也完全可以连接两条链路通过生成树自动block链路即可。
所以完全没有必要放弃堆叠,对于支持port-channel的,堆叠能实现更好的性能,不支持的,也没有什么太大的区别,还能节省配置,何乐而不为呢。
(写的有点乱哄哄的,凑合着看吧,不明白再说{:2_27:})

在原帖中查看解决方案

10 条回复10

ilay
VIP
VIP
mikeright24293 发表于 2020-11-16 08:53
如果和堆叠交换机相邻的设备无法配置portchannel,那是否意味着只能放弃堆叠,做vrrp或hsrp?

不是的
首先portchannel是用来实现链路冗余的; VRRP/HSRP是首跳冗余协议,换句话说是网关冗余的协议。
堆叠的好处就是 可以将两条或者两台以上的交换机逻辑的当做一台设备来使用。可以实现跨物理交换机的链路捆绑,在这种情况下没有必要使用vrrp/hsrp。此时如果对端设备不支持portchannel,完全可以任意单独接一条线,或者从两台交换机上各接一条,通过spanning-tree来保证链路无环
如果放弃堆叠,要实现网关的冗余则必然需要使用vrrp、hsrp; 对应的,如果设备不支持port-channel,那也是任意单接一边,同样无法避免单点故障的问题。如果对端设备支持两两条链路连接,也会在生成树的工作下只能使用其中一条。
093332y19niha3jlz3p9vd.png
拿个实际例子说明,上图sw1sw2堆叠成一台逻辑设备,此时与其相连的access sw和pc可以直接通过建立portchannel,保证链路冗余性,如果设备不支持portchannel 如PC2,可以任意在sw1、sw2上取一个接口连接即可(无论上图还是下图,PC2都无法避免单节点引发的故障)
下面的图是两条设备各自运行,通过vrrp或者hsrp实现网关冗余,但是相应的access-sw PC1,只能实现一条链路使用,当sw1故障的时候,另一条链路才会使用。相当于空闲着一条链路。PC2,无论接SW1还是SW2都能正常工作,但是单节点故障时会受到影响。
093358vnlc4htrrr3fhmnp.png
总的来说 堆叠还是有好处的,现在大多数交换机基本上都支持port-channel,服务器也可以做team网卡捆绑,即便是按照你说的不支持portchannel的设备,也完全可以连接两条链路通过生成树自动block链路即可。
所以完全没有必要放弃堆叠,对于支持port-channel的,堆叠能实现更好的性能,不支持的,也没有什么太大的区别,还能节省配置,何乐而不为呢。
(写的有点乱哄哄的,凑合着看吧,不明白再说{:2_27:})

ilay
VIP
VIP
堆叠本身就是一种冗余机制,将两台交换机组成一台逻辑的设备。本身具备双机的特性。
需要注意的是,与其相邻的设备需要同时连接堆叠组中的两台交换机。可以直接通过二层或者三层的portchannel实现
尽管交换机做了堆叠,如果下面的设备没有同时连接这两台交换机的话,也是会出故障的

mikeright24293
Level 1
Level 1
感谢大师指点,我的交换机端口,大部分是trunk,有两个端口是配了ip地址的,trunk口和配了ip地址的口如何做portchannel呢?还请大师不吝赐教。

ilay
VIP
VIP
mikeright24293 发表于 2020-11-12 15:53
感谢大师指点,我的交换机端口,大部分是trunk,有两个端口是配了ip地址的,trunk口和配了ip地址的口如何做 ...

trunk就使用二层的portchannel ,配置IP地址的就用三层的portchannel 啊
举例 堆叠的3850 和一台3650使用三层portchannel连接
--- 3850 config---
interface Port-channel1
description connected-to-3650-po1
no switchport
ip address 10.3.254.1 255.255.255.252
!
interface TenGigabitEthernet1/0/24
description connected-to-3650 t1/1/3
no switchport
no ip address
channel-group 1 mode active
!
interface TenGigabitEthernet2/0/24
description connected-to-3650 t1/1/4
no switchport
no ip address
channel-group 1 mode active
!
--- 3650 config ---
interface Port-channel1
description connected-to-3850 Stack-SW
no switchport
ip address 10.3.254.2 255.255.255.252
!
interface TenGigabitEthernet1/1/3
description connected-to-3850 Stack-Switch-1 T1/0/24
no switchport
no ip address
channel-group 1 mode active
!
interface TenGigabitEthernet1/1/4
description connected-to-3850 Stack-Switch-2 T1/0/24
no switchport
no ip address
channel-group 1 mode active
!

mikeright24293
Level 1
Level 1
gengchunlin 发表于 2020-11-12 16:10
trunk就使用二层的portchannel ,配置IP地址的就用三层的portchannel 啊
举例 堆叠的3850 和一台3650 ...

之前没做过堆叠设备的双机热备,谢谢!

mikeright24293
Level 1
Level 1
mikeright24293 发表于 2020-11-12 16:34
之前没做过堆叠设备的双机热备,谢谢!

portchannel和etherchannel是一个东西吗?有何异同?

mikeright24293
Level 1
Level 1
gengchunlin 发表于 2020-11-12 16:10
trunk就使用二层的portchannel ,配置IP地址的就用三层的portchannel 啊
举例 堆叠的3850 和一台3650 ...

portchannel和etherchannel是一个东西吗?有何异同?

ilay
VIP
VIP
mikeright24293 发表于 2020-11-12 16:47
portchannel和etherchannel是一个东西吗?有何异同?

不是一个含义
可以这么理解:
port-channel 是IOS中的一个虚拟接口
Etherchannel 是一种链路捆绑或者链路聚合技术,允许设备将两个或者两个以上的接口用作一个“接口”使用
创建的portchanne正常工作l时需要用到etherchannel技术

mikeright24293
Level 1
Level 1
gengchunlin 发表于 2020-11-12 16:10
trunk就使用二层的portchannel ,配置IP地址的就用三层的portchannel 啊
举例 堆叠的3850 和一台3650 ...

但是有个问题,如果都是思科的设备按您的建议配置应该没问题。但我的两台堆叠的C9300上联口是防火墙,防火墙是飞塔的设备,不知道飞塔能否和C9300做portchannel,如果不能的话,这种情况下该怎么办呢?

mikeright24293
Level 1
Level 1
gengchunlin 发表于 2020-11-12 17:02
不是一个含义
可以这么理解:
port-channel 是IOS中的一个虚拟接口

如果和堆叠交换机相邻的设备无法配置portchannel,那是否意味着只能放弃堆叠,做vrrp或hsrp?
快捷链接