取消
显示结果 
搜索替代 
您的意思是: 
cancel
3103
查看次数
2
有帮助
2
回复

成树协议和端口镜像的关系

lizhengtao
Level 1
Level 1
设备在配置端口镜像的时候,为什么目的端口要关闭生成树协议。我想知道整个原理,谢谢各位好友麻烦给予解答。
1 个已接受解答

已接受的解答

Lei Zhang
Cisco Employee
Cisco Employee
您好!
Cat 65:
A destination port does not participate in spanning tree while the SPAN session is active.
http://www.cisco.com/c/en/us/support/docs/switches/catalyst-6500-series-switches/10570-41.html
Nexus 7K:
Destination ports do not participate in any spanning tree instance. SPAN output includes bridge protocol data unit (BPDU) Spanning-Tree Protocol hello packets.
http://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus7000/sw/system-management/guide/b_Cisco_Nexus_7000_Series_NX-OS_System_Management_Configuration_Guide-RI/b_Cisco_Nexus_7000_Series_NX-OS_System_Management_Configuration_Guide_chapter_01010...
没有说SPAN destination "必须" 关闭STP。。。只是说SPAN destination port不参与STP而已。
以N7K为例:
N7K-3(config-monitor)# show run monitor
!Command: show running-config monitor
!Time: Tue Mar 28 10:29:50 2017
version 7.2(1)D1(1)
monitor session 1
source interface Ethernet4/47 both
destination interface Ethernet9/14《《《《《《《《《《《e9/14 为SPAN destination
no shut
N7K-3(config-monitor)# show run int e9/14
!Command: show running-config interface Ethernet9/14
!Time: Tue Mar 28 10:30:33 2017
version 7.2(1)D1(1)
interface Ethernet9/14
switchport mode trunk
switchport monitor
spanning-tree port type edge《《《《《《《STP enable & type is edge
no shutdown
N7K-3(config-monitor)#
N7K-3(config-monitor)# show monitor session 1
session 1
---------------
type : local
state : up《《《《《《《《《《《《《《《《《《monitor session is up
source intf :
rx : Eth4/47
tx : Eth4/47
both : Eth4/47
source VLANs :
rx :
tx :
both :
source exception :
filter VLANs : filter not specified
destination ports : Eth9/14
Feature Enabled Value Modules Supported Modules Not-Supported
-----------------------------------------------------------------------------
MTU-Trunc No
rate-limit-rx No
rate-limit-tx No
Sampling No
MCBE No
L3-TX - - 2 3 7 9 4
Legend:
MCBE = Multicast Best Effort
L3-TX = L3 Multicast Egress SPAN
ExSP-X = Exception Span for type X (L3, FP, or misc)
N7K-3(config-monitor)#
希望可以帮到你!
谢谢!

在原帖中查看解决方案

2 条回复2

Lei Zhang
Cisco Employee
Cisco Employee
您好!
Cat 65:
A destination port does not participate in spanning tree while the SPAN session is active.
http://www.cisco.com/c/en/us/support/docs/switches/catalyst-6500-series-switches/10570-41.html
Nexus 7K:
Destination ports do not participate in any spanning tree instance. SPAN output includes bridge protocol data unit (BPDU) Spanning-Tree Protocol hello packets.
http://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus7000/sw/system-management/guide/b_Cisco_Nexus_7000_Series_NX-OS_System_Management_Configuration_Guide-RI/b_Cisco_Nexus_7000_Series_NX-OS_System_Management_Configuration_Guide_chapter_01010...
没有说SPAN destination "必须" 关闭STP。。。只是说SPAN destination port不参与STP而已。
以N7K为例:
N7K-3(config-monitor)# show run monitor
!Command: show running-config monitor
!Time: Tue Mar 28 10:29:50 2017
version 7.2(1)D1(1)
monitor session 1
source interface Ethernet4/47 both
destination interface Ethernet9/14《《《《《《《《《《《e9/14 为SPAN destination
no shut
N7K-3(config-monitor)# show run int e9/14
!Command: show running-config interface Ethernet9/14
!Time: Tue Mar 28 10:30:33 2017
version 7.2(1)D1(1)
interface Ethernet9/14
switchport mode trunk
switchport monitor
spanning-tree port type edge《《《《《《《STP enable & type is edge
no shutdown
N7K-3(config-monitor)#
N7K-3(config-monitor)# show monitor session 1
session 1
---------------
type : local
state : up《《《《《《《《《《《《《《《《《《monitor session is up
source intf :
rx : Eth4/47
tx : Eth4/47
both : Eth4/47
source VLANs :
rx :
tx :
both :
source exception :
filter VLANs : filter not specified
destination ports : Eth9/14
Feature Enabled Value Modules Supported Modules Not-Supported
-----------------------------------------------------------------------------
MTU-Trunc No
rate-limit-rx No
rate-limit-tx No
Sampling No
MCBE No
L3-TX - - 2 3 7 9 4
Legend:
MCBE = Multicast Best Effort
L3-TX = L3 Multicast Egress SPAN
ExSP-X = Exception Span for type X (L3, FP, or misc)
N7K-3(config-monitor)#
希望可以帮到你!
谢谢!

suzhouxiaoniu
Spotlight
Spotlight
本帖最后由 suzhouxiaoniu 于 2016-1-13 12:37 编辑
一直没找到官方解释,感谢楼下
入门指南

使用上面的搜索栏输入关键字、短语或问题,搜索问题的答案。

我们希望您在这里的旅程尽可能顺利,因此这里有一些链接可以帮助您快速熟悉思科社区:









快捷链接