取消
显示结果 
搜索替代 
您的意思是: 
cancel
公告

December 2020

9337
查看次数
0
有帮助
15
回复
zhanglei1
Beginner

请问来电显示的问题

请教下大侠:我们公司的BE6K,里面的CUCM,我们在IP话机上看不到外线电话号码。
部署情况是:2901的路由器,加上模拟外线板卡接了2个模拟外线,经检测,线路上是有来电显示的,拿电话直接接上去测试过。
路由器到CUCM之间走的是H.323的trunk,
现在外线打进来,转到分机,我们分机显示unkown。
不知道问题出在哪里,怎么去做这个排错的工作呢。
1 个已接受解答

已接受的解答
xiaoloya
Beginner

建议把2901以及CUCM等版本信息提供出来,其次把2901对应的配置先导出来。很有可能是漏配以及配置错误导致的问题,当然也不排除类似版本issue。

在原帖中查看解决方案

15 条回复15
xiaoloya
Beginner

建议把2901以及CUCM等版本信息提供出来,其次把2901对应的配置先导出来。很有可能是漏配以及配置错误导致的问题,当然也不排除类似版本issue。

在原帖中查看解决方案

完全感觉
Participant

voice-port 0/0/0
caller-id enable
xiaoloya
Beginner

建议把2901以及CUCM等版本信息提供出来,其次把2901对应的配置先导出来。很有可能是漏配以及配置错误导致的问题,当然也不排除类似版本issue。
frankhong
Beginner

try this first:
voice-port 0/0/0
caller-id enable
caller-id alerting ring 2
if still doesn't work, please provide “debug vpm signal”
huoran1234
Participant

我是纯进来学习的。。;P
congx
Cisco Employee

voice-port 0/0/0
caller-id enable
caller-id alerting ring 2
如果还不生效,请尝试修改CPtone,如果修改CPtone后有了来电显但是挂不断,再重新做个挂断音就行了。
wujianlong
Beginner

你转的分机是内线还是外线啊
jing zhang
Beginner

楼主问题解决了么?
one-time
Expert

thousandmoun 发表于 2015-5-8 21:58 back.gif
楼主问题解决了么?

@zhanglei1 楼主问题解决了吗~我们这有专家帮忙解答哦;P@thousandmoun
zhanglei1
Beginner

Current configuration : 5815 bytes
!
! No configuration change since last restart
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname dingsheng
!
boot-start-marker
boot-end-marker
!
!
logging buffered 51200 warnings
enable password tsun
!
no aaa new-model
clock timezone BJ 8 0
!
ip cef
!
!
!
ip dhcp excluded-address 192.168.1.1 192.168.1.99
ip dhcp excluded-address 192.168.1.200 192.168.1.254
!
ip dhcp pool dspool
network 192.168.1.0 255.255.255.0
dns-server 192.168.1.1
default-router 192.168.1.1
option 150 ip 192.168.1.221
!
!
!
no ip domain lookup
ip domain name yourdomain.com
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-1268404433
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1268404433
revocation-check none
rsakeypair TP-self-signed-1268404433
!
!
crypto pki certificate chain TP-self-signed-1268404433
certificate self-signed 01
3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 31323638 34303434 3333301E 170D3133 30373033 30353531
31365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 32363834
30343433 3330819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100BFF4 D3F1102F 6208CD99 21F1B3AC 5DE03E95 26D27CD3 ACA7D8A6 1CD6EACE
05FA06FF 2EBCB44A 89177FEC 16DCE35D 4CB2D85F 3292B75E D108D351 24FB7733
61DE9F5F 98DD9172 1C3BC445 D5A3B6F2 8A77EF41 0B7FB1EB 97599A5A 2AEECFBC
12A962CB F036B07E B91A0259 96EA5DA8 852E16B5 C4866319 A07604C9 54143EDE
C8890203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
551D2304 18301680 14ABFA67 300F1AE8 0CE8CA61 67FA99E3 68A39C7E E4301D06
03551D0E 04160414 ABFA6730 0F1AE80C E8CA6167 FA99E368 A39C7EE4 300D0609
2A864886 F70D0101 05050003 818100B6 6F3ACB9A 46430ED5 EA67A13B EF0617EC
6A50F6FB E016985F 95D411F6 C725CA58 438FC7EA B2EF49BE 3AA74561 949A5C54
18FF5582 0870C3F0 5BF963E9 F2CF5F95 F532AC50 42C24B4D 5B52A76A 5720A2BD
E7492004 4F01D7E4 FA0CEBEC DD11F539 0DD318D4 A5E554E0 87A4C6FF 50018C11
0ED24A21 57BE40D7 BE204A0B 61C789
quit
voice-card 0
!
!
!
voice service voip
qsig decode
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
supplementary-service h450.12
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
h323
sip
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729r8
!
voice class h323 1
h225 timeout tcp establish 3
h225 timeout setup 3
!
!
!
!
!
!
!
application
service aa flash:its-CISCO.2.0.3.0.tcl
param operator 201
paramspace english index 1
paramspace english language en
paramspace english location flash:
paramspace english prefix en
param welcome-prompt _welcome.au
param max-extension-length 3
!
service its-CISCO.2.0.3.0.tcl aa
!
!
license udi pid CISCO2901/K9 sn FGL170812TA
hw-module pvdm 0/0
!
!
!
username tsun privilege 15 password 0 tsun
!
redundancy
!
!
!
!
!
csdb tcp synwait-time 30
csdb tcp idle-time 3600
csdb tcp finwait-time 5
csdb tcp reassembly max-memory 1024
csdb tcp reassembly max-queue-length 16
csdb udp idle-time 30
csdb icmp idle-time 10
csdb session max-session 65535
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address 192.168.1.251 255.255.255.0
duplex auto
speed auto
h323-gateway voip interface
h323-gateway voip bind srcaddr 192.168.1.251
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip forward-protocol nd
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
!
!
!
control-plane
!
!
voice-port 0/0/0
supervisory disconnect dualtone mid-call
input gain -6
output attenuation -6
cptone CN
timeouts call-disconnect 5
timeouts wait-release 5
connection plar opx immediate 299
caller-id enable
!
voice-port 0/0/1
supervisory disconnect dualtone mid-call
input gain -6
output attenuation -6
cptone CN
timeouts call-disconnect 5
timeouts wait-release 5
connection plar opx immediate 299
caller-id enable
!
voice-port 0/0/2
supervisory disconnect dualtone mid-call
input gain -6
output attenuation -6
cptone CN
timeouts call-disconnect 5
timeouts wait-release 5
connection plar opx immediate 299
caller-id enable
!
voice-port 0/0/3
supervisory disconnect dualtone mid-call
input gain -6
output attenuation -6
cptone CN
timeouts call-disconnect 5
timeouts wait-release 5
connection plar opx immediate 299
caller-id enable
!
!
!
!
!
!
mgcp profile default
!
!
dial-peer voice 1 voip
destination-pattern 299
session target ipv4:192.168.1.221
voice-class codec 1
voice-class h323 1
dtmf-relay h245-alphanumeric
no vad
!
dial-peer voice 100 pots
destination-pattern 9.T
port 0/0/0
!
dial-peer voice 101 pots
destination-pattern 9.T
port 0/0/3
!
dial-peer voice 102 pots
destination-pattern 9.T
port 0/0/2
!
dial-peer voice 103 pots
destination-pattern 9.T
port 0/0/1
!
!
!
!
gatekeeper
shutdown
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
login local
line aux 0
password cisco
login local
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
privilege level 15
password cisco
login local
transport input telnet ssh
line vty 5 15
access-class 23 in
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
ntp master
!
end
zhanglei1
Beginner

May 14 05:13:42.659: htsp_process_event: [0/0/0, FXOLS_ONHOOK, E_DSP_SIG_0000]fxols_onhook_ringing
May 14 05:13:42.659: htsp_timer - 125 msec
May 14 05:13:42.787: htsp_process_event: [0/0/0, FXOLS_WAIT_RING_MIN, E_HTSP_EVENT_TIMER]fxols_wait_ring_min_timer
May 14 05:13:42.787: htsp_timer - 10000 msec
May 14 05:13:42.787: htsp_timer_stop3 htsp_setup_ind
May 14 05:13:42.787: [0/0/0] get_fxo_caller_id:Caller ID receive failed. parseCallerIDString:no data.
May 14 05:13:42.787: [0/0/0] get_local_station_id calling num= calling name= calling time=05/14 13:13 orig called=
May 14 05:13:42.787: htsp_process_event: [0/0/0, FXOLS_WAIT_SETUP_ACK, E_HTSP_SETUP_ACK]
May 14 05:13:42.787: fxols_wait_setup_ack:
May 14 05:13:42.787: htsp_timer - 6000 msec
May 14 05:13:42.787: [0/0/0] htsp_start_caller_id_rx:Mode FSK. Alerting 0x3
May 14 05:13:42.791: htsp_process_event: [0/0/0, FXOLS_PROCEEDING, E_HTSP_PROCEEDING]fxols_offhook_prochtsp_alert_notify
May 14 05:13:42.803: htsp_process_event: [0/0/0, FXOLS_PROCEEDING, E_HTSP_ALERT]fxols_offhook_alerthtsp_call_service_msghtsp_call_service_msg not EFXS (2)
May 14 05:13:42.855: htsp_call_bridged invokedhtsp_call_service_msghtsp_call_service_msg not EFXS (2)
May 14 05:13:42.859: htsp_process_event: [0/0/0, FXOLS_PROCEEDING, E_HTSP_CONNECT]fxols_offhook_connect
May 14 05:13:42.859: [0/0/0] htsp_stop_caller_id_rx. message length 0
May 14 05:13:42.859: [0/0/0] set signal state = 0xC timestamp = 0
May 14 05:13:42.859: htsp_timer_stop
May 14 05:13:42.859: htsp_process_event: [0/0/0, FXOLS_CONNECT, E_HTSP_VOICE_CUT_THROUGH]fxols_connect_proc_voice
May 14 05:13:43.059: htsp_process_event: [0/0/0, FXOLS_CONNECT, E_DSP_SIG_0100]fxols_normal_battery
May 14 05:13:43.059: htsp_timer_stop2
May 14 05:13:50.099: htsp_digit_ready(0/0/0): digit = 2
May 14 05:13:50.439: htsp_digit_ready(0/0/0): digit = 2
May 14 05:13:51.335: htsp_digit_ready(0/0/0): digit = 5
May 14 05:13:52.771: htsp_process_event: [0/0/0, FXOLS_CONNECT, E_HTSP_VOICE_CUT_THROUGH]fxols_connect_proc_voicehtsp_call_service_msghtsp_call_service_msg not EFXS (2)
May 14 05:13:53.639: htsp_process_event: [0/0/0, FXOLS_CONNECT, E_HTSP_VOICE_CUT_THROUGH]fxols_connect_proc_voice
May 14 05:14:03.083: htsp_process_event: [0/0/0, FXOLS_CONNECT, E_DSP_SUP_DISCONNECT]fxols_conn_sup_disc
May 14 05:14:03.083: htsp_timer2 - 5000 msec
May 14 05:14:08.083: htsp_process_event: [0/0/0, FXOLS_CONNECT, E_HTSP_EVENT_TIMER2]fxols_disc_confirm
May 14 05:14:08.083: htsp_timer_stop
May 14 05:14:08.083: htsp_timer_stop2
May 14 05:14:08.083: htsp_timer_stop3
May 14 05:14:08.083: htsp_timer_stop3
May 14 05:14:08.099: htsp_process_event: [0/0/0, FXOLS_REMOTE_RELEASE, E_HTSP_RELEASE_REQ]fxols_offhook_release
May 14 05:14:08.099: htsp_timer_stop
May 14 05:14:08.099: htsp_timer_stop2
May 14 05:14:08.099: htsp_timer_stop3
May 14 05:14:08.099: [0/0/0] set signal state = 0x4 timestamp = 0
May 14 05:14:08.099: htsp_timer - 2000 msec
May 14 05:14:10.099: htsp_process_event: [0/0/0, FXOLS_GUARD_OUT, E_HTSP_EVENT_TIMER]fxols_guard_out_timeout
May 14 05:14:10.099: htsp_process_event: [0/0/0, FXOLS_ONHOOK, E_DSP_SIG_0100]
May 14 05:14:13.495: htsp_process_event: [0/0/0, FXOLS_ONHOOK, E_DSP_SIG_0000]fxols_onhook_ringing
May 14 05:14:13.495: htsp_timer - 125 msec
May 14 05:14:13.623: htsp_process_event: [0/0/0, FXOLS_WAIT_RING_MIN, E_HTSP_EVENT_TIMER]fxols_wait_ring_min_timer
May 14 05:14:13.623: htsp_timer - 10000 msec
May 14 05:14:13.623: htsp_timer_stop3 htsp_setup_ind
May 14 05:14:13.623: [0/0/0] get_fxo_caller_id:Caller ID receive failed. parseCallerIDString:no data.
May 14 05:14:13.623: [0/0/0] get_local_station_id calling num= calling name= calling time=05/14 13:14 orig called=
May 14 05:14:13.623: htsp_process_event: [0/0/0, FXOLS_WAIT_SETUP_ACK, E_HTSP_SETUP_ACK]
May 14 05:14:13.623: fxols_wait_setup_ack:
May 14 05:14:13.623: htsp_timer - 6000 msec
May 14 05:14:13.623: [0/0/0] htsp_start_caller_id_rx:Mode FSK. Alerting 0x3
May 14 05:14:13.627: htsp_process_event: [0/0/0, FXOLS_PROCEEDING, E_HTSP_PROCEEDING]fxols_offhook_prochtsp_alert_notify
May 14 05:14:13.635: htsp_process_event: [0/0/0, FXOLS_PROCEEDING, E_HTSP_ALERT]fxols_offhook_alerthtsp_call_service_msghtsp_call_service_msg not EFXS (2)
May 14 05:14:13.699: htsp_call_bridged invokedhtsp_call_service_msghtsp_call_service_msg not EFXS (2)
May 14 05:14:13.703: htsp_process_event: [0/0/0, FXOLS_PROCEEDING, E_HTSP_CONNECT]fxols_offhook_connect
May 14 05:14:13.703: [0/0/0] htsp_stop_caller_id_rx. message length 0
May 14 05:14:13.703: [0/0/0] set signal state = 0xC timestamp = 0
May 14 05:14:13.703: htsp_timer_stop
May 14 05:14:13.703: htsp_process_event: [0/0/0, FXOLS_CONNECT, E_HTSP_VOICE_CUT_THROUGH]fxols_connect_proc_voice
May 14 05:14:13.907: htsp_process_event: [0/0/0, FXOLS_CONNECT, E_DSP_SIG_0100]fxols_normal_battery
May 14 05:14:13.907: htsp_timer_stop2
May 14 05:14:20.515: htsp_digit_ready(0/0/0): digit = 2
May 14 05:14:21.675: htsp_digit_ready(0/0/0): digit = 5
May 14 05:14:22.415: htsp_digit_ready(0/0/0): digit = 5
May 14 05:14:23.855: htsp_process_event: [0/0/0, FXOLS_CONNECT, E_HTSP_VOICE_CUT_THROUGH]fxols_connect_proc_voicehtsp_call_service_msghtsp_call_service_msg not EFXS (2)htsp_call_service_msghtsp_call_service_msg not EFXS (2)
May 14 05:14:29.663: htsp_process_event: [0/0/0, FXOLS_CONNECT, E_HTSP_VOICE_CUT_THROUGH]fxols_connect_proc_voice
May 14 05:14:37.839: htsp_timer_stop3
May 14 05:14:37.851: htsp_process_event: [0/0/0, FXOLS_CONNECT, E_HTSP_RELEASE_REQ]fxols_offhook_release
May 14 05:14:37.851: htsp_timer_stop
May 14 05:14:37.851: htsp_timer_stop2
May 14 05:14:37.851: htsp_timer_stop3
May 14 05:14:37.855: [0/0/0] set signal state = 0x4 timestamp = 0
May 14 05:14:37.855: htsp_timer - 2000 msec
May 14 05:14:39.855: htsp_process_event: [0/0/0, FXOLS_GUARD_OUT, E_HTSP_EVENT_TIMER]fxols_guard_out_timeout
May 14 05:14:39.855: htsp_process_event: [0/0/0, FXOLS_ONHOOK, E_DSP_SIG_0100]
zhanglei1
Beginner

以上是2次dubug的输出,我们2个模拟外线,我转内线分机,分机看不到来电,经检测,直接拿话机接到外线上,线路是有来电显示的,所以说线路上应该没问题。
另外,我们现在振铃1声就到语音信箱了。
JK_Chang1
Beginner

cucm dn
Answer Ring Duration (seconds)
提高这参数 就不会只振铃1声
大约三秒是一响
zhanglei1
Beginner

JK_Chang1 发表于 2015-5-14 16:34 back.gif
cucm dn
Answer Ring Duration (seconds)
提高这参数 就不会只振铃1声

这个参数在哪里配置?貌似没有看到。
来电显示跟这个有关系吗?网关貌似就没接到来电显示的信息。
Content for Community-Ad