取消
显示结果 
搜索替代 
您的意思是: 
cancel
公告

December 2020

December 2020

December 2020

946
查看次数
0
有帮助
5
回复
huihuxu735715
Beginner

ASA5516 9.8版本配置PPPOE命令,防火墙接口没有获取到地址

当前场景为一台ASA5516防火墙,现在在用的运营商线路是给的固定公网IP地址,但是先在新增加一条PPPOE拨号的宽带,配置好命令后,show ip address  接口没有获取到IP地址  官网手册配置为:

interface Ethernet0/1
nameif outside
security-level 0

pppoe client vpdn group CHN

--------------------------

mtu  outside 1492

vpdn group CHN request dialout pppoe 

vpdn group CHN localname cisco

vpdn group CHN ppp authentication pap

vpdn username cisco password *********

 

主要就是以上这些 我的配置:


interface GigabitEthernet1/5
nameif outside-pppoe
security-level 0
ip address pppoe setroute

-------------------------

mtu outside-pppoe 1492
vpdn group isp request dialout pppoe
vpdn group isp localname 02543082802
vpdn group isp ppp authentication pap
vpdn username 02543082802 password *****

 

这边的用户名密码, 我的理解是宽带拨号时使用的账号密码,不知道是不是

1 个已接受解答

已接受的解答

如果是这样的话,怀疑通过的DHCP分配的IP地址,而不是需要PPPOE?

如果静态配置也可以上网的话,您可以使用PBR来做某个网段的策略。

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Rps-Cheers | If it solves your problem, please mark as answer. Thanks !

在原帖中查看解决方案

5 条回复5
huihuxu735715
Beginner

忘了补充一个问题,笔记本用网线直接接入PPPOE的宽带上,是可以直接获取到一个私网地址192.168.1.2,然后网关是192.168.1.2

Rps-Cheers
Collaborator

参考示例:ASA PPPoE Client
!
vpdn group PPPoE request dialout pppoe
vpdn group PPPoE localname test@cisco.com
vpdn group PPPoE ppp authentication chap
vpdn username test@cisco.com password cisco
!
interface GigabitEthernet0/0
nameif outside
security-level 0
pppoe client vpdn group PPPoE
ip address pppoe setroute
no shutdown
!
mtu outside 1492
!

可以试试看,另外网关应该是192.168.1.1吧?

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Rps-Cheers | If it solves your problem, please mark as answer. Thanks !

我的配置和您分享的基本是一致的,当用笔记本电脑直连宽带时,我注意到笔记本(自动获取)是直接获取到了IP地址192.168.1.2,此时我还没有输入用户名密码进行拨号上网,当我把192.168.1.2配置到防火墙的接口上,在和宽带直连,防火墙可以ping通192.168.1.1 那是否说明我可以使用BPR让内网某个网段从192.168.1.1这个接口出去上网

如果是这样的话,怀疑通过的DHCP分配的IP地址,而不是需要PPPOE?

如果静态配置也可以上网的话,您可以使用PBR来做某个网段的策略。

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Rps-Cheers | If it solves your problem, please mark as answer. Thanks !

根据你的描述,笔记本其实已经通过DHCP获取私网IP了,这时候如果你笔记本还没有PPPOE就已经能正常上网,说明并不需要PPPOE拨号。

对应到ASA侧配置,就不需要再配置PPPOE相关配置了;对应Outside接口下手动配置IP、默认路由指向网关IP,以及配置PAT相关配置,即可上网。

创建
认可您的同行
Content for Community-Ad