取消
显示结果 
搜索替代 
您的意思是: 
cancel
公告

December 2020

December 2020

2579
查看次数
0
有帮助
1
回复
123zhouyong
Beginner

ASA9.1版本NAT问题

本帖最后由 123zhouyong 于 2015-8-4 17:35 编辑
sh run
: Saved
:
ASA Version 9.1(2)
!
hostname ciscoasa
enable password 8Ry2YjIyt7RRXU24 encrypted
names
!
interface GigabitEthernet0/0
nameif outside
security-level 0
ip address 172.18.120.248 255.255.255.0
!
interface GigabitEthernet0/1
nameif inside
security-level 100
ip address 10.10.10.1 255.255.255.252
!
interface GigabitEthernet0/2
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/3
<--- More --->
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/4
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/5
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
management-only
nameif management
security-level 100
no ip address
!
boot system disk0:/asa912-smp-k8.bin
<--- More --->
ftp mode passive
object network 50000
host 192.168.1.98
object network 3389
host 192.168.1.98
object network 4899
host 192.168.1.98
object network 8001
host 192.168.1.97
object network 8002
host 192.168.1.97
object network 8003
host 192.168.1.97
object network 8004
host 192.168.1.97
object network 1433
host 192.168.1.97
object network 8081
host 192.168.1.97
object network 8887
host 192.168.1.97
object network 9998
host 192.168.1.97
object network 8989
<--- More --->
host 192.168.1.97
object network inside-outside-all
subnet 0.0.0.0 0.0.0.0
access-list outside_access_in extended permit icmp any any
access-list outside_access_in extended permit ip any any
access-list outside_access_in extended permit tcp any any
access-list outside_access_in extended permit udp any any
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu management 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-713.bin
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
!
object network 50000
nat (inside,outside) static interface service tcp 50000 50000
object network 3389
nat (inside,outside) static interface service tcp 3389 3389
object network 4899
nat (inside,outside) static interface service tcp 4899 4899
<--- More --->
object network 8001
nat (inside,outside) static interface service tcp 8001 8001
object network 8002
nat (inside,outside) static interface service tcp 8002 8002
object network 8003
nat (inside,outside) static interface service tcp 8003 8003
object network 8004
nat (inside,outside) static interface service tcp 8004 8004
object network 1433
nat (inside,outside) static interface service tcp 1433 1433
object network 8081
nat (inside,outside) static interface service tcp 8081 8081
object network 8887
nat (inside,outside) static interface service tcp 8887 8887
object network 9998
nat (inside,outside) static interface service tcp 9998 9998
object network 8989
nat (inside,outside) static interface service tcp 8989 8989
object network inside-outside-all
nat (inside,outside) dynamic interface
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 172.18.120.2 1
route inside 192.168.1.0 255.255.255.0 10.10.10.2 1
route inside 192.168.100.0 255.255.255.0 10.10.10.2 1
<--- More --->
route inside 192.168.101.0 255.255.255.0 10.10.10.2 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpool policy
telnet timeout 5
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
<--- More --->
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
<--- More --->
inspect tftp
inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:0107a2d6ddb4e9310d3754a4f5f5785c
: end
ciscoasa#
ciscoasa#
ciscoasa#
ciscoasa# show nat det
ciscoasa# show nat detail
Auto NAT Policies (Section 2)
1 (inside) to (outside) source static 1433 interface service tcp 1433 1433
translate_hits = 0, untranslate_hits = 0
Source - Origin: 192.168.1.97/32, Translated: 172.18.120.248/24
Service - Protocol: tcp Real: 1433 Mapped: 1433
2 (inside) to (outside) source static 8001 interface service tcp 8001 8001
translate_hits = 0, untranslate_hits = 0
Source - Origin: 192.168.1.97/32, Translated: 172.18.120.248/24
Service - Protocol: tcp Real: 8001 Mapped: 8001
3 (inside) to (outside) source static 8002 interface service tcp 8002 8002
translate_hits = 0, untranslate_hits = 0
Source - Origin: 192.168.1.97/32, Translated: 172.18.120.248/24
Service - Protocol: tcp Real: 8002 Mapped: 8002
4 (inside) to (outside) source static 8003 interface service tcp 8003 8003
translate_hits = 0, untranslate_hits = 0
Source - Origin: 192.168.1.97/32, Translated: 172.18.120.248/24
Service - Protocol: tcp Real: 8003 Mapped: 8003
5 (inside) to (outside) source static 8004 interface service tcp 8004 8004
translate_hits = 0, untranslate_hits = 0
Source - Origin: 192.168.1.97/32, Translated: 172.18.120.248/24
Service - Protocol: tcp Real: 8004 Mapped: 8004
6 (inside) to (outside) source static 8081 interface service tcp 8081 8081
translate_hits = 0, untranslate_hits = 0
Source - Origin: 192.168.1.97/32, Translated: 172.18.120.248/24
<--- More --->
Service - Protocol: tcp Real: 8081 Mapped: 8081
7 (inside) to (outside) source static 8887 interface service tcp 8887 8887
translate_hits = 0, untranslate_hits = 0
Source - Origin: 192.168.1.97/32, Translated: 172.18.120.248/24
Service - Protocol: tcp Real: 8887 Mapped: 8887
8 (inside) to (outside) source static 8989 interface service tcp 8989 8989
translate_hits = 0, untranslate_hits = 0
Source - Origin: 192.168.1.97/32, Translated: 172.18.120.248/24
Service - Protocol: tcp Real: 8989 Mapped: 8989
9 (inside) to (outside) source static 9998 interface service tcp 9998 9998
translate_hits = 0, untranslate_hits = 0
Source - Origin: 192.168.1.97/32, Translated: 172.18.120.248/24
Service - Protocol: tcp Real: 9998 Mapped: 9998
10 (inside) to (outside) source static 3389 interface service tcp 3389 3389
translate_hits = 0, untranslate_hits = 0
Source - Origin: 192.168.1.98/32, Translated: 172.18.120.248/24
Service - Protocol: tcp Real: 3389 Mapped: 3389
11 (inside) to (outside) source static 4899 interface service tcp 4899 4899
translate_hits = 0, untranslate_hits = 0
Source - Origin: 192.168.1.98/32, Translated: 172.18.120.248/24
Service - Protocol: tcp Real: 4899 Mapped: 4899
12 (inside) to (outside) source static 50000 interface service tcp 50000 50000
translate_hits = 0, untranslate_hits = 0
Source - Origin: 192.168.1.98/32, Translated: 172.18.120.248/24
<--- More --->
Service - Protocol: tcp Real: 50000 Mapped: 50000
13 (inside) to (outside) source dynamic inside-outside-all interface
translate_hits = 0, untranslate_hits = 0
Source - Origin: 0.0.0.0/0, Translated: 172.18.120.248/24
ciscoasa#
ciscoasa#
按照官方文档写的端口映射,为什么不成功
show nat det 显示NAT已经做好了,但是接上线之后没有数据流量的转发,求大神指导下
1 条回复1
flexjohndou
Beginner

难道一定要写成access-list outside_access_in extended permit ip any object 50000 ?
不能显示该小部件。