取消
显示结果 
搜索替代 
您的意思是: 
cancel
公告

December 2020

数据中心思科Nexus设备Qos实战部署

343
查看次数
0
有帮助
0
评论

       常见的数据中心之间通信均会采用运营商MSTP/OTN专线进行互联实现通信,由于长途线路价格昂贵通常我们需要最大化使用线路带宽,传统的网络传输中通常是尽力而为传输一旦突发流量较大就会发生线路拥塞的情况,从而影响业务正常通信传输。这时候我们可以采用Qos技术来实现数据中心思科设备之间关键网络流量保障,从而实现链路最大化利用。

拓扑图场景如下:

微信截图_20210915213652.png

如上图,SW01是位于数据中心A的广域网接入Cisco Nexus 3048交换机,SW02是位于数据中心B的广域网接入Cisco Nexus 3048交换机,SW01和SW02之间为运营商MSTP/OTN专线,由于专线带宽有限,此时我们需要通过Qos来保证关键业务流量正常传输。

此时我们计划针对关键业务流量保障10M带宽,我们可以采用如下配置CLI来实现:

SW01:

ip access-list qos_10M
permit ip 192.168.0.0/16  172.16.0.0/16


class-map type qos match-any qos_10M
match access-group name qos_10M

class-map type queuing 10M_Class_Queuing
match qos-group 8

policy-map type qos 10M_SET_QoS_Group
class qos_10M
set qos-group 8
class class-default

policy-map type queuing 10M_Policy_Queuing
class type queuing 10M_Class_Queuing
priority
shape kbps 10000 min 10000
class type queuing class-default

class-map type network-qos 10M_Class_nq
match qos-group 8

policy-map type network-qos Global_Network_QoS_10M
class type network-qos 10M_Class_nq
mtu 1500

 

system qos
service-policy type qos input 10M_SET_QoS_Group
service-policy type network-qos Global_Network_QoS_10M

 

interface Ethernet1/1
service-policy type queuing output 10M_Policy_Queuing

 

SW02:

ip access-list qos_10M
permit ip  172.16.0.0/16 192.168.0.0/16 

 

lass-map type qos match-any qos_10M
match access-group name qos_10M

class-map type queuing 10M_Class_Queuing
match qos-group 8

policy-map type qos 10M_SET_QoS_Group
class qos_10M
set qos-group 8
class class-default


policy-map type queuing 10M_Policy_Queuing
class type queuing 10M_Class_Queuing
priority
shape kbps 10000 min 10000
class type queuing class-default

class-map type network-qos 10M_Class_nq
match qos-group 8


policy-map type network-qos Global_Network_QoS_10M
class type network-qos 10M_Class_nq
mtu 1500

system qos
service-policy type qos input 10M_SET_QoS_Group
service-policy type network-qos Global_Network_QoS_10M

 

interface Ethernet1/1
service-policy type queuing output 10M_Policy_Queuing

 

验证:

show class-map type queuing 10M_Policy_Queuing
show policy-map
show queuing interface ethernet 1/1

show logging

通过如上命令来验证Qos生效情况,检查对应队列是否有数据匹配情况,通过show logging检查是否有Qos active的log日志。

此时即使线路拥塞也会给ACL中匹配的关键应用预留10M带宽,从而确保数据中心业务高可用,实现数据快速转发。需要注意的是Cisco Nexus 设备较传统的Cat系列、ASR、ISR系列配置较多些,命令有所区别。