取消
显示结果 
搜索替代 
您的意思是: 
cancel
公告

December 2020

December 2020

3761
查看次数
10
有帮助
6
回复
zzrboss
Beginner

有关,VPC一个问题,就是物理口,UP,但是.port-channel显示没有成员,就是不起来.

配置.
DSW-A# sh run int port-channel 1525
!Command: show running-config interface port-channel1525
!Time: Thu Oct 25 10:45:23 2018
version 5.1(3)N2(1)
DSW-A# sh run int e123/1/26
!Command: show running-config interface Ethernet123/1/26
!Time: Thu Oct 25 10:45:30 2018
version 5.1(3)N2(1)
interface Ethernet123/1/26
switchport access vlan 295
channel-group 1525 mode active
interface port-channel1525
switchport access vlan 295
vpc 1525
DSW-B# sh run int port-channel 1525
!Command: show running-config interface port-channel1525
!Time: Thu Oct 25 10:46:45 2018
version 5.1(3)N2(1)
interface port-channel1525
switchport access vlan 295
vpc 1525
DSW-B# sh run int e124/1/26
!Command: show running-config interface Ethernet124/1/26
!Time: Thu Oct 25 10:47:15 2018
version 5.1(3)N2(1)
interface Ethernet124/1/26
switchport access vlan 295
channel-group 1525 mode active
------------------------------------------------------
DSW-A# sh int port-channel 1525
port-channel1525 is down (No operational members)
vPC Status: Down, vPC number: 1525 [packets forwarded via vPC peer-link]
Hardware: Port-Channel, address: 0cd9.96ce.245b (bia 0cd9.96ce.245b)
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA
Port mode is access
auto-duplex, 1000 Mb/s
Input flow-control is off, output flow-control is on
Switchport monitor is off
EtherType is 0x8100
Members in this channel: Eth123/1/26
Last clearing of "show interface" counters never
30 seconds input rate 520 bits/sec, 0 packets/sec
30 seconds output rate 3896 bits/sec, 7 packets/sec
Load-Interval #2: 5 minute (300 seconds)
input rate 1.07 Kbps, 1 pps; output rate 4.58 Kbps, 7 pps
RX
250465635884 unicast packets 0 multicast packets 27806 broadcast packets
250465663690 input packets 249611926014584 bytes
0 jumbo packets 0 storm suppression bytes
0 runts 0 giants 0 CRC 0 no buffer
0 input error 0 short frame 0 overrun 0 underrun 0 ignored
0 watchdog 0 bad etype drop 0 bad proto drop 0 if down drop
0 input with dribble 0 input discard
0 Rx pause
TX
266678274905 unicast packets 7060547 multicast packets 460729958 broadcast packets
267176773236 output packets 249460536309323 bytes
350738 jumbo packets
30707826 output errors 0 collision 0 deferred 0 late collision
0 lost carrier 0 no carrier 0 babble 0 output discard
0 Tx pause
0 interface resets
DSW-A# sh int e123/1/26
Ethernet123/1/26 is up
Hardware: 100/1000 Ethernet, address: 0cd9.96ce.245b (bia 0cd9.96ce.245b)
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA
Port mode is access
full-duplex, 1000 Mb/s
Beacon is turned off
Input flow-control is off, output flow-control is on
Switchport monitor is off
EtherType is 0x8100
Last link flapped 00:08:00
Last clearing of "show interface" counters never
30 seconds input rate 808 bits/sec, 0 packets/sec
30 seconds output rate 3912 bits/sec, 7 packets/sec
Load-Interval #2: 5 minute (300 seconds)
input rate 904 bps, 1 pps; output rate 4.30 Kbps, 7 pps
RX
125232818355 unicast packets 0 multicast packets 13903 broadcast packets
125232832258 input packets 124805963051943 bytes
0 jumbo packets 0 storm suppression bytes
0 runts 0 giants 0 CRC 0 no buffer
0 input error 0 short frame 0 overrun 0 underrun 0 ignored
0 watchdog 0 bad etype drop 0 bad proto drop 0 if down drop
0 input with dribble 0 input discard
0 Rx pause
TX
133339137866 unicast packets 3530337 multicast packets 230367264 broadcast packets
133588389380 output packets 124730268360885 bytes
175369 jumbo packets
15353913 output errors 0 collision 0 deferred 0 late collision
0 lost carrier 0 no carrier 0 babble 0 output discard
0 Tx pause
13 interface resets
------------------------------
另一台.

DSW-B# sh int e124/1/26
Ethernet124/1/26 is down (Link not connected)
Hardware: 100/1000 Ethernet, address: 005f.86ee.f45b (bia 005f.86ee.f45b)
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA
Port mode is access
auto-duplex, auto-speed
Beacon is turned off
Input flow-control is off, output flow-control is on
Switchport monitor is off
EtherType is 0x8100
Last link flapped 43week(s) 0day(s)
Last clearing of "show interface" counters never
30 seconds input rate 0 bits/sec, 0 packets/sec
30 seconds output rate 0 bits/sec, 0 packets/sec
Load-Interval #2: 5 minute (300 seconds)
input rate 0 bps, 0 pps; output rate 40 bps, 0 pps
RX
0 unicast packets 0 multicast packets 0 broadcast packets
0 input packets 0 bytes
0 jumbo packets 0 storm suppression bytes
0 runts 0 giants 0 CRC 0 no buffer
0 input error 0 short frame 0 overrun 0 underrun 0 ignored
0 watchdog 0 bad etype drop 0 bad proto drop 0 if down drop
0 input with dribble 0 input discard
0 Rx pause
TX
0 unicast packets 69104 multicast packets 31508 broadcast packets
100612 output packets 22897480 bytes
0 jumbo packets
0 output errors 0 collision 0 deferred 0 late collision
0 lost carrier 0 no carrier 0 babble 0 output discard
0 Tx pause
3 interface resets
DSW-B# sh int port-channel 1525
port-channel1525 is down (No operational members)
vPC Status: Down, vPC number: 1525 [packets forwarded via vPC peer-link]
Hardware: Port-Channel, address: 0000.0000.0000 (bia 0000.0000.0000)
MTU 1500 bytes, BW 100000 Kbit, DLY 10 usec
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA
Port mode is access
auto-duplex, auto-speed
Input flow-control is off, output flow-control is on
Switchport monitor is off
EtherType is 0x8100
Members in this channel: Eth124/1/26
Last clearing of "show interface" counters never
30 seconds input rate 0 bits/sec, 0 packets/sec
30 seconds output rate 0 bits/sec, 0 packets/sec
Load-Interval #2: 5 minute (300 seconds)
input rate 0 bps, 0 pps; output rate 40 bps, 0 pps
RX
0 unicast packets 0 multicast packets 0 broadcast packets
0 input packets 0 bytes
0 jumbo packets 0 storm suppression bytes
0 runts 0 giants 0 CRC 0 no buffer
0 input error 0 short frame 0 overrun 0 underrun 0 ignored
0 watchdog 0 bad etype drop 0 bad proto drop 0 if down drop
0 input with dribble 0 input discard
0 Rx pause
TX
0 unicast packets 138199 multicast packets 63016 broadcast packets
201215 output packets 45792206 bytes
0 jumbo packets
0 output errors 0 collision 0 deferred 0 late collision
0 lost carrier 0 no carrier 0 babble 0 output discard
0 Tx pause
0 interface resets
6 条回复6
Fusen Huang
Cisco Employee


show lacp nei inter po 1525 看一下
server 双上联,AA 还是 AS?
zzrboss
Beginner

服务器与交换机做AA模式.
DSW-B# sh run int port-channel 1525
!Command: show running-config interface port-channel1525
!Time: Thu Oct 25 21:12:00 2018
version 5.1(3)N2(1)
interface port-channel1525
switchport access vlan 295
vpc 1525
DTV-N5K-SD-2F03-B15-DSW-B# sh lacp neighbor interface port-channel 1525
DTV-N5K-SD-2F03-B15-DSW-B#
-DSW-A# sh lacp neighbor interface port-channel 1525
Flags: S - Device is sending Slow LACPDUs F - Device is sending Fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode
port-channel1525 neighbors
Partner's information
Partner Partner Partner
Port System ID Port Number Age Flags
Eth123/1/26 0,0-0-0-0-0-0 0x0 0 SP
LACP Partner Partner Partner
Port Priority Oper Key Port State
0 0x0 0x0
DTV-N5K-SD-2F03-A15-DSW-A#
zzrboss
Beginner

DSW-A# sh lacp interface e123/1/26
Interface Ethernet123/1/26 is individual
Channel group is 1525 port channel is Po1525
PDUs sent: 869634
PDUs rcvd: 0
Markers sent: 0
Markers rcvd: 0
Marker response sent: 0
Marker response rcvd: 0
Unknown packets rcvd: 0
Illegal packets rcvd: 0
Lag Id: [ [(0, 0-0-0-0-0-0, 0, 0, 0), (0, 0-0-0-0-0-0, 0, 0, 0)] ]
Operational as aggregated link since Thu Jan 1 08:00:00 1970
Local Port: Eth123/1/26 MAC Address= 54-7f-ee-b0-d4-c1
System Identifier=0x8000,54-7f-ee-b0-d4-c1
Port Identifier=0x8000,0x381a
Operational key=34293
LACP_Activity=active
LACP_Timeout=Long Timeout (30s)
Synchronization=IN_SYNC
Collecting=true
Distributing=true
Actor Admin State=(Ac-1:To-1:Ag-1:Sy-0:Co-0:Di-0:De-0:Ex-0)
Actor Oper State=(Ac-1:To-0:Ag-1:Sy-1:Co-1:Di-1:De-1:Ex-0)
Neighbor: 0/0
MAC Address= 0-0-0-0-0-0
System Identifier=0x0,0-0-0-0-0-0
Port Identifier=0x0,0x0
Operational key=0
LACP_Activity=unknown
LACP_Timeout=Long Timeout (30s)
Synchronization=NOT_IN_SYNC
Collecting=false
Distributing=false
Partner Admin State=(Ac-0:To-1:Ag-0:Sy-0:Co-0:Di-0:De-0:Ex-0)
Partner Oper State=(Ac-0:To-0:Ag-0:Sy-0:Co-0:Di-0:De-0:Ex-0)
zzrboss
Beginner

DSW-B# sh interface e124/1/26
Ethernet124/1/26 is down (Link not connected)
Hardware: 100/1000 Ethernet, address: 005f.86ee.f45b (bia 005f.86ee.f45b)
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA
Port mode is access
auto-duplex, auto-speed
Beacon is turned off
Input flow-control is off, output flow-control is on
Switchport monitor is off
EtherType is 0x8100
Last link flapped 43week(s) 1day(s)
Last clearing of "show interface" counters never
30 seconds input rate 0 bits/sec, 0 packets/sec
30 seconds output rate 80 bits/sec, 0 packets/sec
Load-Interval #2: 5 minute (300 seconds)
input rate 0 bps, 0 pps; output rate 40 bps, 0 pps
RX
0 unicast packets 0 multicast packets 0 broadcast packets
0 input packets 0 bytes
0 jumbo packets 0 storm suppression bytes
0 runts 0 giants 0 CRC 0 no buffer
0 input error 0 short frame 0 overrun 0 underrun 0 ignored
0 watchdog 0 bad etype drop 0 bad proto drop 0 if down drop
0 input with dribble 0 input discard
0 Rx pause
TX
0 unicast packets 69731 multicast packets 31508 broadcast packets
101239 output packets 23089342 bytes
0 jumbo packets
0 output errors 0 collision 0 deferred 0 late collision
0 lost carrier 0 no carrier 0 babble 0 output discard
0 Tx pause
3 interface resets
DSW-B# sh lacp interface e124/1/26
Interface Ethernet124/1/26 is invalid
Channel group is 0 port channel is
PDUs sent: 0
PDUs rcvd: 0
Markers sent: 0
Markers rcvd: 0
Marker response sent: 0
Marker response rcvd: 0
Unknown packets rcvd: 0
Illegal packets rcvd: 0
Lag Id: [ [(0, 0-0-0-0-0-0, 0, 0, 0), (0, 0-0-0-0-0-0, 0, 0, 0)] ]
Operational as aggregated link since Thu Jan 1 08:00:00 1970
Local Port: Eth124/1/26 MAC Address= 54-7f-ee-a9-1-41
System Identifier=0x8000,54-7f-ee-a9-1-41
Port Identifier=0x8000,0x0
Operational key=0
LACP_Activity=passive
LACP_Timeout=Long Timeout (30s)
Synchronization=NOT_IN_SYNC
Collecting=false
Distributing=false
Actor Admin State=(Ac-0:To-0:Ag-0:Sy-0:Co-0:Di-0:De-0:Ex-0)
Actor Oper State=(Ac-0:To-0:Ag-0:Sy-0:Co-0:Di-0:De-0:Ex-0)
Neighbor: 0/0
MAC Address= 0-0-0-0-0-0
System Identifier=0x0,0-0-0-0-0-0
Port Identifier=0x0,0x0
Operational key=0
LACP_Activity=unknown
LACP_Timeout=Long Timeout (30s)
Synchronization=NOT_IN_SYNC
Collecting=false
Distributing=false
Partner Admin State=(Ac-0:To-0:Ag-0:Sy-0:Co-0:Di-0:De-0:Ex-0)
Partner Oper State=(Ac-0:To-0:Ag-0:Sy-0:Co-0:Di-0:De-0:Ex-0)
DTV-N5K-SD-2F03-B15-DSW-B#
Fusen Huang
Cisco Employee

对于 DSW-A, 问题应该是在对端 server,LACP 设置可能有 misconfiguration.
1. LACP PDU 对于 nexus,有去无回,协商有问题,所以在 individual 状态,不在 port-channel
DSW-A# sh lacp interface e123/1/26
Interface Ethernet123/1/26 is individual <<<<<
Channel group is 1525 port channel is Po1525
PDUs sent: 869634
PDUs rcvd: 0 <<<<
2. LACP PDU 的状态,其中对端的 Ag-0 字段异常,应该是 Ag-1,表示可以聚合
Local
Actor Oper State=(Ac-1:To-0:Ag-1:Sy-1:Co-1i-1e-1:Ex-0)
Partner
Partner Oper State=(Ac-0:To-0:Ag-0:Sy-0:Co-0i-0e-0:Ex-0)
3. 可以参考之前我给客户的回复
063133o27dq2k5k9k2x7sq.jpeg
对于 DSW-B, 可以先删除 port-channel 配置,观察物理口是否能up
最后建议,开 TAC case,让 TAC online 看一下
zzrboss
Beginner

fushuang 发表于 2018-10-26 06:33
对于 DSW-A, 问题应该是在对端 server,LACP 设置可能有 misconfiguration.
1. LACP PDU 对于 nexus,有 ...

非常感谢,该信息对我很有帮助。幸苦了。
创建
认可您的同行
Content for Community-Ad