取消
显示结果 
搜索替代 
您的意思是: 
cancel
公告

December 2020

5952
查看次数
54
有帮助
6
回复
xy411381121
Participant

请教N7K+N2K环境下BPDU Guard的问题

与生成树有关的配置如下:
spanning-tree vlan 110 priority 28672
interface Ethernet102/1/13
switchport
switchport access vlan 12
no shutdown
interface Ethernet102/1/15
switchport
switchport access vlan 12
no shutdown
N7K_01# show span sum
Switch is in rapid-pvst mode
Root bridge for: VLAN0012, VLAN0110, VLAN0780, VLAN0800
Port Type Default is disable
Edge Port [PortFast] BPDU Guard Default is disabled
Edge Port [PortFast] BPDU Filter Default is disabled
Bridge Assurance is enabled
Loopguard Default is disabled
Pathcost method used is short
STP-Lite is enabled
日志如下:
094604b6lllq5j5bl85qww.jpg
Ethernet102/1/13与Ethernet102/1/15这两个端口之前没有使用,昨天施工跳线才用到这两个端口。
昨出现了几秒临时闪断,我看了下日志,其他都正常,只有BPDU Guard的日志有点儿可疑,正好当时有施工人员在机房跳线,一开始怀疑是不是端口启用了边缘端口,出现临时环路引起中断,然后BPDU Guard功能强制关闭了这两个端口,阻断了环路,网络恢复正常,这样引起的几秒临时闪断,但是今天来现场看了下配置,发端口没有配置边缘端口,也没有启用BPDU Guard功能。
请问,为什么日志你会产生BPDU Guard的日志?
6 条回复6
jingjian
Advocate

默认配置,不会显示在配置文件中
N2K设计只用来连接server,BUDU Guard默认开启
xy411381121
Participant

arvinjing 发表于 2018-8-3 12:16
默认配置,不会显示在配置文件中
N2K设计只用来连接server,BUDU Guard默认开启

因为这两个端口应该是接两台服务器的,但是端口收到BPDU包了,所以今早我们这里为了排查是不是跳错线了,但是发现线路没有接错,N2K接到配线架1,到配线架2,再到服务器,服务器还是关机状态,这为什么会出现BPDU包啊?
edupxl
Beginner

我这也有有类似问题,只要向N2K上插一个叫钉钉无线AP的设备,就会让端口 BPDUGuard errDisable
limingkui
Beginner

接口开启spanning-tree port type edge
Jim—Jin
Cisco Employee

spanning-tree bpduguard enable在FEX的HIF上是默认配置,可以通过show run interface e102/1/13 all看到。
另外如果这个接口对端接的是关机的服务器的话,理论上接口不会up一下。很有可能是当时接口对端误连到设备上。
liu_zhimin
Rising star

请确认下N2K下是否接了交换机设备
Content for Community-Ad