取消
显示结果 
搜索替代 
您的意思是: 
cancel
公告

December 2020

[原创翻译] 重发布OSPF E2路由进BGP

6781
查看次数
40
有帮助
10
评论
本帖最后由 weidhuan 于 2015-6-29 12:59 编辑
重发布OSPF E2路由进BGP

简介:
OSPF 外部路由(E2)在通告进 OSPF 自治系统(AS)的时候会带有特地的开销值,并且次开销值在整个AS里自始至终都不会改变。外部路由是通过对其他的动态路由协议、静态路由或者直连网段进行重发布而学习到的。执行重发布操作的路由器被称为自治系统边界路由器(ASBR)。默认情况下,通过重发布学习到的路由都是 E2 类型的。
把 OSPF 路由(E1 或 E2)重发布进 BGP,通常有两种方法,本文着重讲解 E2 路由。
a) 通过 “redistribute ospf 1 match external 2” 命令
b) 使用 route-map match 语句 “match route-type external type-2”
使用 route-map 给用户带来了更大的灵活性,用户可以根据不同的标准来匹配路由,如 access-list, tag 等。
预备知识:

  • 了解 OSPF 路由协议
  • 了解 边界网关协议 (BGP)

背景摘要:
本文着重介绍使用 route-map 来匹配 E2 类型的路由,进而把它们重发布进其他的路由系统。三台路由器 R1、R2、R3 通过串行接口相连,R1 和 R2 位于 OSPF 区域 0,R2 和 R3 在 AS 100 里建立 BGP 邻居关系。
在 R1 上,环回接口 Lo2 和 Lo3 都重发布进了 OSPF,通过名为 “CONNECTED” 的route-map 来匹配特地的接口,并使用“redistribute connected route-map CONNECTED” 来进行重发布。 在 R2 上,使用了一个 route-map 来单独匹配 E2 类型的路由前缀,并重发布进 BGP 系统(见R2 配置中名为 E2OSPF 的route-map)。
拓扑图:
125720at0ee7u6tqcqtee7.png



R1 R2 R3

hostname R1

!

ip cef

!

no ip domain lookup

!

interface Loopback0

ip address 1.1.1.1 255.255.255.255

!

interface Loopback2

ip address 2.2.2.2 255.255.255.255

!

interface Loopback3

ip address 3.3.3.3 255.255.255.255

!

interface Serial0/0

ip address 10.12.12.1 255.255.255.252

clock rate 2000000

!

router ospf 10

router-id 1.1.1.1

log-adjacency-changes

redistribute connected subnets route-map CONNECTED

network 10.12.12.1 0.0.0.0 area 0

!

route-map CONNECTED permit 10

match interface Loopback2 Loopback3

!

end


hostname R2

!

ip cef

!

no ip domain lookup

!

interface Loopback0

ip address 22.22.22.22 255.255.255.255

!

interface Serial0/0

ip address 10.12.12.2 255.255.255.252

clock rate 2000000

!

interface Serial0/1

ip address 192.23.23.1 255.255.255.252

clock rate 2000000

!

router ospf 10

router-id 22.22.22.22

log-adjacency-changes

network 10.12.12.2 0.0.0.0 area 0

!

router bgp 100

no synchronization

bgp router-id 22.22.22.22

bgp log-neighbor-changes

network 192.23.23.1 mask 255.255.255.255

redistribute ospf 10 route-map E2OSPF

neighbor 192.23.23.2 remote-as 100

neighbor 192.23.23.2 next-hop-self

no auto-summary

!

route-map E2OSPF permit 10

match route-type external type-2

!

end

hostname R3

!

ip cef

!

no ip domain lookup

!

interface Loopback0

ip address 33.33.33.33 255.255.255.255

!

interface Serial0/0

ip address 192.23.23.2 255.255.255.252

clock rate 2000000

!

router bgp 100

no synchronization

bgp router-id 33.33.33.33

bgp log-neighbor-changes

network 192.23.23.2 mask 255.255.255.255

neighbor 192.23.23.1 remote-as 100

no auto-summary

!

end


验证:

show ip route ospf
125716k897l733jj8djjj2.png
show route-map {route-map name}
125731obw42db4232f3n4k.png
show ip route BGP
125728tle9eqal9u9rpkal.png
原文链接:https://supportforums.cisco.com/document/99756/redistribute-ospf-e2-routes-bgp
原文作者:SunilKhanna
评论
blgao
Cisco Employee
支持下!
cpmld-199
Community Member
谢谢楼主分享。
suzhouxiaoniu
Advocate
支持一下,课时图看不到,上面各位,都能看到图吗?
Fisheryu
Cisco Employee
:P:P:P
Fusen Huang
Cisco Employee
谢谢楼主分享
linchen2
Community Member
赞一个
linlinwa
Cisco Employee
谢谢楼主分享
taosun2
Cisco Employee
赞!!!!
chundli
Cisco Employee
漂亮!
yongche2
Cisco Employee
学习学习
创建
认可您的同行
Content for Community-Ad