取消
显示结果 
搜索替代 
您的意思是: 
cancel
公告

December 2020

【原创】Cisco Vipteal SD-WAN实验

10815
查看次数
70
有帮助
33
评论
前段时间一直再看思科的SD-WAN介绍,都是基于胶片。想找个环境来具体实验下,查看很多资料都是基于官网文档,看起来确实很吃力。只能摸索这做个“简单”的实验,后续的实验慢慢研究,此文做了个记录。
实验目的
将Site1个Site2两路由的环回口1.1.1.1和2.2.2.2之间能正常通信。
其实这么“简单”的一件小事需要费一些周折。。。
本次实验将分为四个部分
1,vManage、vBond、vSmart、vEdge及其他设备的初始化
2,vManage、vBond、vSmart、vEdge的证书处理
3,vManage添加vBond、vSmart、vEdge设备
4,两站点之间路由做通
注:实验所需的环境和文件及怎么搭建不在此做其他说明
实验拓扑
195432bi8h48qh6r4i42sq.png
设备的互联如上图所示,vManage接了一个带外便于远程使用Web管理。
设备地址及相关信息
设备 站点 ID System-IP 接口IP 版本
vManage 100 100.1.1.1 10.1.1.1 16.3.2->17.2.0
vBond 100 100.1.1.2 10.1.1.2 16.3.2->17.2.0
vSmart 100 100.1.1.3 10.1.1.3 16.3.2->17.2.0
vEdge1 1 101.1.1.1 172.16.1.1 17.2.0
Site1 - 1.1.1.1 192.168.1.1 -
vEdge2 2 102.1.1.1 172.16.2.1 17.2.0
Site2 - 2.2.2 192.168.2.1 -

重点: 这里需要说明下vManage、vBond、vSmart是先用16.3.2然后升级到17.2.0。因为vManage到17.X.X及以后的版本需要SmartAccount账号到思科官网生成vEdge的认证文件导入vManage才能添加vEdge,而17.X.X之前的版本可以手动创建编辑CSV文件到入到vManage。vEdge用17.X.X是因为之前的版本不能使用自己生成的证书验证。
所以此处是设备先都安装证书然后添加vEdge的认证文件,等vManage升级到17.2.0后再添加vEdge设备。但是一旦设备升级到17.2.0后将无法手动编辑添加vEdge认证文件。
vManage、vBond、vSmart、vEdge及其他设备的初始化
vManage初始配置
system
host-name vmanage
system-ip 100.1.1.1
site-id 100
organization-name iteachs.com
vbond 10.1.1.2
vpn 0
interface eth0
ip address 10.1.1.1/24
no tunnel-interface
no shutdown
!
ip route 0.0.0.0/0 10.1.1.254
!
vpn 512
interface eth1
ip address 192.168.188.61/24
no shutdown
!
ip route 0.0.0.0/0 192.168.188.254
!
commit and-quit


vBond初始配置
system
host-name vbond
system-ip 100.1.1.2
organization-name iteachs.com
vbond 10.1.1.2 local vbond-only
vpn 0
interface ge0/0
ip address 10.1.1.2/24
no tunnel-interface
no shutdown
!
ip route 0.0.0.0/0 10.1.1.254
!
commit and-quit

vSmart初始配置
system
host-name vsmart
system-ip 100.1.1.3
site-id 100
organization-name iteachs.com
vbond 10.1.1.2
!
vpn 0
interface eth0
ip address 10.1.1.3/24
no tunnel-interface
no shutdown
!
ip route 0.0.0.0/0 10.1.1.254
!
commit and-quit
以上为一些摘要,由于文章太长加上我之前的笔记是markdown写的图片也很多,所以我就直接上传附件了。其实我想说后台的编辑很难用~!
管理能设置下附件收费吗?给我加点金币好在论坛换点书看看,支持原创啊。。。

评论
yancheng wang
Beginner
本帖最后由 906158750 于 2020-4-10 13:20 编辑
wuhao0015 发表于 2020-4-10 10:36
搞了各服务器做的,硬件不需要太强大。

pdf文档看完了,就是证书有的步骤不是太明白,其中有个vEdge的证书导入,最后的时候,在不可用的时候,什么操作后,变成了可用状态
wuhao0015
Rising star
906158750 发表于 2020-4-10 11:15
pdf文档看完了,就是证书有的步骤不是太明白,其中有个vEdge的证书导入,最后的时候,在不可用的时候,什 ...

点Valid就可用了。。。
sunbin03351
Beginner
请教版主 这个是和EVE集成的吗?
wuhao0015
Rising star
sunbin03351 发表于 2020-4-15 08:37
请教版主 这个是和EVE集成的吗?

是在EVE里面运行的。。。主要是拓扑管理方便。。
yongtong.zhu1
Community Member
楼主给力,谢谢分享
elitepublic.net
Beginner
感谢楼主分享,谢谢~
136629092@qq.com
Beginner
点赞啊 宝贵的资料
shuaige91662
Beginner
博主这个实验你是通过统一管理设备manage来管理其他设备吗
ShaNing84
Community Member

感谢楼主分享,谢谢~
csco11500747
Community Member
感谢分享。
sunbin03351
Beginner
这个实验环境是怎么搭建达,怎么和eve集成啊
saitohimeajj
Community Member
感谢技术大佬分享
支持楼主支持原创
jinfayao71459
Community Member
eve里面模拟的吗
jinmaichen
Beginner
用eve做的嘛
Content for Community-Ad