取消
显示结果 
搜索替代 
您的意思是: 
cancel
公告

December 2020

[工具分享]手把手教你-利用VACL抓包

5970
查看次数
70
有帮助
16
评论
本帖最后由 xupeng 于 2015-4-19 21:22 编辑
VACL Capture(VACL抓包)


-VLAN ACL(VACL)可以对数据包提供访问控制, 包括同一VLAN内转发的数据包,以及跨VLAN转发的数据包.
-VACL的行为包括:
Drop (丢弃)
Forward [capture] (转发[抓包])
Redirect (重定向)
-capture的行为会将被转发的数据包的capture bit置位,因此,在抓包的接口会收到这些数据包.
-只在Catalyst 6500 / Cisco 7600 支持VACL Capture.


=========
配置案例
=========


ip access-list extended INTERESTING_TRAFFIC //定义ACL来匹配感兴趣流量,这些流量将被发送到抓包的接口.
permit ip host 10.1.100.1 any
permit ip any host 10.1.100.1
ip access-list extended PERMIT_ALL //定义ACL放行剩下的流量
permit ip any any
!
vlan access-map VACL_CAPTURE 10 //定义一个VLAN access-map, 名称是'VACL_CAPTURE'
match ip address INTERESTING_TRAFFIC //匹配定义好的ACL 'INTERESTING_TRAFFIC'
action forward capture //将流量放行并且抓包(关键字capture)
vlan access-map VACL_CAPTURE 20
match ip address PERMIT_ALL //匹配定义好的ACL 'PERMIT_ALL'
action forward //将匹配的流量放行
!
vlan filter VACL_CAPTURE vlan-list 10 //定义VLAN filter名'VACL_CAPTURE',并应用到VLAN 10
!
interface GigabitEthernet1/9 //将Gi1/9作为接收数据包的接口
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport capture //配置接口接收被VACL filter抓到的流量.
!
评论
blgao
Cisco Employee
支持下!
suizeng
Beginner
{:3_41:}
Fusen Huang
Cisco Employee
谢谢楼主分享
Fisheryu
Cisco Employee
Engineer Peng, galivable !
Lin Zhang
Beginner
赞,支持 :D
qwe2
Community Member
谢谢楼主分享
linchen2
Community Member
赞一个
pengxu
Community Member
:P
赞~~~~
chundli
Cisco Employee
赞赞赞
yanzha4
Participant
px精华
nantian021
Community Member
写的太棒了
suzhouxiaoniu
Engager
刚刚还有人问我VACL来着的,很巧啊;P
luxing0418
Beginner
支持一下~~~
suzhouxiaoniu
Engager
CPU排错的东西,一个都不能放过,谢谢分享
lelwu
Cisco Employee
赞!
不能显示该小部件。