取消
显示结果 
搜索替代 
您的意思是: 
cancel
公告

December 2020

N5K // Basic LACP troubleshooting

6505
查看次数
40
有帮助
5
评论
Troubleshooting LACP issues
这里有一些非常基本的故障排除步骤LACP(port-channels)。
Config guide:
http://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus5000/sw/configuration/guide/cli_rel_4_0_1a/CLIConfigurationGuide/EtherChannel.html
Problem 1:
客户不能做LACP,提示以下报错。
24.09.5010A.2(config-if)# channel-group 1 mode active
LACP process needs to be started before configuring active mode <-------------
Solution 1:
开启feature
24.09.5010A.2(config-if)# feature lacp
24.09.5010A.2(config)# int e1/1
24.09.5010A.2(config-if)# channel-group 1 mode active <--- allowed now
Problem 2:
端口在I或者S状态
# sh port-channel summary
Flags: D - Down P - Up in port-channel (members)
I - Individual H - Hot-standby (LACP only)
s - Suspended r - Module-removed
S - Switched R - Routed
U - Up (port-channel)
M - Not in use. Min-links not met
--------------------------------------------------------------------------------
Group Port- Type Protocol Member Ports
Channel
--------------------------------------------------------------------------------
1 Po1(SD) Eth LACP Eth1/1(I) <------------------------------
Troubleshooting:
Step 1: 检查配置,我们需要确保我们是LACP设置,主机匹配速率/双工模式,等等。
interface port-channel1
switchport mode trunk
interface Ethernet1/1
switchport mode trunk
channel-group 1 mode active
步骤2:明确lacp计数器,并确保我们收到LACPDUs。如果收不到,端口不会up.这些计数器将默认每30秒增加。
24.09.5010A.2# clear lacp counters
172.18.121.121# sh lacp counters
LACPDUs Marker Marker Response LACPDUs
Port Sent Recv Sent Recv Sent Recv Pkts Err
---------------------------------------------------------------------
port-channel1
Ethernet1/1 3 0 0 0 0 0 0 <----------
24.09.5010A.2# sh lacp counters
LACPDUs Marker Marker Response LACPDUs
Port Sent Recv Sent Recv Sent Recv Pkts Err
---------------------------------------------------------------------
port-channel1
Ethernet1/1 4 0 0 0 0 0 0
步骤3:检查显示lacp接口,看看他们是同步的,下面的邻居信息不应该所有都是0。
24.09.5010A.2(config-if)# sh lacp interface e1/1
Interface Ethernet1/1 is individual
Channel group is 1 port channel is Po1
PDUs sent: 4
PDUs rcvd: 0
Markers sent: 0
Markers rcvd: 0
Marker response sent: 0
Marker response rcvd: 0
Unknown packets rcvd: 0
Illegal packets rcvd: 0
Lag Id: [ [(0, 0-0-0-0-0-0, 0, 0, 0), (0, 0-0-0-0-0-0, 0, 0, 0)] ]
Operational as aggregated link since Mon Apr 30 14:17:43 2012
Local Port: Eth1/1 MAC Address= 0-5-73-cd-37-c1
System Identifier=0x8000,0-5-73-cd-37-c1
Port Identifier=0x8000,0x111
Operational key=0
LACP_Activity=active
LACP_Timeout=Long Timeout (30s)
Synchronization=IN_SYNC
Collecting=true
Distributing=true
Partner information refresh timeout=Long Timeout (90s)
Actor Admin State=(Ac-1:To-1:Ag-1:Sy-0:Co-0:Di-0:De-0:Ex-0)
Actor Oper State=(Ac-1:To-0:Ag-1:Sy-1:Co-1:Di-1:De-1:Ex-0)
Neighbor: 0/0 <-------------------------------
MAC Address= 0-0-0-0-0-0
System Identifier=0x0,0-0-0-0-0-0
Port Identifier=0x0,0x0
Operational key=0
LACP_Activity=unknown
LACP_Timeout=Long Timeout (30s)
Synchronization=NOT_IN_SYNC
Collecting=false
Distributing=false
Partner Admin State=(Ac-0:To-1:Ag-0:Sy-0:Co-0:Di-0:De-0:Ex-0)
Partner Oper State=(Ac-0:To-0:Ag-0:Sy-0:Co-0:Di-0:De-0:Ex-0)
第四步:尝试删除通道组的端口,看看我们是否可以从服务器ping通N5K。你需要在同一子网IP主机测试。
24.09.5010A.2(config)# int e1/1
24.09.5010A.2(config-if)# no channel-group
24.09.5010A.2(config-if)# exit
24.09.5010A.2(config)# feature interface-vlan <--- turn on the feature, this is NON-disruptive
24.09.5010A.2(config)# int vlan 100 <--- create a SVI in the same vlan as the host
24.09.5010A.2(config-if)# ip address 1.1.1.1/24 <----- assign an IP in the same vlan as the host
24.09.5010A.2(config-if)# end
24.09.5010A.2# ping 1.1.1.2
PING 1.1.1.2 (1.1.1.2): 56 data bytes
64 bytes from 1.1.1.2: icmp_seq=0 ttl=254 time=1.605 ms
64 bytes from 1.1.1.2: icmp_seq=1 ttl=254 time=0.992 ms
64 bytes from 1.1.1.2: icmp_seq=2 ttl=254 time=1.028 ms
64 bytes from 1.1.1.2: icmp_seq=3 ttl=254 time=1.204 ms
64 bytes from 1.1.1.2: icmp_seq=4 ttl=254 time=1.008 ms
第五步:尝试把端口加回到portchannel
24.09.5010A.2(config)# int e1/1
24.09.5010A.2(config-if)# channel-group 1 mode active
24.09.5010A.2(config-if)# end
24.09.5010A.2# ping 1.1.1.2
PING 1.1.1.2 (1.1.1.2): 56 data bytes
Request 0 timed out
Request 1 timed out
Request 2 timed out
Request 3 timed out
Request 4 timed out
第六步:尝试mode on模式
24.09.5010A.2(config)# int e1/1
24.09.5010A.2(config)# no channel-group
24.09.5010A.2(config-if)# channel-group 1 <---- without mode active, this is mode on (forcing port-channel up)
24.09.5010A.2(config-if)# end
24.09.5010A.2# ping 1.1.1.2
24.09.5010A.2# ping 1.1.1.2
PING 1.1.1.2 (1.1.1.2): 56 data bytes
64 bytes from 1.1.1.2: icmp_seq=0 ttl=254 time=1.605 ms
64 bytes from 1.1.1.2: icmp_seq=1 ttl=254 time=0.992 ms
64 bytes from 1.1.1.2: icmp_seq=2 ttl=254 time=1.028 ms
64 bytes from 1.1.1.2: icmp_seq=3 ttl=254 time=1.204 ms
64 bytes from 1.1.1.2: icmp_seq=4 ttl=254 time=1.008 ms
可能的解决方式:
客户需要检查server是不是支持LACP,如果不支持的话只能配置mode on模式了。也有可能是对端设备有bug的情况。
Troubleshooting Commands
debug lacp error
show lacp interface ethernet
show lacp internal info interface ethernet detail fsmlog
show lacp internal event-history errors
show lacp internal event-history msgs
show port-channel internal event-history interface ethernet
show port-channel internal event-history msgs
show system internal ethpm event-history interface ethernet
show system internal ethpm info interface ethernet
show lacp internal info int eX/Y detail fsmlog
show clock
评论
Fusen Huang
Cisco Employee
谢谢楼主分享!
Fisheryu
Cisco Employee
:o:o:o:o
xupeng
Cisco Employee
谢谢楼主分享!
cpmld-199
Community Member
谢谢分享,学习了。
sxsure001
Beginner
赞赞 谢谢分享
创建
认可您的同行
Content for Community-Ad