取消
显示结果 
搜索替代 
您的意思是: 
cancel
公告

December 2020

December 2020

2227
查看次数
6
有帮助
3
回复
Rockyw
Advisor

#分享达人#【思科】热备份路由选择协议HSRP+VRRP实战!


实验拓扑

实验需求

在M1配置HSRP使其成为VLAN10的主设备,在M2配置HSRP使其成为VLAN10的备设备。

在M2配置VRRP使其成为VLAN20的主设备,在M1配置VRRP使其成为VLAN20的备设备。

配置步骤


IP规划

VLAN10 :192.168.10.0/24 网关:192.168.10.1

VLAN20 :192.168.20.0/24 网关:192.168.20.1

C1 :192.168.10.100/24

C2 :192.168.20.100/24

M1 VLAN10:192.168.10.10/24

M1 VLAN20:192.168.20.10/24

M1 F1/1 :12.0.0.2/30

M2 VLAN10:192.168.10.20/24

M2 VLAN20:192.168.20.20/24

M2 F1/1 :13.0.0.2/30

R1 F0/1 :12.0.0.1/30

R1 F0/0 :13.0.0.1/30

R1 环回 :1.1.1.1/32


SW1配置

SW1(config)#vlan 10,20

SW1(config-vlan)#exit

SW1(config)#interface f1/1

SW1(config-if)#switchport access vlan 10

SW1(config-if)#int f1/2

SW1(config-if)#switchport access vlan 20

SW1(config-if)#int rang f1/14 -15

SW1(config-if-range)#switchport mode trunk

SW1(config-if-range)#switchport trunk encapsulation dot1q


VLAN10 HSRP M1配置


M1(config)#vlan 10,20

M1(config-vlan)#int f1/15

M1(config-if)#sw mode trunk

M1(config-if)#sw trunk encapsulation dot1q

M1(config-if)#no shutdown

M1(config-if)#int vlan 10

M1(config-if)#ip add 192.168.10.10 255.255.255.0

M1(config-if)#no shutdown

M1(config-if)#standby 1 ip 192.168.10.1 //设置虚拟网关

M1(config-if)#standby 1 preempt //设置抢占,当对方优先级比我低的时候立即抢占主

M1(config-if)#standby 1 priority 120 //配置优先级,默认为100如果链路出现问题会自动减10

M1(config-if)#exit

M1(config)#track 1 interface f1/1 line-protocol //定义一个要追踪的接口,如果上行接口down了是不会切换的所以要监测一下上行的端口

M1(config-track)#int vlan 10

M1(config-if)#standby 1 track 1 //追踪上行端口


VLAN10 HSRP M2配置


M2(config)#vlan 10,20

M2(config-vlan)#int f1/15

M2(config-if)#sw mode trunk

M2(config-if)#sw trunk enc dot1q

M2(config-if)#no shutdown

M2(config-if)#int vlan 10

M2(config-if)#ip add 192.168.10.20 255.255.255.0

M2(config-if)#no shutdown

M2(config-if)#standby 1 ip 192.168.10.1

M2(config-if)#standby 1 preemt


M2(config-if)#standby 1 priority 115 //备设备的优先级要比主设备要小,如果相同则比较2个设备的端口号端口号小的为主设备


VLAN20 VRRP M2配置

VRRP配置和HSRP一样只是"standby"换成了"vrrp"

M2(config)#int vlan 20

M2(config-if)#ip add 192.168.20.20 255.255.255.0

M2(config-if)#vrrp 1 ip 192.168.20.1

M2(config-if)#vrrp 1 preempt

M2(config-if)#vrrp 1 priority 120

M2(config-if)#exit

M2(config)#track 1 interface f1/1 line-protocol

M2(config-if)#vrrp 1 track 1


VLAN20 VRRP M1配置


M1(config)#int vlan 20


M1(config-if)#ip add 192.168.20.10 255.255.255.0


M1(config-if)#vrrp 1 ip 192.168.20.1

M1(config-if)#vrrp 1 priority 115

M1(config-if)#vrrp 1 preempt


------------------------------流量倒换测试-----------------------------------------------

用C1去ping R1的环回口

跟踪一下C1的路由,C1的主为M1,M1的vlan10 IP为192.168.10.10

用C1去一直ping 1.1.1.1,然后将M1的上行口shutdown看流量是否能够切换

跟踪路由,VLAN10的备用设备是M2 vlan10 IP为192.168.10.20

通过show standby brief 查看一下M1的状态,会发现活跃的设备IP是192.168.10.20(备设备),优先级由原来的120变为了110.


通过以上实验会发现丢了一个包之后流量由主设备(M1)切换到了备设备(M2),备份生效。


验证VLAN20的VRRP是否生效


用C2 ping R1的环回口

跟踪一下路由,VLAN20的主设备应该是M2 vlan20的IP为192.168.20.20

将M2的上行口shutdown,看是否切换到备设备

跟踪路由,备设备为M1 vlan20接口IP为192.168.20.10

通过验证发现丢了2个包后流量成功从主设备切换到了被设备



注意:如果住设备被抢修好优先级会变回原来的120,会自动抢占主


HSRP为思科私有协议,VRRP为标准协议所有厂商都支持


出处:http://11178097.blog.51cto.com/11168097/1958681
3 条回复3
pxhen
Participant

收藏一下啊
李东杰
Beginner

不错的配置案例 收藏了,希望以后能多一些配置案例。
Rockyw
Advisor

李东杰 发表于 2017-8-30 09:57
不错的配置案例 收藏了,希望以后能多一些配置案例。

可以的话,给个评分吧
Content for Community-Ad


不能显示该小部件。