取消
显示结果 
搜索替代 
您的意思是: 
cancel
5437
查看次数
14
有帮助
8
回复

哪儿配置问题呢,求大神赐教

kaoshisk1
Beginner
Beginner
除了R4和R5之前是rip协议,其他区域都是运行OSPF协议,在R4上吧rip协议重分发到ospf协议,但是R1只能ping到R4的s1/3 不能到R5的s1/3 为什么呢。
8 条回复8

ilay
Collaborator
Collaborator
抛开gns3模拟器问题的可能,建议你先把R4、R5的关键配置发一下。比如接口ip,相关的路由进程,重分发配置等等
不然没有办法定位问题所在。

kaoshisk1
Beginner
Beginner
gengchunlin 发表于 2016-4-7 19:21 back.gif
抛开gns3模拟器问题的可能,建议你先把R4、R5的关键配置发一下。比如接口ip,相关的路由进程,重分发配置等 ...

R4的关键配置:
interface Serial1/2
ip address 3.1.1.2 255.255.255.0
serial restart-delay 0
!
interface Serial1/3
ip address 4.1.1.1 255.255.255.0
serial restart-delay 0
!
router ospf 100
log-adjacency-changes
area 2 nssa
redistribute rip subnets
network 3.1.1.0 0.0.0.255 area 2
!
router rip
version 2
network 4.0.0.0
no auto-summary

kaoshisk1
Beginner
Beginner
gengchunlin 发表于 2016-4-7 19:21 back.gif
抛开gns3模拟器问题的可能,建议你先把R4、R5的关键配置发一下。比如接口ip,相关的路由进程,重分发配置等 ...

R5的配置:interface Serial1/3
ip address 4.1.1.2 255.255.255.0
serial restart-delay 0
!
router rip
version 2
network 4.0.0.0
no auto-summary
!

ilay
Collaborator
Collaborator
kaoshisk1 发表于 2016-4-7 22:43 back.gif
R5的配置:interface Serial1/3
ip address 4.1.1.2 255.255.255.0
serial restart-delay 0

你查一下你的R1上面的路由表中有没有R5上面网段的相关路由条目。如果学到了R5的路由。那么问题的根源应该是你的R5没有到达R1的路由条目。
如果要解决的话,需要在R5上面添加相应网段的路由条目,或者在R5上写一条默认路由指向R4

limerez01
Beginner
Beginner
R5没有回包路由,需要指路由,或者R4双向重分发

不适用
既然看了,顶一个吧,好帖子

fortune
VIP Expert VIP Expert
VIP Expert
你这是只做了RIP 到ospf的重发布,没有做ospf到RIP的重发布,这样R5没有到R1的路由怎么会通呢?

superspace521
Beginner
Beginner
单点双向重发布,在把ospf重发布到rip就行了。
入门指南

使用上面的搜索栏输入关键字、短语或问题,搜索问题的答案。

我们希望您在这里的旅程尽可能顺利,因此这里有一些链接可以帮助您快速熟悉思科社区:

快捷链接