取消
显示结果 
搜索替代 
您的意思是: 
cancel
公告

December 2020

603
查看次数
0
有帮助
6
回复
nexusNXOS57758
Beginner

思科9300 RIP协议疑惑

我选择的 是ver2 ,为什么network 感觉还是有类地址,不支持掩码,发送两个 10.67.x.0 的地址 被合并成 10.0.0.0了
按理说V1是有类地址,V2应该是无类地址,能精确到掩码啊
interface Vlan705
description Route_Vlan_A21-A21
ip address 10.67.2.17 255.255.255.252
!
interface Vlan706
description Route_Vlan_A21-A22
ip address 10.67.2.21 255.255.255.252
!
router rip
version 2
network 10.0.0.0
no auto-summary
6 条回复6
Rps-Cheers
Rising star

show ip route呢?
RIP的配置应该OK的哦
141655176876927
Beginner

你在配置 10.67.x.0 的地址 时是不是后面没有加掩码
应该配置
network 10.67.1.0 0.0.0.255
network 10.67.2.0 0.0.0.255
……
如果在配置时没有加掩码,那么默认还是主类地址
nexusNXOS57758
Beginner

141655176876927 发表于 2020-12-29 22:47
你在配置 10.67.x.0 的地址 时是不是后面没有加掩码
应该配置
network 10.67.1.0 0.0.0.255

RIP 不支持配掩码
test-10.67.1.65(config-router)#network 10.67.7.0 0.0.0.255
^
% Invalid input detected at '^' marker.
test-10.67.1.65(config-router)#network 10.67.7.0 255.255.255.0
^
% Invalid input detected at '^' marker.
test-10.67.1.65(config-router)#network 10.67.7.0
test-10.67.1.65(config-router)#network 10.67.8.0
test-10.67.1.65(config-router)#
18653465190
Enthusiast

模糊的记忆,好像RIP V2需要激活一下,
tony_tan
Beginner

添加一条no auto-summary,不要汇总,项目上好久没有使用过RIP,你试一下
nexusNXOS57758
Beginner

tony_tan 发表于 2021-1-21 09:00
添加一条no auto-summary,不要汇总,项目上好久没有使用过RIP,你试一下

缺省就是关闭自动汇总
不能显示该小部件。