取消
显示结果 
搜索替代 
您的意思是: 
cancel

请教eigrp的路径选择问题

xy411381121
Participant
Participant
本帖最后由 xy411381121 于 2019-1-24 15:53 编辑
请教一下思科2901路由器上eigrp选路的问题
公司的这部分网络拓扑大致如下:
010942myy9htbb4blzkney.png
eigrp 600与650双向重发布了的。
以ASR-1为例:
router eigrp 600
redistribute eigrp 650
network 192.12.66.0 0.0.0.3
auto-summary
router eigrp 650
redistribute eigrp 600
network 172.29.197.96 0.0.0.3
no auto-summary
目前在R1上路径追踪ASR-1的F0/0口走的是R2的通道
R1#traceroute 192.12.66.1 so 172.29.197.98
Type escape sequence to abort.
Tracing the route to 192.12.66.1
1 192.168.1.226 28 msec 20 msec 20 msec
2 172.29.197.101 32 msec 44 msec 44 msec
3 192.12.66.6 60 msec 80 msec 56 msec
4 12.1.1.1 92 msec 68 msec 104 msec
5 192.12.66.1 52 msec 76 msec 52 msec
应该还是ASR与N7K的100M与1000M那里产生了次优路由,该怎么决绝EIGRP次优路由着问题呢?
我补充一下路由器表信息:
R1上:192.12.66.0/30网段的路由
R1#sho ip rou 192.12.66.0 255.255.255.252
Routing entry for 192.12.66.0/30
Known via "eigrp 650", distance 170, metric 1762816, type external
Redistributing via eigrp 650
Last update from 192.168.1.227 on GigabitEthernet0/0, 21:27:55 ago
Routing Descriptor Blocks:
* 192.168.2.227, from 192.168.2.227, 21:27:55 ago, via GigabitEthernet0/1
Route metric is 1762816, traffic share count is 1
Total delay is 20040 microseconds, minimum bandwidth is 2048 Kbit
Reliability 254/255, minimum MTU 1500 bytes
Loading 6/255, Hops 4
192.168.1.227, from 192.168.1.227, 21:27:55 ago, via GigabitEthernet0/0
Route metric is 1762816, traffic share count is 1
Total delay is 20040 microseconds, minimum bandwidth is 2048 Kbit
Reliability 254/255, minimum MTU 1500 bytes
Loading 6/255, Hops 4
R1#sho ip eigrp topology 192.12.66.0 255.255.255.252
EIGRP-IPv4 Topology Entry for AS(650)/ID(172.29.200.173) for 192.12.66.0/30
State is Passive, Query origin flag is 1, 2 Successor(s), FD is 1762816
Descriptor Blocks:
192.168.1.227 (GigabitEthernet0/0), from 192.168.1.227, Send flag is 0x0
Composite metric is (1762816/1762560), route is External
Vector metric:
Minimum bandwidth is 2048 Kbit
Total delay is 20040 microseconds
Reliability is 254/255
Load is 6/255
Minimum MTU is 1500
Hop count is 4
Originating router is 192.12.66.13
External data:
AS number of route is 600
External protocol is EIGRP, external metric is 26368
Administrator tag is 0 (0x00000000)
192.168.2.227 (GigabitEthernet0/1), from 192.168.2.227, Send flag is 0x0
Composite metric is (1762816/1762560), route is External
Vector metric:
Minimum bandwidth is 2048 Kbit
Total delay is 20040 microseconds
Reliability is 254/255
Load is 6/255
Minimum MTU is 1500
Hop count is 4
Originating router is 192.12.66.13
External data:
AS number of route is 600
External protocol is EIGRP, external metric is 26368
Administrator tag is 0 (0x00000000)
172.29.197.97 (Serial0/3/0:0), from 172.29.197.97, Send flag is 0x0
Composite metric is (1764352/28160), route is External
Vector metric:
Minimum bandwidth is 2048 Kbit
Total delay is 20100 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
Originating router is 192.12.66.9
External data:
AS number of route is 600
External protocol is EIGRP, external metric is 0
Administrator tag is 0 (0x00000000)
EIGRP-IPv4 Topology Entry for AS(600)/ID(172.29.200.173)
%Entry 192.12.66.0/30 not in topology table
R1#
1 个已接受解答

已接受的解答

alton.tang
Beginner
Beginner
本帖最后由 ts1110 于 2019-1-25 12:17 编辑
这个就是一个简单的EIGRP选路问题,上次没有注意LZ环境中的带宽问题!
当前R1去往192.12.66.0/30网段有两条路径:
第一条:走ASR-1
走ASR-1时,由于在ASR-1上重分发时没有修改过任何Metric值的参数,所以Metric值的计算如下:
最小带宽 = 2048kbp
延迟之和 = R1的S1/0接口的延迟(20000ms)+ ASR-1的F0/0接口的延迟(该接口为100M口,延迟为100ms) = 20100ms
第二条路:走R2,走R2时,有两个接口,其Metric值计算一样!
走R2时,由于在ASR-2上重分发时没有修改过任何Metric值的参数,所以Metric值的计算如下:
最小带宽 = 2048kbp
延迟之和 = R1的F0/0接口的延迟(该接口为1000M口,延迟为10ms)+ R2的S1/0接口的延迟(20000ms)+ ASR-2的F0/0接口的延迟(该接口为1000M口,延迟为10ms)+ N7K-2的F0/1接口的延迟(该接口为1000M口,延迟为10ms)+ N7K-1的F0/0接口的延迟(该接口为1000M口,延迟为10ms)= 20040ms
综上所述,在R1上对比两条路
带宽一样,第二条的延迟小一些,所有选择第二条路,没问题!
所以LZ的图示上有问题,N7K-1的F0/0肯定是一个1000M接口!
-----------------------------------------------------------------
-----------------------------------------------------------------
如果要使得R1走ASR-1的话,解决办法无外乎一下几种:
第一种:修改N7K-1的接口延迟,将其延迟修改成100M接口的延迟100ms,这样修改后,将会导致R2去往192.12.66.0/30网段走R1,是否满足LZ需求,酌情处理!
第二种:在ASR-1上做重分发时,修改延迟,具体修改多少,LZ自己计算!
第三种:在R1上做offset-list,具体怎么做,就不再熬述!
第四种:在R1上使用distribute-list做过滤,不收R2发送过来的192.12.66.0/30网路的路由!

在原帖中查看解决方案

8 条回复8

alton.tang
Beginner
Beginner
本帖最后由 ts1110 于 2019-1-25 12:17 编辑
这个就是一个简单的EIGRP选路问题,上次没有注意LZ环境中的带宽问题!
当前R1去往192.12.66.0/30网段有两条路径:
第一条:走ASR-1
走ASR-1时,由于在ASR-1上重分发时没有修改过任何Metric值的参数,所以Metric值的计算如下:
最小带宽 = 2048kbp
延迟之和 = R1的S1/0接口的延迟(20000ms)+ ASR-1的F0/0接口的延迟(该接口为100M口,延迟为100ms) = 20100ms
第二条路:走R2,走R2时,有两个接口,其Metric值计算一样!
走R2时,由于在ASR-2上重分发时没有修改过任何Metric值的参数,所以Metric值的计算如下:
最小带宽 = 2048kbp
延迟之和 = R1的F0/0接口的延迟(该接口为1000M口,延迟为10ms)+ R2的S1/0接口的延迟(20000ms)+ ASR-2的F0/0接口的延迟(该接口为1000M口,延迟为10ms)+ N7K-2的F0/1接口的延迟(该接口为1000M口,延迟为10ms)+ N7K-1的F0/0接口的延迟(该接口为1000M口,延迟为10ms)= 20040ms
综上所述,在R1上对比两条路
带宽一样,第二条的延迟小一些,所有选择第二条路,没问题!
所以LZ的图示上有问题,N7K-1的F0/0肯定是一个1000M接口!
-----------------------------------------------------------------
-----------------------------------------------------------------
如果要使得R1走ASR-1的话,解决办法无外乎一下几种:
第一种:修改N7K-1的接口延迟,将其延迟修改成100M接口的延迟100ms,这样修改后,将会导致R2去往192.12.66.0/30网段走R1,是否满足LZ需求,酌情处理!
第二种:在ASR-1上做重分发时,修改延迟,具体修改多少,LZ自己计算!
第三种:在R1上做offset-list,具体怎么做,就不再熬述!
第四种:在R1上使用distribute-list做过滤,不收R2发送过来的192.12.66.0/30网路的路由!

suzhouxiaoniu
Advocate
Advocate
本帖最后由 suzhouxiaoniu 于 2019-2-18 16:53 编辑
双向多点重分发环路的解决方法有很多,比如重分发过滤,比如路由标记等等

alton.tang
Beginner
Beginner
楼上兄弟有误导,这里跟AD没有关系,R1从ASR-1哪里学到的为外部路由,从R2哪里学习的到的也是外部路由,AD一样!
把LZ的环境还原了一下,R1去ASR-1的F0/0,是直接走S1/0接口的!
R1#show ip eigrp neighbors 
EIGRP-IPv4 Neighbors for AS(650)
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
2 192.168.1.226 Et0/0 12 00:17:08 10 100 0 19
1 192.168.2.226 Et0/1 14 00:17:08 9 100 0 18
0 172.29.197.98 Se1/0 11 00:17:16 17 102 0 7

R1#show ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR
Gateway of last resort is not set
12.0.0.0/30 is subnetted, 1 subnets
D EX 12.1.1.0 [170/2221056] via 172.29.197.98, 00:13:54, Serial1/0
172.29.0.0/16 is variably subnetted, 3 subnets, 2 masks
D 172.29.197.100/30
[90/2195456] via 192.168.2.226, 00:15:42, Ethernet0/1
[90/2195456] via 192.168.1.226, 00:15:42, Ethernet0/0
192.12.66.0/30 is subnetted, 2 subnets
D EX 192.12.66.0 [170/2195456] via 172.29.197.98, 00:14:15, Serial1/0
D EX 192.12.66.4 [170/2221056] via 192.168.2.226, 00:13:54, Ethernet0/1
[170/2221056] via 192.168.1.226, 00:13:54, Ethernet0/0

R1#traceroute 192.12.66.1 source serial 1/0
Type escape sequence to abort.
Tracing the route to 192.12.66.1
VRF info: (vrf in name/id, vrf out name/id)
1 172.29.197.98 10 msec * 10 msec
R1#

18653465190
Enthusiast
Enthusiast
在ASR-1和ASR-2上,写前缀列表,匹配自己发布的路由,分别把在600和650下,将自己发布路由过滤掉。
形成次优是因为出现路由回灌情况,就是把自己发布出去的路由,又重新发布回自己的区域了。

xy411381121
Participant
Participant
ts1110 发表于 2019-1-23 11:11
楼上兄弟有误导,这里跟AD没有关系,R1从ASR-1哪里学到的为外部路由,从R2哪里学习的到的也是外部路由,AD ...

DCS-1#sho ip rou 192.12.66.0 255.255.255.252
Routing entry for 192.12.66.0/30
Known via "eigrp 650", distance 170, metric 1762816, type external
Redistributing via eigrp 650
Last update from 192.168.1.227 on GigabitEthernet0/0, 21:27:55 ago
Routing Descriptor Blocks:
* 192.168.2.227, from 192.168.2.227, 21:27:55 ago, via GigabitEthernet0/1
Route metric is 1762816, traffic share count is 1
Total delay is 20040 microseconds, minimum bandwidth is 2048 Kbit
Reliability 254/255, minimum MTU 1500 bytes
Loading 6/255, Hops 4
192.168.1.227, from 192.168.1.227, 21:27:55 ago, via GigabitEthernet0/0
Route metric is 1762816, traffic share count is 1
Total delay is 20040 microseconds, minimum bandwidth is 2048 Kbit
Reliability 254/255, minimum MTU 1500 bytes
Loading 6/255, Hops 4
DCS-1#sho ip eigrp topology 192.12.66.0 255.255.255.252
EIGRP-IPv4 Topology Entry for AS(650)/ID(172.29.200.173) for 192.12.66.0/30
State is Passive, Query origin flag is 1, 2 Successor(s), FD is 1762816
Descriptor Blocks:
192.168.1.227 (GigabitEthernet0/0), from 192.168.1.227, Send flag is 0x0
Composite metric is (1762816/1762560), route is External
Vector metric:
Minimum bandwidth is 2048 Kbit
Total delay is 20040 microseconds
Reliability is 254/255
Load is 6/255
Minimum MTU is 1500
Hop count is 4
Originating router is 192.12.66.13
External data:
AS number of route is 600
External protocol is EIGRP, external metric is 26368
Administrator tag is 0 (0x00000000)
192.168.2.227 (GigabitEthernet0/1), from 192.168.2.227, Send flag is 0x0
Composite metric is (1762816/1762560), route is External
Vector metric:
Minimum bandwidth is 2048 Kbit
Total delay is 20040 microseconds
Reliability is 254/255
Load is 6/255
Minimum MTU is 1500
Hop count is 4
Originating router is 192.12.66.13
External data:
AS number of route is 600
External protocol is EIGRP, external metric is 26368
Administrator tag is 0 (0x00000000)
172.29.197.97 (Serial0/3/0:0), from 172.29.197.97, Send flag is 0x0
Composite metric is (1764352/28160), route is External
Vector metric:
Minimum bandwidth is 2048 Kbit
Total delay is 20100 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
Originating router is 192.12.66.9
External data:
AS number of route is 600
External protocol is EIGRP, external metric is 0
Administrator tag is 0 (0x00000000)
EIGRP-IPv4 Topology Entry for AS(600)/ID(172.29.200.173)
%Entry 192.12.66.0/30 not in topology table
DCS-1#

xy411381121
Participant
Participant
suzhouxiaoniu 发表于 2019-1-21 09:43
管理距离的问题,ASR-1的F0/0口对R1来说,直接从ASR-1到达,由于在不同个AS号,所以属于外部路由DEX,管理距 ...

我补充了真实设备上的路由表信息与拓扑表信息
600的重发布到650时,R1上与R2上都是外部路由,都是170,但为什么路由表里就选择了R2的?是因为AS 600里ASR-1与ASR-2的100M与1000M链路造成的吗?

xy411381121
Participant
Participant
18653465190 发表于 2019-1-23 17:07
在ASR-1和ASR-2上,写前缀列表,匹配自己发布的路由,分别把在600和650下,将自己发布路由过滤掉。
形成次 ...

我补充了真实设备上的路由表信息与拓扑表信息
600的重发布到650时,R1上与R2上都是外部路由,都是170,但为什么路由表里就选择了R2的?是因为AS 600里ASR-1与ASR-2的100M与1000M链路造成的吗?

xy411381121
Participant
Participant
本帖最后由 xy411381121 于 2019-1-28 17:11 编辑
ts1110 发表于 2019-1-25 12:14
这个就是一个简单的EIGRP选路问题,上次没有注意LZ环境中的带宽问题!
当前R1去往192.12.66.0/30网段有 ...

谢谢了,讲解的很细致。
我在N7K上show int看到的速率都是100M,但延迟却是10ms。如下:
N7K的端口配置:
interface Ethernet10/1
description TO ASR-1 G1/2/0
ip address 192.12.66.2/30
ip router eigrp 600
no shutdown
N7K的端口状态:
Ethernet10/1 is up
admin state is up, Dedicated Interface
Hardware: 10/100/1000 Ethernet, address: 8478.ac1c.7d41 (bia 4c00.82a6.1aa0)
Description: TO ASR-1 G1/2/0
Internet Address is 192.12.66.2/30
MTU 1500 bytes, BW 100000 Kbit, DLY 10 usec
reliability 255/255, txload 11/255, rxload 1/255
Encapsulation ARPA, medium is broadcast
full-duplex, 100 Mb/s
Beacon is turned off
Auto-Negotiation is turned on
Input flow-control is off, output flow-control is off
N7K的端口同样是100M,但默认的延迟是10,ASR上却是100。我想了解下端口默认延迟是由哪些因素决定的啊?设备型号好不同,相同速率的延时都会存在差异吗?
入门指南

使用上面的搜索栏输入关键字、短语或问题,搜索问题的答案。

我们希望您在这里的旅程尽可能顺利,因此这里有一些链接可以帮助您快速熟悉思科社区:

快捷链接