cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
236
Views
0
Helpful
9
Replies
Highlighted
Beginner

Cant ping across Router

ping.pngthe switch that connects to router A
switch1

interface FastEthernet0/1

switchport trunk allowed vlan 10,20

switchport mode trunk

 

interface FastEthernet0/2

switchport trunk allowed vlan 10,20

switchport mode trunk

 

interface FastEthernet0/6

switchport trunk allowed vlan 10,20

switchport mode trunk

 

interface Vlan10

ip address 192.168.10.6 255.255.255.0

 

ip default-gateway 192.168.10.1

 

the switch that connect to router B

switch0(1)

hostname switch0(1)

interface FastEthernet0/1

switchport trunk allowed vlan 10,20

switchport mode trunk

 

interface FastEthernet0/2

switchport trunk allowed vlan 10,20

switchport mode trunk

 

interface FastEthernet0/5

switchport trunk allowed vlan 10,20

switchport mode trunk

 

interface Vlan20

ip address 192.168.20.7 255.255.255.0

ip default-gateway 192.168.20.1

 

router A

hostname RouterA

interface GigabitEthernet0/0

ip address 10.0.0.11 255.0.0.0

 

interface GigabitEthernet0/1

ip address 11.0.0.22 255.0.0.0

 

interface GigabitEthernet0/2

ip address 192.168.10.1 255.255.255.0

 

router ospf 1

log-adjacency-changes

network 192.168.10.0 0.0.0.255 area 0

network 10.0.0.0 0.255.255.255 area 0

network 11.0.0.0 0.255.255.255 area 0

 

router B

hostname RouterB

interface GigabitEthernet0/0
ip address 10.0.0.11 255.0.0.0

interface GigabitEthernet0/1
ip address 11.0.0.12 255.0.0.0
duplex auto
speed auto
!
interface GigabitEthernet0/2
ip address 192.168.20.1 255.255.255.0


interface FastEthernet0/0/3
switchport mode access
switchport nonegotiate

router ospf 1
log-adjacency-changes
network 192.168.20.0 0.0.0.255 area 0
network 10.0.0.0 0.255.255.255 area 0
network 11.0.0.0 0.255.255.255 area 0

PC1 192.168.10.11

PC2 192.168.10.21

PC3 192.168.10.31 

 

PC4 192.168.20.41

PC5 192.168.20.51

PC5 192.168.20.61

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Rising star
Rising star

Re: Cant ping across Router

Hi 

You have duplicate IP address on RouterA and RouterB .. you have assigned same address on both sides. 

Configure sub-interface on Routers for the vlans .. gig0/2.10 on RouterA and gig0/2.20 on RouterB as already suggested.

See attached.

Screenshot 2020-05-22 at 11.31.05.png

View solution in original post

9 REPLIES 9
Highlighted
Hall of Fame Expert

Re: Cant ping across Router on a Stick

Hello @kobe5934 ,

when using a L2 trunk that allows Vlans 10,20 like in your case the router interface has to configure using subinterfaces with appropriate matching 802.1Q encapulation.

 

example:

on routerA:

interface gi0/2

no ip address

interface gi0/2.10

encapsulation 802.1Q 10

ip address 192.168.10.1 255.255.255.0

exit

 

on routerB:

int gi0/2

no ip address

interface gi0/2.20

encapsulation 802.1Q 20

ip address 192.168.20.1 255.255.255.0

 

The subinterfaces numbers can be different but the commands for encapsulation must match the Vlans defined on the switch.

 

Edit:

after examing again your network diagram and configuration you need to configure one subinterface for vlan 10 on RouterA and the other subinterface of RB for vlan 20 gi0/2.20

in any case even with a single subinterface you need to use it because the switch ports are configured as trunks and will send out 802.1Q tagged frames that require subinterface(s) to be processed by the attached router(s).

 

Hope to help

Giuseppe

 

Highlighted
Beginner

Re: Cant ping across Router on a Stick

i am suppose to ping pc1-3 to router A
P4-6 to router B
switch1 to router A

switch0(1) to router B
I need help in this 

Highlighted
Beginner

Re: Cant ping across Router

i am suppose get all ping 

Highlighted
Rising star
Rising star

Re: Cant ping across Router

Hi 

You have duplicate IP address on RouterA and RouterB .. you have assigned same address on both sides. 

Configure sub-interface on Routers for the vlans .. gig0/2.10 on RouterA and gig0/2.20 on RouterB as already suggested.

See attached.

Screenshot 2020-05-22 at 11.31.05.png

View solution in original post

Highlighted
Beginner

Re: Cant ping across Router

what do u mean duplicate ip add ? i an unable to open the file @omz 

 

 

Highlighted
Rising star
Rising star

Re: Cant ping across Router

IP add on RouterA int g0/0 and RouterB g0/0 are the same .. 10.0.0.11/8 .. should be different like g0/1 

using ver 7.3

 

Highlighted
Beginner

Re: Cant ping across Router

ok ty

 

Highlighted
Beginner

Re: Cant ping across Router

may i know what version are u using ?

Highlighted
Beginner

Re: Cant ping across Router

CreatePlease to create content
Content for Community-Ad
Cisco Community April 2020 Spotlight Award Winners