cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4852
Views
5
Helpful
9
Replies

ACI Simulator 5.0 Can't ping after the successfull install

Hello, I am a newbie on ACI that is why I am trying to learn it from simulator first.  We do have the ACI at work, but I wanted to practice in simulator first since I am new to this.

 

Does anyone had an issue accessing APIC after the successful ACI simulator install?  I can't ping or hit the https access.

I kept all the default, I am using VLAN50 for the management IP.  I have another windows machine on the same POrt-Group (VLAN50) in VCENTER DVSwitch that I can ping.  My windows machine is 172.16.0.5/24 and GW is 172.16.0.1/24.  My APIC is 172.16.0.2/24. 

I tried changing to VLAN50 in APIC setup and still not able to ping or access it via https.

I also enabled promiscuous mode in my DVport-group.

Did I missed anything?

 

BTW, not sure if there is an issue with hardware compatibility for ACI simulator?  I am using dell r610 12 core CPU, 64gb ram, 2tb ssd NAS.  I don't have the UCS system in hy homelab.

 

Thanks in advance!

9 Replies 9

Francesco Molino
VIP Alumni
VIP Alumni
Hi

With ACI simulator you have to use vlan 4 in the initial setup otherwise it won’t work. At least for 4.2x releases it was so. Never tested yet with 5.0.

Restart the VM, initial setup will be come up again and use vlan 4. Afterwards it should come up.

Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question

Hi @Francesco,

Basically vlan 4 is using for infrastructure management between spine and leaf, if anyone changed to instead of default then he will never found the spine and leaf for fabric discovery to fabric membership.

For ping issues, in ESXi, change VM Network group to
Promiscuous mode: Accept
MAC Address Changes: Accept
Forged Transmits: Accept

 

Thanks.

@Md. Mahbubul Alam 

Your comment on a 2020 post (3.6 years later) is just more evidence that posts older than 3 months that have not been marked as answered be locked from ADDITIONAL comments being made.

 

RedNectar aka Chris Welsh.
Forum Tips: 1. Paste images inline - don't attach. 2. Always mark helpful and correct answers, it helps others find what they need.

afassl2004
Level 1
Level 1

Hi,

 

I've deployed the ACI 5.0 on an ESXI 6.7 hypervisor. Had the same issue, solution was to enable promiscuous mode and the other two security features (Mac address changes, forged transfer) for the virtual switch.

 

Best regards

Andreas

@afassl2004 thank you very much - this was the fix for me.  Following the documentation I already had promiscuous mode enabled but could not ping.  When I enabled MAC address changes and forged transmits I was almost immediately able to ping the ACI Simulator 4.2(x). 

chulo1922
Level 1
Level 1

Did you ever find a fix for this? I am running into the exact same problem. I have the vswitch configured with promiscuous mode as well as the mac and forged transmits are set to accept. I have other vms that are on the same vswitch and network and they are working fine. I have tried resetting the vm as well as reinstalling with no luck.

 

Thanks

Hi, 

I've written some blog articles on how to install ACI on ESXi and other topics.

Maybe this is helpful?

https://7o9.de/index.php/2020/06/16/the-aci-simulator

 

BR

Andreas

balbaletabrez
Level 1
Level 1

Give this a try....

 

iping -V tenant_name:vrf_name <ipadd> -S <s-ipaddress>

AminRamadan
Level 1
Level 1

In EXSI, I succeeded by changing the port-group of network to Promiscuous mode as it is shown in pic.
Screenshot 2021-08-18 124644.png

Save 25% on Day-2 Operations Add-On License