Showing results for 
Search instead for 
Did you mean: 

Nexus 9396 won't boot NX-OS

pasa barnett
Level 1
Level 1

Switch was shipped with ACI mode, and I am trying to convert it back to standalone mode. I have the NX-OS image on the switch, however; the it will not boot into NX-OS from loader prompt. Can anyone assist?

10 Replies 10

Ryan Bos
Level 1
Level 1


Are you following a specific guide on converting back to standalone NX-OS from ACI mode? For example,

Are you receiving any error messages from the switch when trying to boot your NX-OS image? What NX-OS image version are you trying to boot to?


Yes I am attempting to convert back to standalone mode. I am trying to load image
  n9000-dk9.6.1.2.I3.4b.bin, and below is the error I receive.

Trying to read config file /boot/grub/menu.lst.recovery from (hd1,4)
 Filesystem type is ext2fs, partition type 0x83
No autoboot or failed autoboot. falling to loader


Can you confirm that image is in the bootflash of the switch and that it is not corrupted? The md5 hash of the file should be 76ee482c8f9c082c621380289264c6d7

I have tried 2 images with the same result. Could both images be corrupt?

Unlikely, but anything is possible.

I see that you have another thread on this issue and that is much further along than this thread. Your best bet for this issue would be to open a TAC case so the TAC engineer can see exactly what is going on before, during, and after this error message appears.

It appears Pasa was running into:


We got on a webex and we got his switches successfully converted.


I have a similar problem when converting from ACI to standalone.  Here the issue is that when it goes back to standalone mode, software it not able to recognize the GEM card. This causes it to reboot.  Any suggestions ?

 84 Booting n9000-dk9.7.0.3.I1.3.bin
 85 Trying diskboot
 86  Filesystem type is ext2fs, partition type 0x83
 87 Image valid
 90 Image Signature verification was Successful.
 92 ^MINIT: version 2Loading IGB driver ...
 93 Installing SSE module ... done
 94 Creating the sse device node ... done
 95 Installing CCTRL driver for card_type 6 ...
 96 cat: /var/run/mpaindex: No such file or directory

 97 mpa_card_type=:
 98 >>>>>> NO GEM CARD FOUND !! <<<<<<<
 99 >>>>>>      Rebooting       <<<<<<<
100 >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
101 ^MINIT: SwitchingSending all processes the TERM signal...
102 Sending all processes the KILL signal...
103 Unmounting filesystems...
104 [   15.824480] [1452292663] Restarting system.
106 CISCO SWITCH Ver7.17
107 Device detected on 0:6:0 after 0 msecs
108 Device detected on 0:1:1 after 0 msecs

Two things:

1. Make sure the GEM Module is in the switch and seated well. You may want to try to reseat GEM Module.

2.  Make sure the your GEM Module Model is supported in your release  "n9000-dk9.7.0.3.I1.3.bin"

New Hardware Features in Cisco NX-OS Release 7.0(3)I2(1)

Cisco NX-OS Release 7.0(3)I2(1) supports the following new hardware features:

* Cisco Nexus 31128PQ switch
* Cisco Nexus 9372PX-E switch (enhanced version of the Cisco Nexus 9372PX switch)
* M6PQ-E uplink module (enhanced version of the M6PQ uplink module used for the Cisco Nexus 93120TX, 9396PX, and 9396TX switches)

thanks Tomas.

1) I have already done this re-seating multiple times. And the inventory seems fine:

(none)# show inventory
NAME: "Chassis",  DESCR: "Nexus C9396PX Chassis"
PID: N9K-C9396PX         ,  VID: V03  ,  SN: SAL1946SWZR

NAME: "Slot 1 ",  DESCR: "1/10G Ethernet Module"
PID: N9K-C9396PX         ,  VID: V03  ,  SN: SAL1946SWZR

NAME: "GEM    ",  DESCR: "40G Ethernet Expansion Module"
PID: N9K-M6PQ-E          ,  VID: V01  ,  SN: SAL1945SPMB

2) You may be right on the nxos version though.. i am running n9000-dk9.7.0.3.I1.3.bin, but the hardware is supported from NX-OS Release 7.0(3)I2(1).

Will try with newer software.

Cisco Employee
Cisco Employee

Just to update the thread.

After upgrading to a later image  NXOS: version 7.0(3)I2(2a), the system boots up and GEM card is recognized.

Thanks Tomas

Save 25% on Day-2 Operations Add-On License