cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Community Live- Tenant Routed Multicast in VXLAN EVPN Fabric
851
Views
0
Helpful
9
Replies
Highlighted

ACI Multi-Pod configuration missing ACI 4.1

Hello,

 

I'm using the ACI version 4.1 and I can't find the create multi-pod menu where we used to create multi-pod in previous ACI versions.

I've uploaded a screenshot of my APIC with the menu create multi-pod missing. I could create a pod but can't create the multi-pod configuration with the dedicated menu I knew from previous releases. Can you tell me where I am wrong ?

 

Thanks,

Everyone's tags (2)
9 REPLIES 9
Highlighted
Beginner

Re: ACI Multi-Pod configuration missing ACI 4.1

Hello,

In the left pane, right-click "Pod Fabric Setup Policy", and select "Create Multi-Pod"...

 

Remi Astruc

Highlighted

Re: ACI Multi-Pod configuration missing ACI 4.1

No I tried that but the menu I should have is "Pod Fabric Setup Utility" I think. But it's not there.

I uploaded a picture of my Pod Fabric Setup Policy menu. You can see that I don't have this menu.

Highlighted
Cisco Employee

Re: ACI Multi-Pod configuration missing ACI 4.1

Can you try under Fabric > Inventory > Quick Start > Add Pod. 

 

Please find the screenshot attached.

 

Regards,

Ranganath

Highlighted

Re: ACI Multi-Pod configuration missing ACI 4.1

I tried but the button doesn't lead anywhere, I click and nothing happens ... See my screenshot.

Anyway, I already created a pod with the Pod Fabric setup policy, but I'm looking for the create multi pod menu, as it was in 3.X, but if it has changed, I don't know what to do

Highlighted

Re: ACI Multi-Pod configuration missing ACI 4.1

You're right it's this button => https://www.cisco.com/c/en/us/td/docs/switches/datacenter/aci/apic/sw/4-x/L3-configuration/Cisco-APIC-Layer-3-Networking-Configuration-Guide-411/Cisco-APIC-Layer-3-Networking-Configuration-Guide-411_chapter_010111.html

 

But in my APIC GUI it doesn't work. I click and nothing happens ... If nobody ele has this issue, I think I should reinstall the APIC ..

Highlighted
Cisco Employee

Re: ACI Multi-Pod configuration missing ACI 4.1

You should get a pop-up when you click on "Add Pod", then I would suggest you to go to the top right of the APIC GUI and under settings (under gear icon), select "Show API Inspector" (attached screen shot).  You should get a blank API inspector window. And then try to click on the Add POD on the GUI again which will generate API calls that can be seen on the API inspector window. Review those to see if you find any error/ anything suspicious. If that still doesn't help, please open a TAC case with the logs collected.

 

Regards,

Ranganath

Highlighted

Re: ACI Multi-Pod configuration missing ACI 4.1

I get that from the API inspector :

 

timestamp: 08:53:21 DEBUG method: GET
 
url: https://172.20.2.22/api/node/class/fabricSetupP.json?query-target-filter=wcard(fabricSetupP.dn,%22^uni/controller/setuppol/setupp-1%22) response: {"totalCount":"1","imdata":[{"fabricSetupP":{"attributes":{"annotation":"","childAction":"","configIssues":"","descr":"","dn":"uni/controller/setuppol/setupp-1","extMngdBy":"","lcOwn":"local","modTs":"2018-10-08T03:50:44.874+00:00","monPolDn":"uni/fabric/monfab-default","name":"","nameAlias":"","podId":"1","podType":"physical","status":"","tepPool":"10.1.0.0/16","uid":"0"}}}]}
timestamp: 08:53:21 DEBUG method: GET
 
url: https://172.20.2.22/api/node/class/l3extInfraNodeP.json?query-target-filter=and(wcard(l3extInfraNodeP.dn,%22pod-1%22),eq(l3extInfraNodeP.fabricExtCtrlPeering,%22yes%22)) response: {"totalCount":"2","imdata":[{"l3extInfraNodeP":{"attributes":{"annotation":"","childAction":"","descr":"","dn":"uni/tn-Generali-infra/out-multipod/lnodep-bSpine/rsnodeL3OutAtt-[topology/pod-1/node-1001]/infranodep","extMngdBy":"","fabricExtCtrlPeering":"yes","fabricExtIntersiteCtrlPeering":"no","lcOwn":"local","modTs":"2019-02-12T01:01:56.361+00:00","monPolDn":"uni/tn-common/monepg-default","name":"","nameAlias":"","spineRole":"","status":"","uid":"15374"}}},{"l3extInfraNodeP":{"attributes":{"annotation":"","childAction":"","descr":"","dn":"uni/tn-Generali-infra/out-multipod/lnodep-bSpine/rsnodeL3OutAtt-[topology/pod-1/node-1002]/infranodep","extMngdBy":"","fabricExtCtrlPeering":"yes","fabricExtIntersiteCtrlPeering":"no","lcOwn":"local","modTs":"2019-02-12T01:01:56.361+00:00","monPolDn":"uni/tn-common/monepg-default","name":"","nameAlias":"","spineRole":"","status":"","uid":"15374"}}}]}
timestamp: 08:53:21 DEBUG method: GET
 
timestamp: 08:53:21 DEBUG method: GET
 
url: https://172.20.2.22/api/node/class/fabricNode.json?query-target-filter=eq(fabricNode.role,%22spine%22) response: {"totalCount":"1","imdata":[{"fabricNode":{"attributes":{"adSt":"off","address":"10.1.240.33","annotation":"","apicType":"apic","childAction":"","delayedHeartbeat":"no","dn":"topology/pod-1/node-155","extMngdBy":"","fabricSt":"inactive","id":"155","lastStateModTs":"2019-05-27T05:57:18.462+00:00","lcOwn":"local","modTs":"2019-05-27T05:58:08.395+00:00","model":"N9K-C9336PQ","monPolDn":"uni/fabric/monfab-default","name":"spine1","nameAlias":"","nodeType":"unspecified","role":"spine","serial":"SAL1931LA4N","status":"","uid":"0","vendor":"Cisco Systems, Inc","version":""}}}]}
timestamp: 08:53:21 DEBUG method: GET
 
url: https://172.20.2.22/api/node/class/fabricPod.json?query-target-filter=eq(fabricPod.podType,%22physical%22) response: {"totalCount":"2","imdata":[{"fabricPod":{"attributes":{"childAction":"","dn":"topology/pod-1","id":"1","lcOwn":"local","modTs":"2018-10-08T03:50:44.598+00:00","monPolDn":"uni/fabric/monfab-default","podType":"physical","status":""}}},{"fabricPod":{"attributes":{"childAction":"","dn":"topology/pod-2","id":"2","lcOwn":"local","modTs":"2019-05-27T00:00:38.018+00:00","monPolDn":"uni/fabric/monfab-default","podType":"physical","status":""}}}]}
timestamp: 08:53:21 DEBUG method: GET
 
url: https://172.20.2.22/api/node/class/fvFabricExtConnP.json response: {"totalCount":"0","imdata":[]}
timestamp: 08:53:38 DEBUG method: GET
 
url: https://172.20.2.22/api/node/mo/info.json response: {"totalCount":"1","imdata":[{"topInfo":{"attributes":{"childAction":"","currentTime":"2019-06-05T21:31:34.766+00:00","dn":"info","id":"1","podId":"1","role":"controller","status":""}}}]}
Highlighted

Re: ACI Multi-Pod configuration missing ACI 4.1

Please notice that our spine isn't powered on at the moment, but it's a lab environment and I hoped I could do that (at least go with the wizard) without the spine. It had already been registered in the fabric earlier.

 

Tell me if it's mandatory to at least make the Add pod button works ..

Highlighted
Beginner

Re: ACI Multi-Pod configuration missing ACI 4.1


But in my APIC GUI it doesn't work. I click and nothing happens ... If nobody ele has this issue, I think I should reinstall the APIC ..


I can confirm that this is missing in our stock APIC with 4.1.2 too.

CreatePlease to create content
Content for Community-Ad

Cisco COVID-19 Survey