cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4261
Views
0
Helpful
8
Replies
Highlighted
Beginner

Health status change to "Data Layer Partially Diverged" in Single APIC cluster after Upgrade to 1.1(1j)

Any idea? The vmmmgr process seem to have problem, and creating EPC in apic does not create port-group in vm DVS. We are unable to downgrade back to 1.0(3n) because controller health is not in "fully fit" state. 

 

 

 

 

8 REPLIES 8
Highlighted
Rising star

Can you please see if any

Can you please see if any core dump files have been created?  You can check with the command 'show cores' on the APIC.

Zach

Highlighted
Beginner

yes, i have attach the show

yes, i have attach the show cores file here. 

 

 
Highlighted
Rising star

This is just showing core

This is just showing core files on the switches (which we'll look at later).

On the APIC, can you check the /data/techsupport directory for an core files?

Thanks,

Zach

Highlighted
Beginner

Hi Zach, I just rebuilt the

Hi Zach, 

I just rebuilt the fabric instead of troubleshoot it today, because we have a poc for customer very soon....and once i downgrade to 1.0.(4h). The vmmmgr service resumed immediately. But when i try to upgrade 1.1.1j again, the vmmmgr service down again...will rebuild the fabic again tomorrow and stay at 1.0.4h first. 

By the way, the cluster health is return to "Data Layer Partially Diverged", and i can not downgrade the controller firmware becoz it is not fully fit, anyway to bypass it so next time i dont have to rebuild the whole fabric again?

There are 2 core file generated after upgrade to 1.1.1j. Please let me know how to upload the core file to you. Thank you very much.

dbgexp_coreexp-default_apic1_sysid-1_2015-06-24T01-34UTC_svc_ifc_vmmmgr.bin_log.2107.tar.gz
dbgexp_coreexp-default_apic1_sysid-1_2015-06-24T01-35UTC_svc_ifc_vmmmgr.bin_log.2153.tar.gz

 

 

Highlighted
Beginner

I had this exact same problem

I had this exact same problem with one of my APICs after doing an OS downgrade on my fabric.  I tried rebooting the node several times, but still I kept getting the partially diverged error.  In the end I removed/decomm’d apic1 did an eraseconfig setup, then rebooted it.  Then I went thru the initial setup config, commissioned it on another apic, then rebooted the leaf.  All seems to be fully fit now.  I guess that forced a total DB replication to the new node, and is what fixed my issue. 

Highlighted
Beginner

Hi Zach, i have uploaded the

Hi Zach, 

i have uploaded the core file. Thank.

Highlighted
Rising star

You can upload the files to

You can upload the files to:

ftp.cisco.com/incoming/TAC

Please let me know once they are there.

Zach

Highlighted
Rising star

Hi failee2007,Feel free to

Hi failee2007,

Feel free to contact me directly @ seils@cisco.com for help with this issue.

Zach

CreatePlease to create content
Content for Community-Ad

Cisco COVID-19 Survey