cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
897
Views
0
Helpful
2
Replies
ThariqAli
Beginner

Initial ACI Setup

So this being the first ACI  installation I have a question regarding APIC and switch software versions.

 

So the APIC has 4.1(1l) and the leaf has 14.2.3l, will this cause errors such as inactive switches and 

1 ACCEPTED SOLUTION

Accepted Solutions
Sergiu.Daniluk
VIP Advocate

If it is for production, ALWAYS run the same version on your APIC, spine and leaf switches.

If it is for testing in a lab environment, you can have different versions, however you might see unexpected behavior including: undiscovered nodes, misprograming of routes/endpoints, features not working, protocols instability and many others.

 

Stay safe,

Sergiu

View solution in original post

2 REPLIES 2
Francesco Molino
VIP Mentor

Hi

Versions matters and you could endup in something not working or not initializing.
I recommend to make sure apic and leaf are at the same version level.

Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question
Sergiu.Daniluk
VIP Advocate

If it is for production, ALWAYS run the same version on your APIC, spine and leaf switches.

If it is for testing in a lab environment, you can have different versions, however you might see unexpected behavior including: undiscovered nodes, misprograming of routes/endpoints, features not working, protocols instability and many others.

 

Stay safe,

Sergiu

View solution in original post