cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1973
Views
0
Helpful
4
Replies
Ali.Allafzadeh1
Beginner

Multicast on Nexus 9000

Hi Everyone,
I have a problem with Sparse-mode multicast configuration in Nexus 9000. 


I have 2 VLANs (Vlan 2 and 3) and we want to send multicast traffic between VLANs. I have implemented multicast routing (Feature Pim). Stream Server is in VLAN 2 and Receiver is in VLAN3.

I configured Static-RP once but it didn't work and after that I tried Auto-RP but it didn't work either. Could you please check our configuration and let us know if it's the correct configuration? 
Just for info, the multicast inside the VLAN can work without any problem.
Here is my configuration for Static RP and Auto-RP, Can anyone tell me What is the problems? 

Static RP Confiugration:
feature pim
ip pim rp-address 10.2.2.2 group-list 239.0.0.0/8
ip pim ssm range none

interface vlan 2
ip pim sparse-mode
ip igmp version 3
!
interface vlan 3
ip pim sparse-mode
ip igmp version 3

 

Auto-RP Configuration:
feature pim
ip pim auto-rp rp-candidate Vlan2 group-list 239.0.0.0/8
ip pim auto-rp mapping-agent Vlan2
ip pim ssm range none
ip pim auto-rp forward listen

interface vlan 2
ip pim sparse-mode
ip igmp version 3
!
interface vlan 3
ip pim sparse-mode
ip igmp version 3


Many Thanks,
Ali

4 REPLIES 4

Hi @Ali.Allafzadeh1,

This question is better fit on the Community Forum "Data Center Switches" since it pertains to standalone Nexus running in NX-OS and not in ACI mode.

For "Inter-Vlan Multicast Routing", with Multicast Source and Receivers on Directly Connected VLANs (from L3 Routing perspective), you don't really need a PIM Rendezvous Point. You should only need to enable Multicast PIM globally with 'feature pim' and enable Multicast PIM on the interfaces with 'ip pim sparse-mode' as you have already done. It doesn't make any harm to keep the RP configuration there though. Actually, I'd avise to keep it there just in case as I've seen some PIM implementations that require to have that config in place even though in theory PIM Control Plane doesn't need an RP for "Inter-Vlan Multicast Routing".

If your Nexus is in vPC or has redundancy, make sure that only one of them is the PIM DR for all the VLANs just in case. I'm also assuming that you omitted the IP configuration of your SVIs in your question but those are actually there.

Since the Multicast traffic is received successfully on the same VLAN, my guess is that the Multicast traffic generated has the TTL = 1 in the IP header (which prevents it from crossing L3 boundaries). You need to modify that on the device generating the Multicast traffic otherwise it will never cross the VLAN.

A couple of commands you can run on your Nexus that are of great help are in this scenario are:

 

show ip pim interface brief
show ip mroute
show ip igmp groups
show ip igmp snooping

Hope this helps.

 

First of all thanks for your massage. Please look that the Topology that I have attached and see the commands also: 

feature pim
feature interface-vlan


interface Vlan2
no shutdown
ip address 192.168.2.1/24
ip pim sparse-mode

interface Vlan3
no shutdown
ip address 192.168.3.1/24
ip pim sparse-mode  --> I have also tried without this command
ip pim ssm range none

interface Ethernet1/1

no shutdown
switchport access vlan 2

interface Ethernet1/2

no shutdown
switchport access vlan 3



But it does not work also

I have seen that NEXUS 9k has too many Access-lists, that can cause the problem ?

Thanks 

 

NXOS1# show ip pim interface brief
PIM Interface Status for VRF "default"
Interface       IP Address               PIM DR Address               Neighbor            Border
                                                                                             Count             Interface
Vlan2             192.168.2.1                 192.168.2.1                    0                     no
Vlan3             192.168.3.1                 192.168.3.1                    0                     no
loopback1      1.1.1.1                         1.1.1.1                            0                     no

 

NXOS1# show ip mroute
IP Multicast Routing Table for VRF "default"

(192.168.2.2/32, 239.1.1.1/32), uptime: 00:00:35, ip pim
Incoming interface: Vlan2, RPF nbr: 192.168.2.2, uptime: 00:00:35
Outgoing interface list: (count: 0)

 

NXOS1# show ip igmp groups  (This is empty)
IGMP Connected Group Membership for VRF "default" - 0 total entries
Type: S - Static, D - Dynamic, L - Local, T - SSM Translated
Group Address Type Interface Uptime Expires Last Reporter

 

NXOS1# show ip igmp snooping
Global IGMP Snooping Information:
IGMP Snooping enabled
IGMPv1/v2 Report Suppression enabled
IGMPv3 Report Suppression disabled
Link Local Groups Suppression enabled
VPC Multicast optimization disabled

IGMP Snooping information for vlan 1
IGMP snooping enabled
Lookup mode: IP
IGMP querier none
Switch-querier disabled
IGMP Explicit tracking enabled
IGMPv2 Fast leave disabled
IGMPv1/v2 Report suppression enabled
IGMPv3 Report suppression disabled
Link Local Groups suppression enabled
Router port detection using PIM Hellos, IGMP Queries
Number of router-ports: 0
Number of groups: 0
VLAN vPC function disabled
Active ports:
Eth1/4 Eth1/5 Eth1/6 Eth1/7

Report Flooding: Disabled
Interfaces for Report Flooding: n/a
Use Group Address for Proxy Leaves: no

IGMP Snooping information for vlan 2
IGMP snooping enabled
Lookup mode: IP
IGMP querier present, address: 192.168.2.1, version: 2, i/f Vlan2
Querier interval: 125 secs
Querier last member query interval: 1 secs
Querier robustness: 2
Switch-querier disabled
IGMP Explicit tracking enabled
IGMPv2 Fast leave disabled
IGMPv1/v2 Report suppression enabled
IGMPv3 Report suppression disabled
Link Local Groups suppression enabled
Router port detection using PIM Hellos, IGMP Queries
Number of router-ports: 1
Number of groups: 0
VLAN vPC function disabled
Active ports:
Eth1/1 Eth1/2
Report Flooding: Disabled
Interfaces for Report Flooding: n/a
Use Group Address for Proxy Leaves: no

IGMP Snooping information for vlan 3
IGMP snooping enabled
Lookup mode: IP
IGMP querier present, address: 192.168.3.1, version: 2, i/f Vlan3
Querier interval: 125 secs
Querier last member query interval: 1 secs
Querier robustness: 2
Switch-querier disabled
IGMP Explicit tracking enabled
IGMPv2 Fast leave disabled
IGMPv1/v2 Report suppression enabled
IGMPv3 Report suppression disabled
Link Local Groups suppression enabled
Router port detection using PIM Hellos, IGMP Queries
Number of router-ports: 1
Number of groups: 0
VLAN vPC function disabled
Active ports:
Eth1/3
Report Flooding: Disabled
Interfaces for Report Flooding: n/a
Use Group Address for Proxy Leaves: no

 

Hi @Ali.Allafzadeh1 

You should look into your Stream Receiver. You should configure it to continuously request for the Multicast stream.

  • When you are doing "show ip igmp groups" you must see the IP address fo the Multicast Receiver on Vlan 3. I don't see that in your output.
  • Once done, "show ip mroute" should show under "Outgoing interface list" the Vlan where the Multicast Receiver resides, in you case Vlan 3.

About your Stream Server:

  • May I know the IP TTL of the Multicast traffic as suggested initially?
  • What is the application generating the Multicast stream?

There is nothing wrong on your Switch so far.

Hope this helps.