cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4477
Views
5
Helpful
10
Replies
Highlighted
Beginner

ISR 4351 AppNav-XE registration - SSL Handshake failed

Hi, I'm trying to setup a new ISR 4351 router with vWAAS running on UCS-E but having trouble with registering the router for AppNav. The vWAAS install on UCS-E appears to be ok and is registered with the WAAS Central Manager. But when I try to register the IOS router on the WAAS Central Manager I get a 'Successfully processed the registration request' message on the Cisco IOS Router Registration page however when I go to the Devices page I get Device Status of Pending for ages and then eventually get status of Offline and error 'SSL Handshake failed while communicating with AppNav-XE Controller device.' Also, on the router if I have debug ip http running I get the following errors every 5 minutes;

 

Aug 24 16:10:59.175: %HTTPS: SSL handshake fail (-6992)
Aug 24 16:10:59.175: HTTP: ssl handshake failed (-40404)

 

I'm running Cisco IOS XE Software, Version 03.15.01.S Version 15.5(2)S1

 

Has anyone got any ideas why this would happen?

 

Thanks

Everyone's tags (3)
10 REPLIES 10
Highlighted
Beginner

Did you solve this? something

Did you solve this? something to do with the trustpoint used for the SSL handshake but cant figure out what needs changing.

Highlighted
Beginner

Hi Sean, the SSL handshake

Hi Sean, the SSL handshake issue was down to a bug in Central Manager v5.5.1, upgrading it to 5.5.5 resolved that issue. I then had further problems due to ACS authorisation but that's another story.

Highlighted
Beginner

Thanks Jeremy. Been racking

Thanks Jeremy.

 

Been racking my brian on this for the past 2 days. Tried CA certificates etc with no joy.

We are on WAASCM 5.5.1 so am upgrading now to see if this resolves.

Running ACS too and now hoping the WAASCM is the last stumbling block.

 

Cheers,

Highlighted
Beginner

Thanks Jeremy! I feel I ou

Thanks Jeremy!

 

I feel I ou you one! the upgrade resolved the issue!

Thanks so much for the reply or I would still be sitting here scratching my head.

 

Thanks,

Highlighted
Cisco Employee

Hi All, Just for your

Hi All,

 

Just for your information, the issue you had was due to CSCus70116 and this is why your issue got solved after upgrade to 5.5.5.

 

Regards,

Nicolas

Highlighted
Beginner

hi jeremy,

hi jeremy,

anyway i have some issue SSL Handshake failed while communicating with AppNav-XE Controller device in ASR,so how to upgrade vWaas ver. 5.5.1 to ver. 5.5.5 ?

thanks 

Highlighted
Beginner

Same issue here with 6.1.1a

Same issue here with 6.1.1a and ISR4331 on bootflash:isr4300-universalk9.03.15.02.S.155-2.S2-std.SPA.bin

Highlighted
Beginner

Re: Same issue here with 6.1.1a

Hey neidlein,

Did you fix device registration? I got the same message 'SSL Handshake failed while communicating with AppNav-XE controller device'. CM is running 'waas-universal-6.1.1.26-k9.bin '.

Highlighted
Beginner

Re: ISR 4351 AppNav-XE registration - SSL Handshake failed

I have the same issue. I'm running WCM version 6.2.3e.  I'm trying to register a ASR1004 RP2 as an AppNav XE controller.

Highlighted

Re: ISR 4351 AppNav-XE registration - SSL Handshake failed (SOLVED)

I am having the same issue with ISR AppNav-XE Controllers 4351 and 4451; after a successful registration the units transition from Pending to Offline Status with an Error of " Socket connect timed out while communicating with AppNav-XE Controller device."

 

CreatePlease to create content
Content for Community-Ad

Cisco COVID-19 Survey