cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1371
Views
5
Helpful
9
Replies
Highlighted

WAAS CIFS alarms

Hi guys,

got couple of alarms in one of our waas box! dont know what it means! would be great to get some help! i have attached the screenshot.

cheers

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

yep I know is suppose to be fix... thanks for opening a TAC case please keep up posted.

cheers

View solution in original post

9 REPLIES 9
Highlighted

not sure whether my attachment came through! reattaching again!

cheers

Highlighted

hi Srini,

can you send us the following outputs:

#show accelerator

#show license

WAE#sh tech-support page | begin Accelerator Global Statistics         (from this output  I just need to see from where it says " CIFS: Global Statistics"  to  "Auto-Discovery Statistics" )

I also need the following logs:

first you do  WAE-502-M1#cd errorlog

then  WAE-502-M1#type-tail cifsao-errorlog.current 30

any questions let me know,

Felix

Highlighted

also what WAAS version are you running ?

cheers

Highlighted

Thanks Felix.

we are running 4.2.3b!

I also deregistered from the CM did a database maintanence and registered it again. It looks ok for a while but goes back to shutdown mode. I have planned to reboot the box tonite.see the logs below:

waearm1#sh accelerator

Accelerator     Licensed        Config State    Operational State
-----------     --------        ------------    -----------------
cifs            Yes             Enabled         Shutdown
epm             Yes             Enabled         Running
http            Yes             Enabled         Running
mapi            Yes             Enabled         Running
nfs             Yes             Disabled        Shutdown
ssl             Yes             Enabled         Running
video           No              Disabled        Shutdown
wafs-core       Yes             Disabled        Shutdown
wafs-edge       Yes             Disabled        Shutdown
waearm1#show license
License Name   Status      Activation Date Activated By
-------------- ----------- --------------- --------------
Transport      not active
Enterprise     active      03/21/2009      setAtUpgrade
Video          not active

waearm1#cd errorlog
waearm1#type-tail cifsao-errorlog.current 30
  AO:"CIFS", ncpus: 1, final NB model(threads) = OPTIMAL(0)
[aoshell.c:1961]
07/03/2012 16:35:52.289(Local)(18788) NTCE (289795) received LC event: AOSH_ALLO
C_RES [AoShellWrapper.cpp:1256]
07/03/2012 16:35:52.392(Local)(18788) NTCE (392442) received LC event: AOSH_CFG_
WAIT [AoShellWrapper.cpp:1265]
07/03/2012 16:35:52.516(Local)(18788) NTCE (516403) received LC event: AOSH_STAR
T_ACCEL, setting max_conn to 750 [AoShellWrapper.cpp:1270]
07/03/2012 16:36:51.640(Local)(19034) ERRO (640438) Error connecting to file ser
ver 10.4.36.20. [AoShellLog.cpp:25]
07/03/2012 16:43:51.589(Local)(18785) ERRO (589810) Calling aoshell to exit [AoS
hellWrapper.cpp:475]
07/03/2012 16:43:51.627(Local)(18788) CRTC (627093) An internal error occurred w
hile stopping Edge File Engine, component CIFS. [AoShellLog.cpp:28]
07/03/2012 16:44:01.102(Local)(21243) NTCE (102145) ******* AO INITIALIZING ****
***
******* AO is CIFS *******
  Internal config model used: OPTIMAL
  AO:"CIFS", ncpus: 1, final NB model(threads) = OPTIMAL(0)
[aoshell.c:1961]
07/03/2012 16:44:03.882(Local)(21332) NTCE (882836) received LC event: AOSH_ALLO
C_RES [AoShellWrapper.cpp:1256]
07/03/2012 16:44:03.986(Local)(21332) NTCE (986863) received LC event: AOSH_CFG_
WAIT [AoShellWrapper.cpp:1265]
07/03/2012 16:44:04.115(Local)(21332) NTCE (115624) received LC event: AOSH_STAR
T_ACCEL, setting max_conn to 750 [AoShellWrapper.cpp:1270]
07/03/2012 16:45:03.487(Local)(21595) ERRO (487846) Error connecting to file ser
ver 10.4.36.20. [AoShellLog.cpp:25]
07/03/2012 16:52:03.441(Local)(21329) ERRO (441171) Calling aoshell to exit [AoS
hellWrapper.cpp:475]
07/03/2012 16:52:03.492(Local)(21332) CRTC (492117) An internal error occurred w
hile stopping Edge File Engine, component CIFS. [AoShellLog.cpp:28]
07/03/2012 16:52:11.555(Local)(25753) NTCE (555488) ******* AO INITIALIZING ****
***
******* AO is CIFS *******
  Internal config model used: OPTIMAL
  AO:"CIFS", ncpus: 1, final NB model(threads) = OPTIMAL(0)
[aoshell.c:1961]
07/03/2012 16:52:15.855(Local)(25855) NTCE (855269) received LC event: AOSH_ALLO
C_RES [AoShellWrapper.cpp:1256]
07/03/2012 16:52:15.982(Local)(25855) NTCE (982684) received LC event: AOSH_CFG_
WAIT [AoShellWrapper.cpp:1265]
07/03/2012 16:52:16.138(Local)(25855) NTCE (138076) received LC event: AOSH_STAR
T_ACCEL, setting max_conn to 750 [AoShellWrapper.cpp:1270]
07/03/2012 16:53:15.247(Local)(26219) ERRO (247889) Error connecting to file ser
ver 10.4.36.20. [AoShellLog.cpp:25]
07/03/2012 17:00:15.537(Local)(25846) ERRO (537027) Calling aoshell to exit [AoS
hellWrapper.cpp:475]
07/03/2012 17:00:15.576(Local)(25855) CRTC (576178) An internal error occurred w
hile stopping Edge File Engine, component CIFS. [AoShellLog.cpp:28]

cheers

Highlighted

Hello Srini,

I'm afraid I will need you to open a case with TAC or  to upgrade your WAAS devices to a newer version, I believe we have a bug  over here.

If I am right, TAC will either ask you to upgrade or  they will provide a work around.. the main idea is  to have a TAC  engineer to review the whole sysreport.. but  for me you can  upgrade to a  newer version which is the best you could do.

( WAAS 4.4.x upgrade guide)

http://www.cisco.com/en/US/docs/app_ntwk_services/waas/waas/upgrade/guide/waas_upgrade-44.html

(WAAS 5.0 upgrade guide)

http://www.cisco.com/en/US/docs/app_ntwk_services/waas/waas/upgrade/guide/waas_upgrade-50.html

If you open a TAC case, you can refer to the following bug CSCti16574  which I believe is the one you're device is facing based on the logs and software version.

(further bug details)

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCti16574

I am confident this is a bug but if it is something otherwise please let me know.

good luck!

Highlighted

Hi Felix,

The mentioned bug was fixed in 4.2.3a but we are running 4.2.3b! I have logged a TAC case.

regards

Highlighted

yep I know is suppose to be fix... thanks for opening a TAC case please keep up posted.

cheers

View solution in original post

Highlighted

following bug: CSCtd70016, titled "Under rare circumstances, CIFS AO can not be re-enabled".

Symptom: CifsAO shows its operational state as "shutdown" and resources could not be accessed via CIFS.

Conditions: After forced reload of WAE.

Workaround

: Perform

'disk delete-data-partition' to clear CIFS and DRE cache

following bug: CSCtd70016, titled "Under rare circumstances, CIFS AO can not be re-enabled".

Symptom: CifsAO shows its operational state as "shutdown" and resources could not be accessed via CIFS.

Conditions: After forced reload of WAE.

Workaround: Perform 'disk delete-data-partition' to clear CIFS and DRE cache

This fixed our issue.

Highlighted

nice! thanks for sharing.

This widget could not be displayed.