cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

2371
Views
10
Helpful
8
Replies

Can´t get SPA112 to work

Hi there,

 

I´m from Sweden and am not the best at technical english so bare with me.

 

We have installed an intercom system at an apartment complex which visitors should be able to call the residents cellphone which they intend to visit. The intercom system we have installed calls with an analouge line, so we have put up an SPA112 and connected it to the internet. The IT department says that they have opened up for both the SIP protocol and the RTP protocol in the firewall. I do get SIP messages recieved but not any RTP packets recieved. (i attached the page)

 

I have only made the quick setup and changed SIP protocol to TCP under line setting and changed the make call without registration. Is it any other settings i maybe have to change?

 

I also have problem with the IP settings i got from the IT department 

 

192.168.6.173

255.255.255.0

196.168.6.1

 

The ATA says that the subnet mask isn´t the same for the gateway, i figured it was a typo from the IT department so i put the 196 as 192 in the gateway as well, maybe this is the problem? (seems like this was a typo from the IT department the gateway should be 192.)

 

I´m thankfull for any help i can get, i´m not used to working with these types of products

8 REPLIES 8
Howard Wittenberg
Participant

You haven't described your use of the SPA112 in enough detail to understand your setup, however I can make a comment about "one-way audio" that you mentioned.

 

As part of the sip protocol for making calls the SPA tells the distant server the ip address to which the distant server should send the incoming audio rtp packets. Depending on the environment the ip address can be a local ip address or an external internet ip address. One cause of one-way audio is the protocol's failure to send the correct ip address. Often this is corrected by the NAT Mapping Enable setting. If the SPA needs its external ip address and has discovery problems there are additional settings.

Thank you for the reply,

 

I actually dont know if the server is outside the network or not, i will check with the IT department, i tried to enable NAT actually but i dont think it made a difference for me now.

 

Please tell me what information i can give to help you understand my setup.

Reviewing the problem:

The objective of using the SPA112 Analog Terminal Adapter is to enable the connection of the intercom system's output to a distant cellphone connected to one of the cellular networks.

Basic Review:
Cabling:
The intercom system's analog output is designed to connect to a telephone network and dial a number? Using a cable with an standard RJ11 connector you have connected the intercom system's output to the SPA112's "Phone 1 or Phone 2" port. Is this correct?

The SPA112's "Internet" port is cabled to a distant router that attaches to a local network and the internet. Correct?

The SPA112 is cabled to a local power source.

Configuration:
To connect to a telephone number in a cellular network you need to go thru a sip server that can pass the call to the cellular network. This would be a voip service or a PBX server that has a connection to a voip service. What kind of service are you connecting to? Is it located at a local IP address or an external IP address?

You have configured Line 1 or Line 2 Tab (depending on the cabling from the intercom system).

You indicated that you set Make Call Without Reg: Yes The Sip Server accepts unregistered calls? Is this correct?

On the Line Tab you have configured
Proxy: (Domain Name or URL)
User ID: xxxxxxx
Password: xxxxxxxx
Is this correct?

If you are not having the SPA112 Register with the Sip Server, I would set Register: No

You indicated the you set the Sip Transport to TCP. This should be OK. The RTP packets are still sent as UDP. Your router should not be blocking UDP.

For testing I would think instead of attaching the intercom system to the SPA, you could just attach an analog phone and get that working first, then later go to the intercom system.

To debug your problem it would be helpful to see a Sip Debug Trace. The trace will show the SIP Invite you send when you make a call and will show the response (if any) from the sip server. You can get this with a computer attached to the same network as the SPA112. You install a Syslog Server Program on the computer and configure the SPA to send the trace to the computer. On the SPA you put the computer's address and activate the Logging.
See the Cisco SPA100 Series Phone Adapters Administration Guide for detail on the settings.

On the SPA112 You make settings on the Line Tab (Sip Debug Option: FULL) and under Administration > Log >Log Server

under System>Debug Server the ip address of your computer and also under System>Debug Level set 1

 

You can download a simple syslog server program that runs under Windows here

Big thanks for taking your time and replying, i have tried to answer your question the best i can, i will try to get a hold of the IT department for some of the questions and update after that.

 

The objective of using the SPA112 Analog Terminal Adapter is to enable the connection of the intercom system's output to a distant cellphone connected to one of the cellular networks.

Basic Review:
Cabling:
The intercom system's analog output is designed to connect to a telephone network and dial a number? Using a cable with an standard RJ11 connector you have connected the intercom system's output to the SPA112's "Phone 1 or Phone 2" port. Is this correct? Correct, i have connected the RJ11 cable to the Phone 1 output, however, the intercom system dont have an RJ 11 output but 2 screws which the line comes out of, i have connected the 2 middle cables in the RJ11 cable to these screws. I can tell under the voice tab and information that the ATA is trying to dial the correct phone number that i want it to dial, so i figured this is working.

 

The SPA112's "Internet" port is cabled to a distant router that attaches to a local network and the internet. Correct? The "Internet" port is cabled to a network switch which i have gotten a port configurated for the ATA by the IT department, this is probably where the problem starts. I have asked the IT department to open up port 5060 TCP for the SIP protocol and port 16384 UDP for the RTP protocol in the firewall, between my ATA and the SIP server they have handed me.

 

The SPA112 is cabled to a local power source. Yes

 

Configuration:
To connect to a telephone number in a cellular network you need to go thru a sip server that can pass the call to the cellular network. This would be a voip service or a PBX server that has a connection to a voip service. What kind of service are you connecting to? Is it located at a local IP address or an external IP addressI actually dont know, i have gotten information handed to  me about their already existing SIP server they have set up for a similar intercom system at another building. I will check with the IT department when i can get a hold of them about this.

You have configured Line 1 or Line 2 Tab (depending on the cabling from the intercom system).

You indicated that you set Make Call Without Reg: Yes The Sip Server accepts unregistered calls? Is this correct? That i have to check with the people administrating the SIP server.

On the Line Tab you have configured
Proxy: (Domain Name or URL)
User ID: xxxxxxx
Password: xxxxxxxx
Is this correctYes this is correct, the company that owns the apartment buildings have a SIP server set up for this from earlier buildings. I have recieved information from them including server IP which i have set into the proxy field, account id which i set in the User ID field and password ID which i put in the password field.

 

 

I am sorry, i couldnt get the syslog to work, i guess the ata cant connect to my computer due to the firewall. I downloaded the local log from the ATA if that says anything to you, i think i made like 3 calls within the log time.

 

 

I have asked the IT department to open up port 5060 TCP for the SIP protocol and port 16384 UDP for the RTP protocol in the firewall, between my ATA and the SIP server they have handed me.

 

The SPA112 uses a range of port numbers for RTP packets. The admin manual says you should define a range that contains at least 4 even number ports, and if you don't change anything the default port number range is 16384 to 16482 (Admin Guide pg 68). I believe calls only use a single port number for a given call however the adapter doesn't necessarily use the 1st port number in the range.

 


@Howard Wittenberg wrote:

I believe calls only use a single port number for a given call


Mostly true. But I'm unsure its true for suspended->resumed calls and for calls with codec renegotiation initiated by peer during the call.  So I don't bet on it ...

Ok i will ask them to open up several ports for the RTP packets and try again, i will review the admin manual, didnt have that available from the beginning. Thank you


@RobinRiekkola8641 wrote:

Ok i will ask them to open up several ports for the RTP packets and try again, i will review the admin manual, didnt have that available from the beginning. Thank you


Good. Hopefully that will solve the problem.

Of course if you do not open the entire range configured on the SPA112 you will need to use the "Phone Adapter Configuration Utility" built into the SPA122 to configure the range you have enabled. Go to Voice>SIP>RTP Port Min and RTP Port Max

 

Probably not necessary but if you continue to have a problem and wish to capture a sip debug trace, the SPA112 Phone Adapter Configuration Utility settings are as follows:
1. Voice>Line1> Sip Debug Option: FULL
2. Voice>System>Debug Server>[ipaddress of syslog program]
3. Voice>System>Debug Level>1

You need a syslog program and I previously posted an address to obtain a simple windows syslog program.