Showing results for 
Search instead for 
Did you mean: 

Please Help - SPA2102 Firmware Upgrade

Have downloaded the new firmware package, upg-spa2102-5-2-10.exe and spa2102-5-2-10.bin, from Cisco website, but couldn't upgrade my SPA2102 adapter.

With running Solarwinds TFTP server in the background, I have been waiting for hours watching the upg-spa2102-5-2-10.exe to wait for a 'download request' from the SPA2102!

I've tried different computers, firewall off and antivirus off with no luck.

Your help is greatly appreciated!  Thanks!


Re: Please Help - SPA2102 Firmware Upgrade

All you need to do is attach your pc to the ethernet port of the SPA2102 and make sure you get an ip address. Then attempt to login to the web page of the device by going to It should not be password protected. If it is, then you need to ask whoever gave you the device for the password. If it was provided to you via the ITSP, then it will be locked by them and you will not be able to upload new firmware.

If you can login as the admin user and select the advanced link, then just run the upg-spa2102-5-2-10.exe file. It will bring up a box and ask for the IP address of the 2102. Put in for the address (it will list your ip address at the bottom of the box) and then click ok. The upgrade should proceed from there without a problem. If it does not upgrade, contact the SBSC for your country,

for support on this product. You will need to have your serial number ready when you call.

Please post your results.


Cisco Employee

Re: Please Help - SPA2102 Firmware Upgrade

Hi mtl628000,

With SolarWinds, be sure that you don't have a firewall issue on your computer... you may also need to start the TFTP service manually.

I recently downloaded their new TFTP server and my computer appeared to be acting as a TFTP server, but wasn't...

I'd bet that the computer has some security mechanism that is defeating the SolarWinds TFTP server...

You need to force the SPA2102 to request the upgrade:

Good luck,



Re: Please Help - SPA2102 Firmware Upgrade

Sorry for not creating a new thread, but it seems to me that I'm having exactly same problem.

I have a corporate network running my own VoIP server.

Recently I've updated like two dozens of spa2102 from 3.3.6 to 5.2.10, but I have one particular spa2102 that simply refusing to update it's firmware.

The symptoms are exactly the same - the progressbar keeps running on 'waiting for firmware download', but nothing happens.

The computer running update program is in the same subnet with spa2102, I'm pretty sure that this isn't a firewall problem - because I've updated some of the spa2102 in this subnet already from the same computer.

I've tried to upload the firmware onto a tftp server in the same subnet and to force upgrade with an HTTP GET request as it's explained in kb, but tcpdump shows that simply nothing happens - nothing is received on a server side.

The box is idle all the time. I see no reason to behave like that.

Is there some way to 'force force' firmware upgrade ? May be there is a way to upload the image via http protocol ?


Re: Please Help - SPA2102 Firmware Upgrade

If you have not done so already, reset the ATA to factory defaults using the IVR (voice response) menus. On the SPA2102 you will have to re-enable the web configuration screens using the IVR, too.

Reset to factory defaults:

Dial **** 

then 73738 #  1

Restore web configuration screens (on the SPA2102 they are turned off by default; on other devices they're normally on):

Dial ****

then 7932 # 1# 1

The SPA2102 and the PAP2T ATAs both have a http upgrade mode for installing firmware. Here's how to use it:

Acquire the latest firmware for the ATA. The SPA2102 firmware is available from and as of this writing, it's version 5.2.10. Download the .zip archive and extract the .bin file in it -- in this case it's spa2102-5-2-10.bin

Copy the .bin file to an http server that your SPA2102 can access. If you have a account, copy the file to your Public folder, and go into the web interface and get the public URL for your file. It will be something like

Substitute the local address for spa2102 and the link to your file and open the URL in your browser:


The ATA should download the file and flash it. The status light will blink rapidly until the process is finished; do not power down or reset the ATA until it's through.

Message was edited by: Tommy Trussell (added Interactive Voice Response commands).

CreatePlease to create content
Ask the Expert- MPLS troubleshooting