cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

468
Views
0
Helpful
1
Replies
Erik Dekkers
Beginner

Random one way audio with SPA112

Hi folks,

Im facing a strange issue: I do have an customer who is using 10x SPA504G and one SPA112 with two analog phones connected. Both the phones and the ATA are on the same network. There are no audio problems with the SPA504G's.

Unfortunately there are strange problems with the SPA112. In about 50% of the outbound calls there is one way audio. The other end cannot hear them.

The NAT settings of the SPA112 are exactly the same as the SPA504G's, so that cannot be the problem. I've tried different firmware versions (alsof the latest 1.4.1) but no difference.

Does anyone has an idea what this could be?

Best regards,

Erik

1 REPLY 1
Dan Lukes
Advocate

Despite "The NAT settings of the SPA112 are exactly the same as the SPA504G" I'm almost sure it's NAT related issue.

I assume the NAT changes source port of RTP (audio) stream if the source port number used by SPA112 is considered used - but it doesn't patch SIP packets accordingly. In such case the RTP stream is not recognized by peer.

If source port is not busy, then it's passed thru NAT unchanged, so everything works.

To verify such hypothesis you need to packet dump (SIP as well as RTP) captured *after* the NAT. Ask your local network administrator for help if necessary.

Create
Recognize Your Peers
Polls
How would you describe your level of technical expertise?