cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1315
Views
0
Helpful
11
Replies
Highlighted
Beginner

SP3102 connecting to SP2102

Hi,

Is there anyone who can walk me through the programming to have the 3102 and the 2102 be aech others sip proxy without registration?

The application is an analog extension from phone system A, going through a 3102 and extending through the Internet to the 2102 to be located off site?

Thanks,

Doug

11 REPLIES 11
Highlighted
Frequent Contributor

Please check out the enclosed doc.  Thanks.

Highlighted
Beginner

Hello Mr Doug,

could you please design a small diagram or what you want to get with the configuration you are asking for?

Regards

Highlighted

Hi,

Call comes into location A through a Norstar Key sytem. Operator transfers to an analog station "200". That station is plugged into the SP3102 and has a static IP assigned to it. The transfered call should then go through the internet to the SP 2102, that has a static IP assigned to it, and end up at and analog phone plugged into the SP2102.

When ever the phone plugged into the 2102 goes off hook, they should have intercom dialtone coming from the Norstar through the 3102.

Make sense?

Thanks!!

Doug

Highlighted

Hello Doug,

do you want that the analog station 200 forwards the call automatically or there is an operator that manually forwards the call to the phone plugged to the SPA2102?

And if it will be forwarded automatically, do you have any need to have an analog phone plugged into the SPA3102

Regards

Mauro

Highlighted

Manual transfer, not forwarding.  No need for a phone to be in the 3102, it just is a pass through to the internet.

Thanks

Highlighted

Hello Doug,

you should do what I'm going to explain:

          1. Plug an extension of the Norstar Key System PBX to the FXO port of the SPA3102

          2. Configure your SPA3102 on the wan interface with the ip you public on internet

          3. (SPA3102)  Go in VOICE-->PSTN Line:

                                        - Proxy and Registration -> Registration: no

                                        - Proxy and Registration -> Make Call Without Reg: yes

                                        - Proxy and Registration -> Ans Call Without Reg: yes

                                        - Dial Plans -> Dial Plan 1: (xx.)

                                        - Dial Plans -> Dial Plan 2: (S0<:EXT-ON-SPA2102@PUBLIC-IP-SPA-2102:5060)

                                        - VoIP-To-PSTN Gateway Setup -> VoIP-To-PSTN Gateway Enable: yes

                                        - VoIP-To-PSTN Gateway Setup -> Line 1 VoIP Caller DP: 1

                                        - PSTN-To-VoIP Gateway Setup -> PSTN-To-VoIP Gateway Enable: yes

                                        - PSTN-To-VoIP Gateway Setup -> PSTN Ring Thru Line 1: no

                                        - PSTN-To-VoIP Gateway Setup -> PSTN Caller Default DP: 2

                                        - International Control -> you should set the impedance according with your pbx

On the other side:

          1. Plug your phone on the FXS1 of the SPA2102

          2. Configure your SPA2102 on the wan interface with the ip you public on internet

          3. (SPA2102)  Go in VOICE--> Line1 :

                                        - Proxy and Registration -> Proxy:PUBLIC-IP-SPA-3102:5061

                                        - Proxy and Registration -> Registration: no

                                        - Proxy and Registration -> Make Call Without Reg: yes

                                        - Proxy and Registration -> Ans Call Without Reg: yes

                                        - Dial Plan -> Dial Plan: (xx.)

If you have a router infront of the 2 spa devices on both sides you have to forward traffic to the devices.

If you need any further question do not hesitate to ask more questions

Regards

Mauro

Highlighted

Hi,

We are to a point where the 2102 side can make a call out and reach the 3102 side, but when the 3102 trys to call the 2102 (extension 248 off of the Norstar system) it rings no answer and the 2102 can pick up to dialtone while it is ringing from the 3102.

Any ideas?

Thanks

Highlighted

Hi Doug,

with the settings I've posted you can't use a phone plugged on the SPA3102.

You should plug the Norstar system to the FXO port of the SPA3102 and call from a phone behind the Norstar the phone plugged on the SPA2102, but using the extension you have configured in the Norstar related to the SPA3102.

Regards

Highlighted

I'm not sure what you mean. The 3102 is ext 248 (Norstar analog port plugged

into line port on 3102). When the phone off the 2102 calls an extension on

the Norstar, it works perfectly. When the Norstar calls 248, it rings, but

not to the 2102. It worked through the same network, but 2 different

locations, it only works 1 way. Maybe NAT settings?

Thanks

On Mar 29, 2011 3:42 AM, "maambros" <

Highlighted

We have gotten the devices to work as intended without a firewall involved.

right now we have the 3102 pluged into the norstar with a public static programed in the wan port.

We have the 2101 at a remote location with a private ip programed behind a firewall and the firewall setup to do a 1:1 nat forwarding all traffic to the 2102.

We have confirmed that the 2102 is completely visable behind the firewall.

We are assuming this is a NAT issue of some sort, we have messed with the NAT settings on the SIP page, in addition to the Keep alive on the Line 1 page.

If we take the firewall out of the look on the 2102 side and plug the public IP into the 2102 we are able to make calls both ways, but not with the 2102 behind the firewall.

Highlighted

Hello Doug,

try to configure the SPA2102 in this way:

  Voice tab -> SIP

               1. Handle VIA received, Insert VIA received, Substitute VIA Addr: yes

               2. Handle VIA rport, Insert VIA rport, Send Resp To Src Port: yes

               3. Ext IP: Your external IP if static (otherwise do not use this parameter)

  Vice tab -> LINE1:

               1. NAT Mapping Enable: YES

               2. NAT Keep Alive Enable: YES

Give to the SPA2102 a static IP

Regards

Mauro