cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Get the latest Cisco news in this February issue of the Cisco Small Business Monthly Newsletter

230
Views
0
Helpful
3
Replies
Highlighted
Beginner

SPA 122 ATA can't acquire IP address. Is it broken or am I just a numpty?

Hi,

 

This should be straightforward, I only want to connect one analogue phone to a SipGate VOIP account.

 

I don't seem to be able to get off the starting block. When I plug it in, the "System" light on the ATA slowly flashes green which indicates that it is "Acquiring IP address. (by default uses DHCP)." I have been through every set up instruction methodically, but the light always remains flashing and is never a constant.

 

The "Internet" light on the ATA flashes from time to time to show that it is transmitting or receiving data. No life from the Phone 1 or 2 indicator lights. The help notes simply suggest turning everything off and on again if the system light doesn't stop flashing.

 

I am able to login into the ATA through a web browser and change admin password and enable remote web access. I was also able to enter 'quick' connection settings to my VoiP account. But that's about all it will let me do.

 

If I try to upgrade the firmware, it gets to the end of the process and then gives the error message: "Changes cannot be applied while calls are in progress. Please try again when phones are idle."

 

If I try and put it into 'bridge' mode it gives the same error message, and if I try and allocate a Static IP or anything like that I get the same error message.

 

Obviously there is no call in progress because I have never been able to set it up.

 

 

 

I have the Cisco SPA 122 ATA with router.

Hardware 1.0.0

Boot 1.0.1

Firmware 1.0.2 (006)

Recovery firmware 1.0.2

 

I have connected it to a Virgin Hub 3.0 which I have placed in both router and then in modem mode when trying to get the ATA working. According to the set up guide the ATA should work either way. My computer/hub is set up to obtain an IP address automatically. The hub can 'see' the ATA and allocates it an IP address.

 

I have tried all this with a computer connected to the ATA only, connected to the ATA and the hub, and with the ATA connected on its own in every combination I can think of.

 

I have tried all this with the analogue phone connected to Line 1 on the ATA and without it connected. IVR actions are not possible, it's just dead. The phone is relatively modern, powered and works fine when in analogue use.

 

I have tried resetting to factory settings both the ATA and the HUB and switching them on and off in various combinations advised in help notes and on forums.

 

I have read forums and tried a few suggestions that worked for similar problems, but no success.

 

Really grateful for any advice. My technical knowledge is perhaps not adequate enough to know whether there's just something really simple I am missing or not doing here......

 

 

Cheers!!

 

 

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Advocate

Re: SPA 122 ATA can't acquire IP address. Is it broken or am I just a numpty?

Claimed "call in progress" despite no analog phone connected may be sign of broken SLIC (consider it just hardware failure unless you understand the acronym)

Check the status page. If either analog line shows "off-hook" despite there's no phone connected at all, you may consider hypothesis verified.

If not, syslog&debug messages may help with further analysis.

 

View solution in original post

3 REPLIES 3
Highlighted
Hall of Fame Community Legend

Re: SPA 122 ATA can't acquire IP address. Is it broken or am I just a numpty?

1. Factory reset the ATA
2. Update the firmware of the ATA
3. Configure the SIP settings
Highlighted
Advocate

Re: SPA 122 ATA can't acquire IP address. Is it broken or am I just a numpty?

Claimed "call in progress" despite no analog phone connected may be sign of broken SLIC (consider it just hardware failure unless you understand the acronym)

Check the status page. If either analog line shows "off-hook" despite there's no phone connected at all, you may consider hypothesis verified.

If not, syslog&debug messages may help with further analysis.

 

View solution in original post

Highlighted
Beginner

Re: SPA 122 ATA can't acquire IP address. Is it broken or am I just a numpty?

Thanks everyone. I've tried everything.

 

Es ist Kaputt ;-(