Showing results for 
Search instead for 
Did you mean: 

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.
Get the latest news in this issue of the Cisco Small Business Monthly Newsletter


SPA 8800 echo

Hi all, I have sucessfully setup an 8800 on 3cx IP PBX. The operation was simple and it is very stable apart for echo.

I have all echo can fields turned on, but the end users are complaing about hearing themsleves come back when on an outside call.

If I call in, I dont hear it. Some other characteristics.

At first I was getting lots of my own voice come back when on an outside call. I turned off "echo can adapt enable" and this seems to have helped.

What they are saying now is that when both parties talk the far end is muted slightly to the point of distraction.

I am also told that ehco can still be present, especially it seems when there are a few concurrent outside callers

I really hope someone can help me with this, as it is causing me much grief with my customer

The 8800 is currently on


If I need to updte firmware, can you please let me know whatever other utlitlies or info I need to do an update

Thanks in advance

Everyone's tags (1)
Frequent Contributor

SPA 8800 echo

Below is checklist for echo, try the following to see if it helps narrow down and/or resolves the issue.

1. Make sure you disable "Silence Suppression" in your line configuration and you have enough bandwidth for uplink and downlink of ~100Kbps. You can set "Network Jitter Level" to high and disable echo canceller (optional)

2. Try to lower down the values for PSTN gain. SPA To PSTN Gain and PSTN to SPA gain should be lowered. These values can be set anywhere from -15 (quietest) to 12 (loudest). To give an approximate idea of how loud the different gain values affect volume, -12 is half as loud as -6, -6 is about half as loud as zero, 6 is about twice as loud as zero, and 12 is about twice as loud as 6. The PSTN Gain might just be too high for the adapter to compensate.

3. You should also ensure that your telephone cables and plugs are secure. A loose connection can cause some echo.

4. Calls to cell phones (cell networks) seem to have a longer latency (time delay), thus more echo, than calls to a wireline PSTN number. In addition, some cell phone speaker phones will also create echo; so ask your caller to not use the speakerphone if possible.

5. To help in isolating the problem, try using a different corded phone plugged directly into the device.


SPA 8800 echo

Hi, I have a UC320W with a SPA8800.

When the SPA8800 is connected, we hear echo.  I have read that disabling Silence Suppression may correct it.  I can see the option when I log into the SPA8800 but cannot change it.

Does anyone have instructions on how to change it?




Re: SPA 8800 echo


I understand that you have echo on your CO Line Ports on the SPA 8800 (FXO). In my experience, 95% of the time this is caused by the line impedence being different between the SPA 8800 port and the Telco CO line.

I advise you to go into the "Port Impedence" section on the SPA 8800 and change the settings per port, then make a serious [series] of test calls using that line. Best way to do this is local calls, long distance calls, and cell phone calls until you come up with a best choice.

If you had a Cisco UC320W, you could connect it to the lines and run a test that would tell you exactly which settings to use, however, on the SPA 8800 you will need to do it manually.

Please give me feedback and rating if this solves your problem. Thanks.


Re: SPA 8800 echo

Thank you for your response.

I am running a UC320W with a SPA8800 connected to it.

Within the Configuration Utility for the UC320W there are settings for the SPA8800. 

We have run the impedance matching test and tried adjusted in either direction.

We have no echo issues with the UC320W.

The settings on the SPA8800 match those of the UC320W.

If we take a trunk from the SPA8800, that has echo issues, and move it to the UC320W there is no echo.  We have swapped the SPA8800 with a new one and the echo is still present.  We have also swapped the UC320W and the SF302-08P.

Here are our current settings.

Thank you again.