cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Get the latest new and information the November issue of the Cisco Small Business Monthly Newsletter

164
Views
0
Helpful
1
Replies
Beginner

SPA112 blinking power + Voice module not ready

Hello,

 

I just installed my SPA112 i purchased a few years ago. The internet led is green and steady but the power led is continuously blinking. The phone is connected to "Phone 1" and the phone 1 led is off.I have access to the web management but can't do anything since clicking both the "Quick setup" tab or "Voice" tab is displaying  : " Voice module not ready." I tried updating the firmware from 1.3.5 to 1.4.1 (SR5) but nothing changed. I tried different network configurations : DHCP with ntp server and Static IP with manual time but with no success. I then enabled debug logs and here are some extracts :

 

Jan 1 00:00:07 SPA112 kern.err [17179569.420000] physmap-flash physmap-flash.0: map_probe failed
Jan 1 00:00:07 SPA112 kern.info [17179569.424000] NAND device: Manufacturer ID: 0xc2, Chip ID: 0xf1 (Unknown NAND 128MiB 3,3V 8-bit)
Jan 1 00:00:07 SPA112 kern.debug [17179569.428000] Bad block table found at page 65472, version 0x01
Jan 1 00:00:07 SPA112 kern.debug [17179569.432000] Bad block table found at page 65408, version 0x01
.....
Jan 1 00:00:07 SPA112 kern.err [17179571.100000] ksz8873 0-005f: failed with status -1
Jan 1 00:00:07 SPA112 kern.warning [17179571.104000] ksz8873: probe of 0-005f failed with error -1
.....
Jan 1 00:00:07 SPA112 kern.err [17179580.124000] br0: Dropping NETIF_F_UFO since no NETIF_F_HW_CSUM feature.
Jan 1 00:00:07 SPA112 kern.info [17179581.788000] device eth0 entered promiscuous mode
Jan 1 00:00:07 SPA112 kern.info [17179581.788000] br0: port 1(eth0) entering learning state
Jan 1 00:00:07 SPA112 kern.debug [17179581.796000] sysevt_comm_sendto: (52, rc)=>
Jan 1 00:00:07 SPA112 kern.debug [17179581.808000] sysevt_comm_sendto: (52, rc)=>
Jan 1 00:00:07 SPA112 kern.warning [17179581.872000] Empty flash at 0x000e2010 ends at 0x000e2800
Jan 1 00:00:07 SPA112 kern.notice [17179581.876000] jffs2_scan_inode_node(): CRC failed on node at 0x000eafec: Read 0xffffffff, calculated 0x1a3e6142
Jan 1 00:00:07 SPA112 kern.warning [17179581.888000] Empty flash at 0x000eb060 ends at 0x000eb800
Jan 1 00:00:07 SPA112 kern.warning [17179581.904000] Empty flash at 0x000ec810 ends at 0x000ed000
Jan 1 00:00:07 SPA112 kern.warning [17179581.916000] Empty flash at 0x000ee808 ends at 0x000ef000
Jan 1 00:00:07 SPA112 kern.info [17179583.788000] br0: topology change detected, propagating
Jan 1 00:00:07 SPA112 kern.info [17179583.788000] br0: port 1(eth0) entering forwarding state
.....
Jan 1 00:00:21 SPA112 kern.info [17179598.576000] device eth0 left promiscuous mode
Jan 1 00:00:21 SPA112 kern.info [17179598.584000] br0: port 1(eth0) entering disabled state
Jan 1 00:00:21 SPA112 kern.debug [17179598.708000] sysevt_comm_sendto: (52, rc)=>
Jan 1 00:00:21 SPA112 daemon.info system[1]: vlan-module send out delete interface(br0, 0x8) notify...(0)
Jan 1 00:00:21 SPA112 daemon.info system[1]: delete interface br0 with vid(0)...
Jan 1 00:00:21 SPA112 kern.err [17179598.784000] br0: Dropping NETIF_F_UFO since no NETIF_F_HW_CSUM feature.
Jan 1 00:00:21 SPA112 daemon.info system[1]: new create interface br0 with vid(0)...
Jan 1 00:00:21 SPA112 kern.info [17179599.092000] device eth0 entered promiscuous mode
Jan 1 00:00:21 SPA112 kern.info [17179599.100000] br0: port 1(eth0) entering learning state
Jan 1 00:00:21 SPA112 kern.debug [17179599.112000] sysevt_comm_sendto: (52, rc)=>
Jan 1 00:00:21 SPA112 daemon.info system[1]: vlan-module send out update interface(br0, 0xa) notify...(0)
Jan 1 00:00:21 SPA112 daemon.err system[1]: notify add wan1 interface(br0)

 Any idea of what's going on ?

 

Thanks in advance

Everyone's tags (1)
1 REPLY 1
Advocate

Re: SPA112 blinking power + Voice module not ready

Reset SPA112 to factory default (Press and hold RESET button for 20 seconds.).

If it doesn't help, read SPA 112 power light flashing continuously.

If spare power adapter will not help, consider SPA112 faulty.

 

See also Status Lights and Ports on the SPA112 and SPA122