cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

6361
Views
0
Helpful
11
Replies
ikoimecs
Beginner

spa112 can't get T.38 fax working

Dear Support,

We are testing new cisco ATAs - SPA112 to replace SPA2102 which is out of sale. We never had fax issues with SPA2102, but now can't get T.38 working on new SPA112. Tried different settings, including recommeded in admin guide (section: "Optimizing Fax Completion Rates"), but nothing helped.

There is difference in receiving and sending faxes, but with stable results - sending fails, receiving - success, but with retransmissions and at lower speed. This is how it look like:

1. Sending:

- T.38 negotiation successful

- receiving (PSTN) side sends T.38 DIS messages three times, but SPA112 does not send back DCS message and does not start fax transmission.

- fax transmission fails

2. Receiving:

- T.38 negotiation successful

- DIS-DCS-Training procedure successful (14400b)

- first page received, but after MPS (multipage signal ) from sending side, SPA112 sends back RTN (retrain negative) every time

- procedure continues at 12000b, fails again

- procedure continues at 9600b, and this time successfully

- next pages transmitted at 9600b successfully.

Upgraded to v1.2.1, but nothing is changed.

Please find attached call analyis from wireshark - two calls incoming and outgoing.

Also please find attached fax config screenshot.

Best regards

Ivo

11 REPLIES 11
Patrick Born
Cisco Employee

Hi Ivo,

Just to be clear, this is a community forum, not "official Cisco support".
If you want or need support, please locate the phone number of the Cisco Small Business Support Center that is closest to you at the

http://www.cisco.com/en/US/support/tsd_cisco_small_business_support_center_contacts.html URL.

I'm interested in further investigating the T.38 fax issue that you're reporting. Can you please send the following to me at paborn at cisco:

- SPA112 configuration:

    http://ipOfSpa112/admin/config.xml > view source, copy all, paste into a file

    (view source so that output is nicely formatted)

- Description of network, test environment, and test equipment

Regards,

Patrick

----------

Hi Patrick,

Please check e-mail.

Regards,

Ivo

Hi Ivo,

Thanks for sending me the information.

I've filed this issue against CDETS# CSCub63326 and will report back after further analysis.

Regards,

Patrick

----------

Ivo- Have you received any resolve to your fax problem?  Im running into same issues with my SPA112. Several of my audio configs are different from yours, at the suggestion of Callcentric. But still no consistant faxing outbound.

tnx- Craig

Hi Craig,

Sorry for the delay, I was on vacations. The problem still not resolved. They suggested to change Gain settings to improve completion rate for sending:

"I  think I can reproduce your problem under my test bed now, and as I told to Ivo  before, we suspect which is related to signal attenuation, so just wonder  whether the call can work fine when you set =3dB? According to my  test, when change this parameter to 3, the outgoing call can work fine."

Also there is some issue with reception, and they are working on it:

"About  this issue, we suspect this is caused by the reason that our t38 lib cannot  encode/decode CED tone packets, which cause the fax call training failure, and  currently our third part vendor is working on this feature requirement. And we  will get back to you once it done."

Regards,

Ivo

Hi Ivo,

I've just sent you an email with a link to Engineering test code where we believe we've resolved the T.38 issue you reported and would appreciate you testing in your environment.

Regards,

Patrick---

Hi Craig,

If you'd like to test our fix for this T.38 issue with unreleased Engineering code, please contact me at paborn at Cisco and I'll get the firmware to you.

Regards,

Patrick---

   Use this reference document to locate SPA ATA resources including, firmware, docs, & application notes

Hi patrick,

I have the same issues on my SPA112s with latest firmware (JAN13)

I'm available for your Engineering code.

You can write me ... livio at airbeam dot it

Hi Livio,

Checking my notes, I see I sent you the firmware on April 9th. Were you able to test the firmware? If so, how did it work out for you?

Thanks,

Patrick---

Hi,

I sent you a couple of email the same day.

It works (sometime), but looks like there are some other problems.

Hi ptraick i have the same fax problem, can you send me the firmware on april 9th, thanks!!!