Showing results for 
Search instead for 
Did you mean: 

Get the latest new and information the November issue of the Cisco Small Business Monthly Newsletter


spa112 proper way to provision


We have been using PAP2t and they worked and provisioned well.

I create the file on my tftp server and then plug the PAP2T into my network.  In 5 minutes it has downloaded its config, upgraded its firmware and is registered.  The IVR works after about 5 seconds of plugging it in.  On a rare ocasion or when we are in a rush we get the ip and do a admin/resync

Using the spa 112 this does not work

I create my tftp config file and plug in the spa112.  After between 1-20 minutes (usually closer to 10) the IVR comes up and I can get an ip address.  Now I do a admin/resync  to get it to pick up the /spa112.cfg file.  now the spa112 has the profile rule a with all my default configs, profile rule b with the ata specific stuff.  I have to again wait the 1-20 minutes to get IVR to to an admin/resync.  now the spa112 has a firmware (1.1.0) file saved.  I have to do another admin/resync to get it to get the firmware

It literally takes us 45 minutes on average to get a spa112 provisioned vs 5 min (and no work) on the pap2t

What is the proper way to provision, shouldnt this work like the PAP2t or the spa50x phones do?

Shouldnt the spa112 request the spa112.cfg file on boot up as the defualts contain resync at boot?

Just tired of the spa112  

If anyone has a batch of PAP2T's please contact me 714-338-8807


Everyone's tags (4)

Re: spa112 proper way to provision

At the first, 5minutes for PAP2T is so long for me. So I developped procedure to minimize the delay that works for PAP2T. Now, it works for SPA112 as well for me with no modification, I ha snot been affected by problem your described.

I can describe my procedure to you, it may help you to solve your problem.

Following data are taken from SPA configured to "factory default" via IVR, then disconnected. Time is in format M:SS

SPA in question has 1.2.1 firmware, but if I remembered correctly, it worked even with 1.0.2 for me.


+0:00 - device powered on

+0:40 - DHCP started by device

+0:49 - DHCP handshaking completed, device has IP address and option 66 with TFTP server name

+1:04 - NTP query started from device, got reply from server, completed

+1:08 - DNS query with TFTP server name, got reply from server

+1:08 - TFTP RRQ /spa112.cfg, data transfer

content of first-time configuration file downloaded from TFTP:







The trick is "flip/flop" of Enable_CDP. As this attribute require rebot on change, this force device restart. You can use any other attribute that force restart on change. As Resync_On_Reset is set to Yes, new provisionign request will be issued after reboot.

In advance, there is Resync_Periodic and Resync_Error_Retry_Delay set to 30s, just to be sure.

+1:09 - first-time configuration download complete

+1:54 - DNS request for, resolved succesfully

+1:55 - HTTPS request

     final device configuration downloaded from HTTP server

+1:55 - device reboot

+2:43 - DHCP started

+2:54 - DHCP completed

+3:02 - NTP started & completed

+3:52 - SIP REGISTER sent, registration completed, device ready for call


You can compare my results with yours. It may help you to solve the problem.


Re: spa112 proper way to provision

You have this listed



Do you mean to have this under the same flat profile or is that supose to show both times?


Re: spa112 proper way to provision

The content of tftp://.../spa112.cfg (a.k.a first-time configuration) has been included in my comment exactly as I have it.

I'm not sure what you are asking for.


Re: spa112 proper way to provision

I ran a new config with a spa112 fresh from the box.

I got dhcp

It then requested ntp, it got a responce then sat for 20 minutes before I got bored of it sitting there.

The next one I plugged in exactly the same way



reads file 1


reads file 2 and 3



download firmware



This is plugged into the same cable, behind the same router with the same config files.


On a side note I found a supplier who still has PAP2t's I have 300 on their way.