cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

835
Views
0
Helpful
8
Replies

SPA232D DECT reorder tone

Hello,

Although it's not officially supported, it seems that the SPA232D can work with third-party DECT/GAP handsets.
After setting "Handset Pairing Passwd" to 0000, I can successfully register any DECT/GAP handset.

I set up a SIP profile on DECT Line 1. Inbound calls are working fine. However, when trying to call outbound, all I get is a reorder (fast busy) tone for 4-5 seconds. Why is this?

Unfortunately I do not have an official SPA302D handset to test with.

Calling outbound with a wired phone on Line 1 does work fine (identical SIP profile).

I'm using the SPA232D in bride mode, I set up a fixed IP address. TCP/UDP ports are correctly forwarded.
Hardware: SPA232D-G7 v02
Firmware: 1.4.1

Any help is appreciated.

Thank you.

8 REPLIES 8
Dan Lukes
Advocate

I had tried a Siemens DECT handset with SPA232D and it has worked.

Unfortunately, no way we can help you with issues related to undisclosed handset running on SPA232D with unknown configuration.

Turn on syslog&debug of Voice application and catch them. It may help to identify the cause.

I'm using a Motorola D101, but also tried different brands which behaves the same.

DECT Line 1 is configured for my SIP provider. Inbound calls are working fine.

This is what happens when pressing the off-hook button (without entering a number):

cordless_tick(), got something...
cordless_SIP_AP_eventProc(), recevie cmd = 0, src AP = 2
Initial Address
 
 (instance = 0x10000006, source = , dest = , line = 125)
 Cordless session 0 allocated
cordless_SIP_AP_eventProc(), IAM comes from handset 1
preProcessHandsetOutNum(0x2c7c58)
preProcessHandsetOutNum(125)
All call occupied, make call failed
cordless_SendLineCfm(0, 0, 6)

Instead of a dial tone, I get a reorder (fast busy) tone for 4-5 seconds, then it ends.

What do you think of this?

DECT use SS7 protocol inside.

IAM stands for Initial Address Message. It is requests to call to be established. Contains the called number, type of service and other parameters.

In short - your Motorola is trying to call somewhere. May be it wish for overlapping call sequence setup.

Unfortunately, I'm not near my test lab now, so I can't try it and compare dialing sequences.  May be my Siemens has used en-block dialing.

I will try once I will return.

It does register each key press like this:

cordless_tick(), got something...
cordless_SIP_AP_eventProc(), recevie cmd = 1, src AP = 2
instance(0x10000002) not found!

However these entries appear after the "make call failed" error (whether entered before or after pressing the off-hook button, both the same).

It seems like it's trying to call an empty number. So I tried a hot line auto dial plan like ( <:12345>S0 ), but it still gives the annoying reorder tone and doesn't call 12345.

Also tried with a Philips D500 handset.
Please note I'm located in Europe, so DECT frequency band is 1880-1900 MHz if this matters.

All call occupied, make call failed

... sounds suspicious to me. It may disclose the configuration is incorrect. FOr example the DECT1 line is not connected to valid/configured outgoing SIP extension.  But until I will try it by self I can make blind guesses only. I will return within few days (somewhere from two days to two weeks, no better estimation, sorry).

 I'm located in Europe, so DECT frequency band is 1880-1900 MHz if this matter

SS7 Messages are delivered from handset to base station, so they are properly connected at link (wireless) level.

I'm curious to your findings.

DECT Line 1 SIP is configured correctly, as far as I can tell. If I apply same config on Line 1, outbound calling works fine using a corded telephone.

I think this is suspicious:
(instance = 0x10000006, source = , dest = , line = 125)

125? Shouldn't that be line 1-10?

In these unrelated threads your syslog says line = 2
SPA232D problems integrating with POTS via FXO
Extra # on the end of called number (SPA232D+SPA302D)

Any news?

Yes, I'm back. But not so good news for you. It doesn't work now.

During my previous attempt I has used SPA232D with an ancient firmware version (I don't remember the exact number). It has worked. With 1.4.0 it works no longer. Even inbound calls doesn't work with my Gigaset. Even headset's login to base station seems to be incomplete - the base station seems not to know IPEI of headset.

As downgrade may brick the device, I will not try to downgrade it.

But verbosity of logs I can capture seems to be substantially higher than the one you provided. Did you set debug level to 3+COMA ?

See bellow for captured logs for HS login (to base station), incomming call, outgoing call. It's catched for A) Siemens Gigaset, B) SPA302 (to establish baseline).

I'm still not giving up. I wish to see what number is dialed by your HS. E.g. your equivalent of following excerpt of my SPA302 outgoing log:

[Cordlesslog] Receive <--Handset No : 1 Instance : 0
[Cordlesslog] 7b 2c 5 36 30
[Cordlesslog] 30 32 23 7e 6
[Cordlesslog] 1 0 80 0 0
[Cordlesslog] 83

You can read ASCII with no supporting tool, isn't it ? ;-)

Thus you can see it by self - 36 30 30 32 23 = "6002#"

Yes, even fully supported SPA302 headset sends 6002# to base station instead of 6002 I has dialed. Unless it's allowed in Dial Plan the call will be rejected.

Thus I'm curious to see your outgoing call log to identify number sent by your HS.