Showing results for 
Search instead for 
Did you mean: 

Jabber IM address being displayed wrong


Running IMP 10.52

Users login with first initial and last name.  IM address should be their email address.  (first name . last name @

When attempting to IM other users email address shows correctly but IM address displays as first initial and lastname @

How can that be changed to reflect email address as the IM address?

14 Replies 14

Cisco Employee
Cisco Employee

Your IM address is always going to be the address you use to log into Jabber.  In Jabber, this is called a JID.  It consists of (and I'm speaking in "jabberese" here) node @ domain / resource, where resource is an ID for the particular client you're using. In general, you do not supply the resource. The client does that. The node is the username.

You can set the display name to something else, which might be a way you could display the user's email address.   But that's just what it says - a display name.  Your IM address will always be the login ID (node).  This is usually the user's email address, too, but even if it's different, Jabber doesn't use the email address for messaging.  Does this answer your question, or did I misunderstand?

By the way, if you set the display name (nickname) in your roster to the email address for that contact, it will appear as if you're sending the IM to the email address, even though it's using the JID under the covers. 

Edward Noell

WWere you able to get this resolved? I have same issue where users are able to be added but their IM address is showing up as their SAMaccount ID vs Mail ID.  Email is correct in jabber profile just not im address.  RUnning 10.52 as well.


Same situation here.... I'm connecting from a developer domain to our jabber server that is on production domain, the email showing is from developer domain.  I'm unable to use the phonebook to make call too. I can make call if I type the number but I cannot search by name and call because the phone icon won't show.

Using a production domain computer this works fine.

Is there a way to fix this?

I'd need a lot more detail to tell you what's happening in your situation.  But again, here's how it works:

Your Jabber IM address is userid@domain/resource.  Ignore resource for right now.  If you want to know what domain it is using, go to the administration web UI for your CUP/IMP server, and go to Presence->Settings->Advanced Configuration. You should see something like this:


There's the domain.  The most safe selection is the first one, Do not change the Default Domain or IM Address scheme.  So, in this case, the IM address will be  It doesn't matter if your email address is something different.  This is what the Jabber IM address will be. 

If you have more than one CUP/IMP server, then your IM address will be determined whichever one you use if you don't have them all synchronized to use the same domain.

Now, as to resource, this is generally assigned by the Jabber client you're using.  You don't have to worry about that, but you should be aware of it, since it determines where messages go.  If you send me a message, and I respond using Jitsi, then the rest of our conversation will be between you and me at  The remaining messages won't show up in other Jabber clients (unless you have a server that supports carbons, and as of 10.5, Cisco IMP doesn't support carbons). 

Nicholas, the OP and others are stating that their login ID for Jabber and the IM address is their username@domain; and they wish to use Email address instead. This isn't a complicated thing to grasp. By default CUPS uses username@domain for log in and sending chats.

Do you have any information or documentation links on how to fix / re-configure CUPS to allow sending IMs to the users email address? I guess that after this type of change, sending IM's to username@domain would no longer work, and any contacts added this way would then show as offline until they were deleted and re-added.

See below screen shots. I believe this is describing the issue?

I have configured users IM chat address to be their Directory URI which is set to use their email address as their chat IM address.

This is set correctly within each users profile, but not within the Directory that the user users to find a contact.

i.e. User "Danny Dog" has a domain account with a login of

But he has an email address of

The correct IM address is set correctly ( within his own profile, (i.e. contains firstname.lastname, but all other users see his chat IM address incorrectly to be his login

This means all users see danny presence status as unavailable and are not able to send any IM to him "Message to Danny Dog could not be delivered".

I assume this must be a bug and effectively  means that you are NOT able to set the IM address to use the Directory URI.

So quite a big bug. I am running 10.5.1

Is there any known workaround?




Some further details:

As you can see that within the IM & Presence Server, the IM address is set correctly.

And this is what each profile see as their OWN IM address. But it views all other contacts as having an IM address of <userid>@<domain> which is not correct (instead of the correct IM address of <email address> or <firstname>.<lastname>@<domain>



Are you using LDAP/Active Directory?

Do you have multiple IM&P servers in a cluster?

Can you post a picture of your Advanced Presence Settings on your IM&P server?  The page looks something like this:



I am using LDAP directory for import of users and authentication.

There is no point in sending a screen shot of that Advanced Presence Settings, because after you make your changes, it always reverts back to looks like your one (except with "my" domain name in it). It does't show how it was configured..

The important thing to note, is that I did used the Advanced Presence Settings tro change from default IM address of <user>@<domain> and selected 3rd option "IM Address Scheme" and changed this to use the "Directory URI" (which is available as an option) and the Directory URI is set on each user on AD import to be the same as their email address attribute value in AD.


Hi all,

is there any fix?

Or do I have to use the jabber-config.xml workaround?


Just an FYI here as I did plan on changing the IM address scheme for our org. to use email address rather than userID@domain so as to make things a bit easier for signing in. However I've made some other recent changes and now I think the IM address scheme change is redundant.

My env.:

CUCM / IMP 11.0

MRA via Expressway's 8.6

Active Directory with Windows 2012 server

SAML SSO with ADFS on Windows 2012 server

Because of the SSO implementation for on-premise and MRA, we can sign in using email address such as ""; or we can use the old method "" where flastname is really the first initial, then lastname. Because of the portion and the portion I have multiple SRV records internally and externally for the autodiscovery to work regardless or what login name is entered. I recently heard that autodiscovery is not implemented in later jabber releases so I'm not sure if these are still required.

For the SSO Sign in, I ran a powershell command (found from google, because I'm not a MS person but I know how to use google ) which means users can use their email address as their username or their user ID as normal.

Once signed in, internal users are found through the LDAP, or are populated automatically through Active Directory groups. I have 3 groups for all users (40 people in the company) and this covers all sites. IM address for internal people is the (our internal domain is a sub domain of the external domain). The IM address for internal users is transparent and never actually typed out by anyone.

For XMPP federation, external parties can send messages to our email addresses such as This is done directly to IMP through our firewall (not via Expressways).

So to summarise, users can log in using email address and external parties send IM's to our internal users via their email address. The only area where the userID@domain IM address is in use is internally which is benign / transparrent to our users.

Hope this helps.


That is useful and interesting. As you say, the end user within a corporation do not ever type an IM chat address, but for external IM you woudl want the your IM address to match your email address (on your email signature).

The issue I believe I have is, is that the directory supplied by CUCM to the Jabber user has an INCORRECT IM address for each user to what the user actually has in IM &P and so when you send an IM it fails.

The SSO Login and different login options  are not directly related to the IM chat address.

But maybe my problem is that I am not using or not configured correctly the directory that the Jabber users are getting to get their chat address.

Any chance you show a screen show of your UC Service Directory config?


I have an update on this issue (thanks Alexey!).

Apparently you need to manually update yoru jabber-config.xml file to use the <email-address> as the IM address.

below is the file and the relevant parameters settings.

I will test and confirm if this works.

But clearly if it does, this is a bug and should be done by the IM & P server automatically when you change the IM address format....


File name: jabber-config.xml

Location tftp root :/







Interested to know if the IM address can be changed via the jabber-config.xml as this doesn't seem like a normal config change. The config file is for the jabber application config as I understood and the IM address is not an end-user application setting.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers