Showing results for 
Search instead for 
Did you mean: 

Jabber SDK error Chrome - "Could not initialize CWIC library"

Level 1
Level 1


The Chrome SDK is not working anymore, it says extension is not installed although it is?

I host the!downloads-and-documents/sample-code on localhost and it works fine on Firefox, but on Chrome it looks like this, saying "Could not initialize CWIC library: ExtensionNotInstalled". Although it is, see pictures attached.

What has happend to this Chrome extension? It used to work but now it does not, what has changed?

This is our last chance before we give up this product. All help is much apreciated.

Thanks in advance



16 Replies 16

Cisco Employee
Cisco Employee

See new post - it's working fine for me in Chrome.

Cisco Employee
Cisco Employee

I have to take that back. I'm running Version 98.0.4758.102 (Official Build) (64-bit) of Chrome, and it's working for me. Please check your Chrome version, and let me know what it is.

Cisco Employee
Cisco Employee

I see you're using newSample/sample.html. Make sure you also copy the src directory in the same place you have newSample.



I simply unpacked the zip as it was, i.e, no changes has been made to any file.

See picture of zip file and local files, all is correct. But also then it wouldnt run on Firefox, since its hosted on localhost, i.e. same code running for both browsers.

I cannot see what could be wrong? There arent any settings as far as I could tell in the extension browser in Chrome. Tried with both "enable in incognito" and without it, no changes there either..

Not anything with admin priveleges aswell, which could've been a thing possibly..

Im really running out of the why here. Its not working for my colleague either so its not just my local machine, both ours, and our customer that reported the first of it. No links there since the sample code was taken from the web. The customer has not touched any code nor have we deployed anything on our end, yet same issue occurs, which only points to the extension itself / its interaction with Chrome being different on our local enviroments, I would assume?

But how?! Was so satisfied with what you replied at first then to take it all away haha..

Thanks for the replied.

Perhaps you don't have the two directories directly in the document root of your web server? For example, my server puts everything in a directory called htdocs. If I point my browser to localhost, it gets the index.php file in htdocs.


I put both newSample and src in htdocs, so that I navigate my browser to




If I put newSample and src in a directory under htdocs (like htdocs/whatever), and then try to browse to


http://localhost/whatever/newSample/sample.html, it won't work.


However, this behavior is not specific to Chrome, so it would break in Firefox, too.


Anyway, it's working fine here, so I'm not sure what to tell you. 

Oh, I forget, can you tell me what version of Chrome you're running? Our Chrome installations are managed by Cisco, so mine is Version 98.0.4758.102 (Official Build) (64-bit), and I can't run another version.

Yes, we have the exact same version then, the latest official one. And about the directory stuff you posted above, I hosted it just as it was told in the official instructions from Cisco, which works on FF but not on Chrome.

Chrome is up to date
Version 98.0.4758.102 

I cannot see why all this is. Why its working for you might be that you're a Cisco Employee with a Cisco setup which somehow makes stuff work thats "inside" the Cisco enviroment. Because I cannot see what else it could be. I mean why is it working on FF but not on Chrome, I cannot possibly see what it could be on my end that is somehow preventing Jabber from doing its thing you know?

Sadly I think I must recommend the customer to chose some other app for this functionality since this is simply not working anymore, unless you guys come up with an update or so. Literally tried every possible solution now, I cannot see any other way to try this out for Chrome. 

There's nothing special about the Cisco network, and I'm using a server in the lab that doesn't know anything about me being a Cisco employee.


I think it's more likely that your Chrome installations have a conflicting extension, or there's a Chrome setting that's causing the problem. Or, a more common problem is one of a corrupted installation, especially if you upgraded instead of doing a fresh install. More than a few times, I've solve Chrome/Jabber voice/video issues by using revo-uninstaller (free) to completely remove the add-on (and remove any registry settings) and then re-install it.




If you still want to give it a chance, I recommend this link:!troubleshooting/voice-and-video---troubleshooting


Cisco Employee
Cisco Employee

As mentioned in the other thread, unfortunately the sample code download linked on the Jabber Downloads page was a bit out-of-date; however in testing today (Win10, latest Firefox and Google Chrome) with the add-ons/extension freshly installed, even the old sample code still worked...

Does the Chrome browser developer tools web console show any errors?  Any files not downloading as expected from the dev tools network tab?  Is this occurring on Windows and Mac?

Replied with the image on the wrong thread.

Here it is in the right context, printscreen from yesterday. However, I do not get the same error today, which I find a bit amusing.

"Resources must be listed in the web_accessible_resources manifest key in order to be loaded by pages outside the extension."

I attach an image from the same try today, which honestly is quite odd, nothing has moved since yesterday. I tried reinstalling the addon once again, only difference from the other printscreen.


From todays print in the network tab: "Referrer Policy: strict-origin-when-cross-origin". Could that be onto something?

Thanks for the quick replies!