cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1315
Views
0
Helpful
2
Replies

Valid Resource Icon

gorbunov
Level 1
Level 1

 

 

 

 

 

 

 

Hello!

 

Having a probelm with Resource Icons. All of them except 2 are displaying just fine. The only two that are messing up are the

onces with names that don't seem to follow the logic of other names. They are:

  1. AnimatedIcon.Ringin
  2. AnimatedIcon.StreamRxTx

Notice that (1) is missing a "g". The example the dev notes (9.1) seems to indicate that the spelling is indeed "AnimatedIcon.Ringin". For (2), the other "Stream..." names say "Streaming" while this one says "Stream".

Anyway, I tried both versions of each (AnimatedIcon.Ringin/AnimatedIcon.Ringing and AnimatedIcon.StreamRxTx/AnimatedIcon.StreamingRxTx). None worked. I get the default mission image icon. All the other icons (animated and static) all work.

 

I downloaded a phone firmware and found that both files exists. I think this is a firmware problem. 

Not found this bug in bug search tool. Is there any workaround?

 

Same problem described here.

2 Replies 2

dstaudt
Cisco Employee
Cisco Employee
Can you confirm the phone is on the latest firmware version available? Which model/version?

I would suggest opening a ticket with DevNet Developer Support so we can look at some detailed traces and work with engineering to see if this is a defect that can be fixed: https://developer.cisco.com/site/support/

We have tryout this phone models:

  1. Cisco Communicator 8.6.6.0
  2. Cisco IP Phone model 7970
  3. Cisco IP Phone model 8961
  4. Cisco IP Phone model 9951
  5. Cisco IP Phone model 8941
  6. Cisco IP Phone model 8811

All phones has latest firmware.

I think any model will give you the same result. 

Just push this XML to phone and you will see:

<CiscoIPPhoneIconFileMenu>
	<IconItem>
		<Index>1</Index>
		<URL>Resource:AnimatedIcon.Ringin</URL>
	</IconItem>
	<MenuItem>
		<Name>Menu Item</Name>
		<IconIndex>1</IconIndex>
		<URL></URL>
	</MenuItem>
</CiscoIPPhoneIconFileMenu>

For now i have no possibility to open a ticket.