cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
975
Views
0
Helpful
4
Replies
Highlighted
Beginner

ACI Learning Labs problem

Hi all,

I'm stuck with a problem on ACI Programmability Options lab, section APIC Sandbox Environment Setup, it says:

# From within the correct virtual environment (venv) apic_fabric_setup\ $ python baseline.py

# Expected Output

Baselining APIC Simulator for Learning Labs

Setting up Fabric Nodes

Configuring Fabric Policies

Setting up Common Tenant

Setting up Heroes Tenant

Setting up SnV Tenant

But my output is:

(venv) C:\Python27\aci-learning-labs-code-samples\apic_fabric_setup>baseline.py

Baselining APIC Simulator for Learning Labs

Setting up Fabric Nodes

Configuring Fabric Policies

Traceback (most recent call last):

  File "C:\Python27\aci-learning-labs-code-samples\apic_fabric_setup\baseline.py", line 11, in <module>

    import startup_script

  File "C:\Python27\aci-learning-labs-code-samples\apic_fabric_setup\startup_script.py", line 225, in <module>

    md.commit(c)

  File "c:\python27\lib\site-packages\acicobra-3.0_1k-py2.7.egg\cobra\mit\access.py", line 63, in commit

    return self._accessImpl.post(configObject)

  File "c:\python27\lib\site-packages\acicobra-3.0_1k-py2.7.egg\cobra\internal\rest\accessimpl.py", line 176, in post

    return self.__parseError(rsp, CommitError, rsp.status_code)

  File "c:\python27\lib\site-packages\acicobra-3.0_1k-py2.7.egg\cobra\internal\rest\accessimpl.py", line 234, in __parseError

    parseXMLError(rsp.text, errorClass, httpCode)

  File "c:\python27\lib\site-packages\acicobra-3.0_1k-py2.7.egg\cobra\mit\xmlcodec.py", line 15, in parseXMLError

    raise errorClass(int(errorCode), errorStr, httpCode)

cobra.mit.request.CommitError: Validation failed: Validation failed for node: 102Overlapping interfaces. Last examined: uni/infra/accportprof-dci-l3out-104

Any ideas what I may have done wrong?

Thanks,

4 REPLIES 4
Cisco Employee

Re: ACI Learning Labs problem

You are NOT doing anything wrong.

Overlapping interfaces - server has something already configured

Beginner

Re: ACI Learning Labs problem

Hello all, so what is the fix here?  I am running into a similar issue within the 1st page of the 

Intermediate ACI Programmability module

I run the baseline.py script and I get the following , looks like it is not able to import anything in the cobra library:

 

(venv) C:\Python27\CISCO_DEVNET\aci-learning-labs-code-samples\apic_fabric_setup>python baseline.py
Traceback (most recent call last):
File "baseline.py", line 11, in <module>
import startup_script
File "C:\Python27\CISCO_DEVNET\aci-learning-labs-code-samples\apic_fabric_setup\startup_script.py", line 3, in <module>
import cobra.mit.access
File "C:\Python27\CISCO_DEVNET\aci-learning-labs-code-samples\venv\lib\site-packages\acicobra-3.2_1m-py2.7.egg\cobra\mit\__init__.py", line 2, in <module>
from ._mit import Mit
File "C:\Python27\CISCO_DEVNET\aci-learning-labs-code-samples\venv\lib\site-packages\acicobra-3.2_1m-py2.7.egg\cobra\mit\_mit.py", line 8, in <module>
topRoot = importlib.import_module('cobra.model.top')
File "C:\Python27\Lib\importlib\__init__.py", line 37, in import_module
__import__(name)
ImportError: No module named model.top

Everyone's tags (4)
Beginner

Re: ACI Learning Labs problem

I had same issue with interface profiles- validation failed overlapping interfaces error

the solution was that I was missing the to and from port in the range.

 

"children": [{
"infraPortBlk": {
"attributes": {
"dn": "uni/infra/accportprof-LEAF{{node}}/hports-E{{port}}-typ-range/portblk-block2",
"fromPort": "{{port}}",
"toPort": "{{port}}",

 

I added those two values and it now works.

Beginner

Re: ACI Learning Labs problem

the APIC API blows.  I'm running 4 code and i'm getting the same error from my APIC.  I go and delete the interface from the access port selector list and then try to readd it thru API and can't.

 

Their validation is not in sync with is showing up in the APIC GUI.  It seems like once you create a policy in the GUI, you can't recreate it in the API if it's ever been created.  There must be something somewhere else holding onto the values in the port profile/interface selecctors.

 

Did you ever get a solution to this issue?

 

 

Content for Community-Ad
August's Community Spotlight Awards
This widget could not be displayed.