cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
332
Views
0
Helpful
1
Replies
Beginner

Cobra issue

I keep following the instructions over on "ACI Programmability Options" section 2 under setup your PC I have tried several different OSs including a fresh Ubuntu and CentOS install.  I keep hitting the error below.  Any ideas?

Processing dependencies for acimodel===3.0-1k

Searching for acimodel===3.0-1k

Reading https://pypi.org/simple/acimodel/

Couldn't find index page for 'acimodel' (maybe misspelled?)

Scanning index of all packages (this may take a while)

Reading https://pypi.org/simple/

No local packages or working download links found for acimodel===3.0-1k

error: Could not find suitable distribution for Requirement.parse('acimodel===3.0-1k')

1 REPLY 1
Highlighted
Beginner

Re: Cobra issue

Why does Cisco have a python 2.7 requirement for their SDK?  It's getting EOLed in 2020 (only 2 years) and has no official support now.  Why not do a python 3.# release for it?  So I'll have to figure out 2.7, then change the code to 3.# in a few years?  BOOO!!!!

Content for Community-Ad
August's Community Spotlight Awards