cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1974
Views
10
Helpful
12
Replies
Highlighted

PNP on trunkports

Hello,

I being looking for a solution to get pnp to work with trunking ports.

My current config is a upstream router (1941) with a EHWIC-D-8ESG-P and a downstream switch WS-C2960XR-48TS-I.

I configured the router as followed:

ip dhcp pool PNP

network 10.243.208.192 255.255.255.192

default-router 10.243.208.193

option 43 ascii "5A1D;B2;K4;I10.0.180.10;J80

option 60 ascii 'ciscopnp'

  remember

vlan 990

name TEST

interface vlan 990

ip address 10.243.208.193 255.255.255.192

pnp startup-vlan 990

interface GigabitEthernet 0/1/6 (a port of the 8 port module)

switchport trunk native vlan 999

switchport mode trunk

no ip address


sh cdp tlv app

APP TLV (Gig 0/1/6), Configured tlv type: 4099 value: 1

When i boot the switch i looks like he doesn't create vlan 990 (normally he should create it because of command pnp startup-vlan 990, no?).

If I configure Gi0/1/6 as a accessport in vlan 990 the setup works just fine. But I need the interface to be a trunk because after the config is pushed to the switch the port on the switch is a trunk port with native vlan 999.

Friendly greets from Belgium,

Stefan

12 REPLIES 12
Highlighted
Cisco Employee

Re: PNP on trunkports

Hi Stefan,

a quick question.  The you try int g1/0/6 as access port, does vlan 990 get configured on the 2960?

What version of code is the 2960 running?

Adam

Highlighted

Re: PNP on trunkports

Adam,

Thx for the super fast reaction.

No the switch stays in vlan 1, receives a ip address + dhcp options and goes from there...

2960 SW Version: 15.2.(2)E6

1941 Version: 15.6(3)M

Stefan

Highlighted
Cisco Employee

Re: PNP on trunkports

I am just taking a closer look at this. 

It looks like the pnp startup-vlan is not being propagated via the switch in the 1941.  You should see another TLV with the value of the startup vlan.

Just as a test, can you do a

"

no pnp startup-vlan 990

pnp startup-vlan 990

"

then

sh cdp tlv app

Adam

Highlighted

Re: PNP on trunkports

Adam,

I executed the commands an now the vlan gets created at the 2960

sh cdp tlv app

APP TLV (Gig 0/1/6), Configured tlv type: 4099 value: 1

APP TLV (Gig 0/1/6), Configured tlv type: 4103 value: 990


Now the vlan exist on the 2960 but he can't get a ip address.

Config SW:

interface GigabitEthernet 1/0/48 (uplink to the router)

switchport access vlan 990

macro description CISCO_SMI_EVENT

interface Vlan990

ip address dhcp

I understand why he can't get a ip address (Trunk port router (G0/1/6) has native vlan 999 and the port on the SW is configured as a access port with vlan 990).

So i was thinking to change the native vlan to 990 but then I get on the switch spanning-tree:

Received 802.1Q BPDU on non trunk GigabitEthernet 1/0/48 VLAN990.

Blocking GigabitEthernet 1/0/48 on vlan 990. Inconsistent port type.

Stefan

Highlighted
Cisco Employee

Re: PNP on trunkports

Hi Stefan,

I think you want to make trunking desirable on the uplink.  Leave the native VLAN.

"switchport mode dynamic desirable"

Have you seen my PnP blog series?  Network Automation with Plug and Play (PnP) – Part 4

and Network Automation with Plug and Play (PnP) – Part 5

Adam

Highlighted

Re: PNP on trunkports

Adam,

That is not a option... Command doesn't exist on the 1941 with EHWIC-D-8ESG-P:

ROUTER1941(config)#int G0/1/6

ROUTER1941(config-if)#switchport mode ?

     access          Set trunking mode to ACCESS unconditionally

     dot1q-tunnel Set trunking mode to TUNNEL unconditionally

     trunk             Set trunking mode to TRUNK unconditionally

Maybe it won't be possible with the current hardware setup?

Stefan

Highlighted
Cisco Employee

Re: PNP on trunkports

yes.  that was my concern.  I am not sure we have tested the ether switch modules downstream to another switch.

I know we have tested a router port down to another switch.

Let me do some digging.

Highlighted
Cisco Employee

Re: PNP on trunkports

Stefan,

Chatted with Adam offline. Can you do "show int G0/1/6 switchport" too on 1941 and show us the output? It looks like switch module does not do dynamic trunking protocol (DTP).  Just want to confirm.

If DTP is off, your switch will be in access mode. Then STP could be the factor here to block VLAN 999 due to type mistmatch (access one side, trunk on the other side).

Highlighted

Re: PNP on trunkports

Hi Peng Xu,

Here is the output requested:

interface GigabitEthernet 0/1/6

switchport trunk native vlan 999

switchport mode trunk

no ip address

ROUTER1941#show int G0/1/6 switchport

Name:Gi0/1/6

Administrative mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: Disabled

Access Mode Vlan: 0 ((Inactive))

Trunking Native mode VLAN: 999 (Trunk)

Trunking VLANs Enabled: ALL

Trunking VLANs Active: 1,3,21,29,33,900,920,990,999

Protected: False

Priority for untagged frames: 0

Override vlan tag priority: FALSE

Voice Vlan: none

Correct I can't set the Gi0/1/6 port in dynamic.

Friendly greets from Belgium,

Stefan

Highlighted
Cisco Employee

Re: PNP on trunkports

Thanks, Stefan. That confirms what we thought. Right now, our smart install macro in switch does not handle the scenario when DTP is off. It relies on DTP to decide what is mode the port should be and macro will kick off the configuration as access or trunk accordingly. We need to enhance the capability to handle DTP off scenario like this.

I know NIM module on ISR4K supports DTP, so you will not have issues there. For this switch module on ISRG2, maybe we can try to upgrade it to latest release, which may support DTP and surprise us, :-).  BTW, it is hard for me to find the module like that, otherwise I will give it a shot.

Highlighted

Re: PNP on trunkports

Hi Peng Xu,

Thx for the support so far

With the install macro on the downstream switch you now create a access port on the connected port to the upstream device. Is there an option you change this to a trunk port? In that case the vlan (from the command pnp startup-vlan xxx) gets created, will pass the trunk and will get a DHCP address and will continu with PNP.


Stefan

Cisco Employee

Re: PNP on trunkports

Hi Stefan,

Unfortunately, today the macro is hidden from users. We should add the intelligence in the future when DTP is off, if we see multiple do1q BPDUs, we should know it is statically set to trunk on uplink. Then we should set the new switch port as trunk and problem will be resolved. That is matter of how to implement and when, :-).

Regards,

Peng

Content for Community-Ad
FusionCharts will render here
This widget could not be displayed.